•   
  • 1
  • 3
  • 4
  • 5
  • 6
  • 7(current)
Solved Stuttering unless OSD is on
#91
(2018-05-09, 22:05)beeswax Wrote: Popy, I raised this issue in the Windows subforum here, as this is the Linux section you might want to try posting in that thread.  I thought it was really strange that nobody else chimed in because having experienced the problem on hardware ranging from a NUC i3 Intel GPU through to 5820k/1080Ti systems, it clearly affects a broad range of hardware.
Thx for the hint. Didn't realized that this is the Linux section. Just goggled the thread and posted

Will post in the windows thread tomorrow.

pOpY
Reply
#92
I struggled this problem sometime and I believe I found the solution but it is possible it is only my case. I had stuttering unless OSD is on several days after updating Kodi to 17. I checked many parameters with no result. Deep debugging shows that Kodi uses OpenGL libraries and there was the problem. I use usual Intel videocard which uses i915 driver so OpenGL works thru MESA. glxinfo said:
Code:
direct rendering: No
OpenGL version string: 1.4 Mesa 17.2.3
I was pretty surprised. Why 1.4 and where is DRI? The answer is here. Intel driver i915  by default drops GL version to 1.4 and make it adequate is quite tricky: you have to add next lines to /etc/drirc 
Code:
<driconf>
...
    <device driver="i915">
        <application name="all">
            <option name="stub_occlusion_query" value="true" />
            <option name="fragment_shader" value="true" />
        </application>
    </device>
...
</driconf>
and reboot. The problem solved - no more stuttering.

WARNING #1: If you have Optimus and use i915 instead of nvidia make sure that while nvidia is not used OpenGL uses proper GL, GLX and DRI libraries. It could be checked by ldd /usr/bin/glxinfo. The output must not contain nvidia's GL, GLX and DRI libraries.

WARNING #2: For smooth playing some videos Kodi may require enabling of MESA VA-API MPEG4 support which is disabled by default. You could turn it on by setting environment variable VAAPI_MPEG4_ENABLED=1
Here is full list of environment variables of MESA.
Reply
#93
This issue seams fixed for 1080p and 720p Mkv files and TV streams from my Ceton 6 tuner card via ServerWMC for the May 27th nightly! Thank you so much for resolving this bug, devs! I am running with DXVA2 on via my R9 270 graphics, windows 7 x64 HTPC.

http://mirrors.kodi.tv/nightlies/windows...er-x64.exe
Reply
#94
i still have this problem. my dirty workaround is to display a very small FPS overlay in the right upper corner of the screen with rivatuner. -> no stuttering, same like OSD on. i hope someday a good nightly will fix this.
Reply
#95
I've gone back to a feb nightly for now to get past this problem...
Reply
  •   
  • 1
  • 3
  • 4
  • 5
  • 6
  • 7(current)
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Stuttering unless OSD is on00