Thread Rating:
  • 0 Vote(s) - 0 Average
Impossible to resume or seek within an m2ts-file
#1
I am having issues with the playback of the main movie file of the movie "Erlösung". Its the original m2ts-file from the original BD without any modification. If i try to resume nothing happens, when i try use seek the buffering icon of estuary appears, get filled, then disappears, then appears and gets filles once again and so on, but playback never starts. Within VLC navigation is working fine.The described behaviour is common to all kodi version i tried: latest V18 build from milhouse, older V17 builds from milhouse, official V17 libreelec, KODI V17 on windows, libreelec V17 on windows and raspberry. Thats why i believe it has something to do with the new videplayer or am i wrong?

Logfiles
Reply
#2
you are wrong. demuxer cannot find the index and then there is no seeks. nothing to do with the 'new video player', ffmpeg is used for demuxing as it always has been.
vlc has its own demuxer so it doesn't compare and i assume it's building an estimated index on avg or the likes bitrate.

scratch that index claim. i didn't realize you were playing the bd and not the m2ts as you claimed. the seeks should be possible then, the data come from the bd indices. funky.
Reply
#3
Could you please try to
a) play the bd from a local source
b) play the main title directly, not using the menu
Reply
#4
First thanks for trying to help!

Sorry, i did attach the wrong log file. If I try to play just the .m2ts file it's also not possible to resume or to seek:
Logfile m2ts-file

p.s.: Beside VLC I also tried windows media player which has no issues with seeking too.
Reply
#5
maybe I have fixed this already on this branch: https://github.com/FernetMenta/kodi-agil...aster/xbmc
Reply
#6
Hi FernetMenta,

just wanted to compile your git version on Ubuntu 16.04. following the readmes, but configure stops with the following error:

config.status: error: cannot find input file: `xbmc/addons/binary/interfaces/Makefile.in'

Any idea what I'm doing wrong?
Reply
#7
(2016-12-15, 01:20)mule1 Wrote: Any idea what I'm doing wrong?

Don't use autotools
Reply
#8
Sorry for the late answer!
Yesterday i compiled your latest git master. I'm sorry to say that the issue still exists. Anything i can do to support you to find the cause?
Reply
#9
As I said earlier, please try to play the file and the disc folder from a local source, just to rule out problems on the nfs side.
Reply
#10
Hi Ace,

thanks for trying to help. I just tried to play the same file/folder back from a USB stick plugged into my kodi NUC, but with the same issues: No skipping or resuming possible.
Reply



Impossible to resume or seek within an m2ts-file00