Kodi 16 - [SOLVED] Global Search dependency fails

  Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
WelshPaul Offline
Fan
Posts: 388
Joined: Mar 2013
Reputation: 7
Location: English Countryside
Post: #1
Unfortunately v17 of Kodi proved unusable on our Fire TV (failing to prevent FTV going to standby and lots of videos playing with black screen). So, to prevent complete family Christmas melt-down I had to revert to v16. To do this I had to completely uninstall Kodi then re-install v 16. Everything added back fine except for the Transparency! skin. Firstly, installation of the skin failed with a 'dependency not met' message. When I checked the log it stated:

Quote:CAddonInstallJob[skin.transparency]: failed to install dependency script.globalsearch

I then tried to install Global Search independently as a program addon to get around the problem, and this threw up the error:

Quote:CAddonInstallJob[script.globalsearch]: could not read addon description of special://home/addons/script.globalsearch

I'm wondering if it's trying to install the v17 code, but I don't know how to access the Jarvis Repository if it isn't automatically finding the correct version.

Is there anything I can do, as we'd very much like to return to the world as it was pre-Krypton, though ideally without Trump or Brexit.
(This post was last modified: 2016-12-31 21:54 by WelshPaul.)
find quote
ronie Offline
Team-Kodi Member
Posts: 13,165
Joined: Jan 2009
Reputation: 391
Post: #2
if you download the globalsearch .zip from our repo here:
http://mirrors.xbmc.org/addons/jarvis/sc...-6.0.6.zip

you should be able to install it in kodi using the 'install from zip' option.

Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ and Search the forum before posting.
For troubleshooting and bug reporting please make sure you read this first.
find quote
WelshPaul Offline
Fan
Posts: 388
Joined: Mar 2013
Reputation: 7
Location: English Countryside
Post: #3
Thanks Ronie, but unfortunately the same thing happens. It's showing this:

Code:
11:10:15 T:18446744072503202000   DEBUG: CAddonInstaller: installing from zip '/sdcard/script.globalsearch-6.0.6.zip'
11:10:16 T:18446744072513227600   ERROR: static bool XFILE::CDirectory::Create(const CURL&) - Error creating /storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/script.globalsearch/resources/skins/Default/720p
11:10:16 T:18446744072513227600   ERROR: static bool XFILE::CDirectory::Create(const CURL&) - Error creating special://home/addons/script.globalsearch/resources/skins/Default/720p
11:10:16 T:18446744072513227600   ERROR: static bool XFILE::CDirectory::GetDirectory(const CURL&, CFileItemList&, const XFILE::CDirectory::CHints&, bool) - Error getting /storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/script.globalsearch/resources/skins/Default/
11:10:16 T:18446744072513227600   ERROR: static bool XFILE::CDirectory::GetDirectory(const CURL&, CFileItemList&, const XFILE::CDirectory::CHints&, bool) - Error getting special://home/addons/script.globalsearch/resources/skins/Default/
11:10:16 T:18446744072513227600   ERROR: CAddonInstallJob[script.globalsearch]: could not read addon description of special://home/addons/script.globalsearch

I've installed other addons (script.cu.lrclyrics) with no problem. Of course this is in no way urgent, so please don't spend any of your holiday time on this.
find quote
WelshPaul Offline
Fan
Posts: 388
Joined: Mar 2013
Reputation: 7
Location: English Countryside
Post: #4
Seems to have been a problem with my Fire TV. I did a factory reset of the FTV and was able to choose Transparency as our skin again. Phew!
find quote