Deinterlacing settings
#1
Hi,

I have an odd issue with live tv (dvb-t uk tvheadend) that causes judder when set to auto, its like its switching between on/off every few seconds. The easy solution for this is to set it to default on for all video.

This means though that when I play a blu ray rip etc its going to be set with deinterlacing on. Is this going to cause any issues such as judder, blur etc or will kodi simply not attempt to deinterlace them evem though its set to on?

I know its a minor thing but it would be nice to not have to switch settings everytime I change from live tv to stored media. Any suggestions on the best way to handle this?
Reply
#2
No Debug Log no issue. This is a support forum ...
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#3
(2016-12-27, 16:43)fritsch Wrote: No Debug Log no issue. This is a support forum ...

What do you want a debug log of? Judder in love tv when set to auto, a blu ray rip with deinterlace on or something else?

To be honest I dont see how a debug log helps for the main question of what kodi does with deinterlacing switched on for non interlaced video.
Reply
#4
Debug logs can tell the devs all sorts of things which as a none-developer (I assume?) you wouldn't know about. In this case however, a debug log would also fill in some of the massive blanks in your OP regarding your basic setup and usage.
Reply
#5
I don't even know (!) which GPU / hwaccel you are using ... not even which platform. Deinterlacers highly depend on the hw / sw platform used ...
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#6
I think you are missing the point though. He asked, if a video doesn't need to be deinterlaced and the flag is set to always deinterlace, does it effect anything. In other words, is it ignored if the video isn't interlaced to begin with.

How does a debug log help that? I understand you are trying to fix the live tv thing, but he's asking about the other part.
Reply
#7
a) The "Auto" setting is gone in v17.
b) Yes it will obviously cause issues, cause what result would you expect when forcing a deinterlacer on progressive content? There is basically exactly one "Deinterlace" that is adaptive, e.g. does nothing if you send a frame into it, that is the yadif deinterlacer.

Best way to handle this: Upgrade to v17 and see if our new way of auto detecting interlaced content helps. Else - a Debug Log is mandatory - as there is no possibility anymore to force Deinterlace to "On" in upcoming v17. And in general: if tvheadend sends content that is interlaced, but "Auto" does not detect that properly, the root cause needs to be fixed.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#8
Here you go. Its the VAAPI motion adaptive/compensated ones that I use. The only thing that I can see with forcing on is that it dups then skips the frames. Whether its done something to those frames I do not know.

http://s000.tinyupload.com/index.php?fil...4653851823
Reply
#9
This is a better log I could observe the issue properly and with the debug overlay I can see it switching back and forth between 25/50 fps.

http://s000.tinyupload.com/index.php?fil...7387398093
Reply
#10
Can you try v17 if everything is working correctly now? For v16 I don't have a solution (besides going through every PVR channel and setting Deinterlace to On) as kodi saves that per video.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#11
(2016-12-28, 12:52)fritsch Wrote: Can you try v17 if everything is working correctly now? For v16 I don't have a solution (besides going through every PVR channel and setting Deinterlace to On) as kodi saves that per video.

I didnt want to update to v17 until libreelec had a stable build. Last time I tried the beta it screwed up a bunch of things and it took hours to revert and reconfigure things.

If i set it to on for every channel does that save it even after clearing livetv/epg data, have to do that occasionally.
Reply
#12
(2016-12-28, 12:52)fritsch Wrote: Can you try v17 if everything is working correctly now? For v16 I don't have a solution (besides going through every PVR channel and setting Deinterlace to On) as kodi saves that per video.

Updateed to libre 7.90.10 (beta 7 i think). Deinterlacing appears to be ok after a short test but my general cpu usage has sky rocketed 20-30% idle, 30-60% playback on an i3 6100. Its enough to bottleneck and is causibg my ambilight clone to get choppy Sad. Looks like another revert, going to give it a few hours just in case its doing something crazy in the background.
Reply
#13
Do you by chance have forced "Prefer VAAPI Render Method" to off?

As said above: no one can help you without a Debug Log. But good the original issue is gone.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#14
(2016-12-28, 18:30)fritsch Wrote: Do you by chance have forced "Prefer VAAPI Render Method" to off?

As said above: no one can help you without a Debug Log. But good the original issue is gone.

I will have a check and upload a debug log just wanted to check settings and give it a few hours in case its taking a while background updating things.
Reply
#15
(2016-12-28, 18:30)fritsch Wrote: Do you by chance have forced "Prefer VAAPI Render Method" to off?

As said above: no one can help you without a Debug Log. But good the original issue is gone.

Here you go, logs a bit overkill but everytime the cpu usage spikes to over 50% it makes boblght lock up and miss frames. Prefer vaapi is on but vdau off but try toggling it on and it didnt iimprove.

http://s000.tinyupload.com/index.php?fil...5940525678
Reply



Logout Mark Read Team Forum Stats Members Help
Deinterlacing settings0
This forum uses Lukasz Tkacz MyBB addons.