v17 TVHeadend HTSP add-on error : "Server version is not compatibile"
#1
Question 
TVHeadend PVR Client (3.4.12) reports error : Server version is not compatible.

From client side I'm using Kodi 17 (Krypton), but from server side I'm using TVHeadend v.3.9.636.

What is wrong TVH add-on or TVH server?
Reply
#2
Um. Not sure what version you are using. For Krypton, current HTSP client is 3.4.10, which is required for beta 7 and later. Earlier versions of Krypton can use 3.4.9. 4.0.0 is the development version of the addon for Kodi 18/L*.

Nowhere in the pvr.hts repository do I see version 3.4.12.

However, current stable Tvheadend is 4.0.3. Development is 4.1.x. I would recommend upgrading your Tvheadend installation. Also, check your version numbers again ...
Reply
#3
Please correct me if I'm wrong, from your reply I understood that for KODI_17 is required TVH server version above 4.* - Right?

TVHeadend PVR Client v.3.4.12 is from Windows 10 App KODI 17 which is available from Windows Store.
Reply
#4
3.9 is too old, you need at least 4.0.
Reply
#5
Yes, I just saw that versions of the HTSP PVR addon above 3.4.10 (meaning, 3.4.11–13) were just translation additions/fixes, but that the code hasn't changed since 3.4.10.

However, it looks like ksooo answered the question more fully: To use Tvheadend with Kodi >= 17, your Tvheadend must be at least 4.0—Tvheadend 3.9.x and earlier is not supported in Kodi any longer.
Reply



Logout Mark Read Team Forum Stats Members Help
TVHeadend HTSP add-on error : "Server version is not compatibile"0
This forum uses Lukasz Tkacz MyBB addons.