Kodi 17 - Movies get wrong year since Kodi 17

  Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
jobinoy Offline
Junior Member
Posts: 2
Joined: Dec 2016
Reputation: 0
Exclamation  Movies get wrong year since Kodi 17
Post: #1
I don't know if this is a skin, kodi or scraper issue.

In Kodi 16, when i scraped my movies with themoviedb they were scraped correctly.
When i build up the library fresh in Kodi 17, the movies get recognized correctly, but in the library the year (first aired date in Estuary Skin) is in more than half of the movies 1969 instead the correct year.

this happens on different devices and in all recent builds of Kodi 17.

It does not happen in Kodi 16.

I supect it to be a skin problem... but do not have any proof...

Do others see the same problem occuring?

Screenshot: https://1drv.ms/i/s!AmXLdQf5bdlFq-VmrcwXH1nPSG8eOw
find quote
jobinoy Offline
Junior Member
Posts: 2
Joined: Dec 2016
Reputation: 0
Post: #2
Adding two things:

1. I changed the skin to Confluence and the problem was still there.

2. When you refresh the information for a single movie and ignore locally stored information it gets the year correct.

but doing every single movie out of 300 is a lot of work just to correct the year... Wink
find quote
freshmilk Offline
Junior Member
Posts: 5
Joined: Jan 2013
Reputation: 0
Post: #3
No solution but I have the same issue with a lot of movies marked as from the year 1906. All the others seem to be OK but can tell for sure. Makes no difference using TMDB or Universal Scraper and the only fix is manually refreshing each movie impacted.

Hope there is a fix
find quote
rschwarz_jr Offline
Junior Member
Posts: 16
Joined: Mar 2007
Reputation: 0
Post: #4
I just noticed the same problem. Mine either have the correct date or 1906. Refresh fixes the problem.
find quote
rschiks Online
Donor
Posts: 1,801
Joined: Feb 2013
Reputation: 33
Post: #5
Why not opening a ticket?

http://trac.kodi.tv

Get Kyra for Kodi 2 here
Get Kyra for Kodi here
Get Kyra for Trakt here
find quote
michamicha Offline
Junior Member
Posts: 2
Joined: Mar 2017
Reputation: 0
Post: #6
Same problem here, anyone found a solution?
find quote
snorrelo Offline
Junior Member
Posts: 1
Joined: Mar 2017
Reputation: 0
Post: #7
I'm not sure if it is a bug or not, but it seems like it.

I have gotten a few of these, and for me it seems to be related to movies that have accompanying .nfo files which Kodi can use before scraping websites.
It looks like I get 'year'->1969 and 'premiered'->1969-12-31 if Kodi can't parse the 'premiered' tag in the file into a proper date. Even if the 'year' tag is correct.

This:
<movie>
<year>2016</year>
<premiered>6 Jan 2017</premiered>
</movie>
gives me the wrong data. Year -> 1969, Premiered -> 1969-12-31

This:
<movie>
<year>2016</year>
<premiered>2017-01-06</premiered>
</movie>
gives me the wrong year. Year -> 2017, Premiered -> 2017-01-06

This:
<movie>
<year>2016</year>
</movie>
gives me the correct year, and naturally no premiere date.

Why Kodi would use 'premiered' info for the year at all, if the 'year' tag is present, I have no idea. For many movies, the premiered date would not be the same as the year.

A workaround could be to remove the premiered tag or only have an imdb url in the nfo file to force an online lookup.
find quote
michamicha Offline
Junior Member
Posts: 2
Joined: Mar 2017
Reputation: 0
Post: #8
(2017-03-19 02:09)snorrelo Wrote:  I'm not sure if it is a bug or not, but it seems like it.

I have gotten a few of these, and for me it seems to be related to movies that have accompanying .nfo files which Kodi can use before scraping websites.
It looks like I get 'year'->1969 and 'premiered'->1969-12-31 if Kodi can't parse the 'premiered' tag in the file into a proper date. Even if the 'year' tag is correct.

This:
<movie>
<year>2016</year>
<premiered>6 Jan 2017</premiered>
</movie>
gives me the wrong data. Year -> 1969, Premiered -> 1969-12-31

This:
<movie>
<year>2016</year>
<premiered>2017-01-06</premiered>
</movie>
gives me the wrong year. Year -> 2017, Premiered -> 2017-01-06

This:
<movie>
<year>2016</year>
</movie>
gives me the correct year, and naturally no premiere date.

Why Kodi would use 'premiered' info for the year at all, if the 'year' tag is present, I have no idea. For many movies, the premiered date would not be the same as the year.

A workaround could be to remove the premiered tag or only have an imdb url in the nfo file to force an online lookup.

Thanks. Have not checked if it works, but cp has an option to create a nfo file with only the imdb URL inside.
find quote
JumperJeff Offline
Junior Member
Posts: 11
Joined: May 2011
Reputation: 0
Post: #9
I noticed the same problem. I'll try removing the Premier tag and see what happens.
find quote
freshmilk Offline
Junior Member
Posts: 5
Joined: Jan 2013
Reputation: 0
Post: #10
Confirm the conclusion on Premier Date. The movies that are tagged with the incorrect year all had premier dates in the nfo file.

My fix was to delete all nfo's (good and bad) and rescan from scratch. That seemed the best way to fix 300+ incorrectly tagged movies.
find quote
Fayne Offline
Junior Member
Posts: 1
Joined: Apr 2017
Reputation: 0
Post: #11
I have had this same issue. I do not know if it is completely connected to nfo files because I've tried a folders that contained only a video file. For me, I've only had issues with movies from 1900 and before, they are all listed as 1969.

I have not had an issue with 1906 movies or anything in between.

I really think this is worth looking into, seems to be a persistent problem, I haven't had a single movie from the year 1900 loaded properly.

Does anyone have any new or useful information?
find quote
dougsmith353 Offline
Junior Member
Posts: 1
Joined: May 2017
Reputation: 0
Post: #12
What version of kodi did you use to get the correct years without premier when you rescanned?

Sent from my SM-N910W8 (typie typie)
find quote
Jelf10 Offline
Junior Member
Posts: 42
Joined: Nov 2013
Reputation: 0
Post: #13
Also have had this problem.
I used to use couchpotato to fetch the metadata for kodi until they started showing as 1969. Turned it off and just let the universal scraper do its job and it's been ok since.
So not sure if it's kodi that's at fault.
find quote