Beta Advanced MAME Launcher - MAME frontend for Kodi
#48
(2018-02-17, 03:14)Kel_Sceptic Wrote: Can you please tell me what causes this behavior when I try to Context menu > Setup plugin > "Build Database".
XUbuntu 16.04.3
M.A.M.E. v0.160 (Mar 31 2015)

...
The version of MAME you are using is too old. Somewhere around MAME 0.180 (I don't recall which version exactly) the MAME team did some changes in the MAME XML. Among other stuff, they changed the tag <game> by <machine>. Because AML only understands the latter hence the crash. Can you please update MAME to 0.189 using Cesare Falco's PPA? Substitute YOUR_UBUNTU_VERSION_HERE by xenial.

AML will be released soon (2, 4, 6 weeks...) and if you cannot update MAME (please tell me why you cannot) I can give support for MAME 0.160. In any case, AML 0.9.4 will include a numerical MAME version that will raise a WARNING (please update your MAME version) and won't crash.
Reply


Messages In This Thread
RE: Advanced MAME Launcher - MAME frontend for Kodi - by Wintermute0110 - 2018-02-17, 11:43


Logout Mark Read Team Forum Stats Members Help
Advanced MAME Launcher - MAME frontend for Kodi2
This forum uses Lukasz Tkacz MyBB addons.