Android Cannot access SMB shares on Windows 10
#40
(2018-06-09, 06:40)Dejabloo Wrote: I dont have a problem with moving away from SMB1, as soon as I find something that works.

So now I have installed Leia, but I am still having problems. I am getting an 'operation not permitted' msg. Do I need to do anything to turn on SMB2 support in Leia?

Same here, trying to get a SMB share added on 18.4 on an Android phone. Following this thread's various steps, I get "operation not permitted". I first tried adding SMB1 to the Windows 10 box and using legacy security, but that would time out when trying to access the share with the username and password. I double checked that I'm using the right username and password (Edit: see below). Now I'm trying with SMB2/3, manually adding the share as suggested, but I get "operation not permitted". I've also tried using the server's IP address rather than the server name, but that still doesn't work. I also checked .kodi/userdata/passwords.xml to make sure the information was correct. I also tried accessing a SMB share that does not have spaces in the path, and this gave me the same error, so that is also ruled out.

Edit: Nevermind. It looks like a Windows Update possibly changed the nature of the "Guest" account that I was using to login to the SMB share? That, or something related to this changed. I found that it was disabled under Computer Management, and enabling it fixed the problem. According to the following, the Guest account is now treated differently, not sure when this changed, but I should probably come up with a different account to handle this, anyway: https://www.howtogeek.com/280527/how-to-...indows-10/
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average


Messages In This Thread
RE: Cannot access SMB shares on Windows 10 - by mmortal03 - 2019-11-23, 23:01


Logout Mark Read Team Forum Stats Members Help
Cannot access SMB shares on Windows 1000