•   
  • 1
  • 130
  • 131
  • 132
  • 133(current)
  • 134
  •   
Android nVidia Shield TV (2015 & 2017 Models) - UPDATED: May 25, 2018
(2020-01-08, 01:05)lartomar2002 Wrote: With the 18.5 update I can not change the audio output device setting to android raw or EAC 3 or change audio pass through. I can change all the other settings such as number of speakers 7.1 and the codecs that my Samsung soundbar HW-K180 supports with wireless rear speakers and that supports Dolby Atmos. But, with 18.5 I have not been able to get any Dolby Atmos sound through my sound system. Are the setting different for 18.5 or is this a bug between Kodi and the Shield?

Kodi never had this feature. Whatever you had before was not official kodi. Though, there is some hope for you as I have implemented this feature and PRd it to kodi. Sadly no reaction until now, if it's wanted in kodi. I include it in my fritschfiretv test versions - install that if you need this feature.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
(2020-02-02, 06:38)fritsch Wrote:
(2020-01-08, 01:05)lartomar2002 Wrote: With the 18.5 update I can not change the audio output device setting to android raw or EAC 3 or change audio pass through. I can change all the other settings such as number of speakers 7.1 and the codecs that my Samsung soundbar HW-K180 supports with wireless rear speakers and that supports Dolby Atmos. But, with 18.5 I have not been able to get any Dolby Atmos sound through my sound system. Are the setting different for 18.5 or is this a bug between Kodi and the Shield?

Kodi never had this feature. Whatever you had before was not official kodi. Though, there is some hope for you as I have implemented this feature and PRd it to kodi. Sadly no reaction until now, if it's wanted in kodi. I include it in my fritschfiretv test versions - install that if you need this feature. 
My soundbar supports dts-hd but does not announce it properly to my shield so it does not show up as available in nvidia shield hdmi settiing and when I enable dts-hd in normal kodi the dts-hd stream was not getting passed through and I was getting not getting any sound. With the raw audio option in your build I got back dts-hd playback. Thanks for this I hope your pr gets added to kodi.
Reply
Yeah - under the hood if you select DTS-HD with RAW, Android will just extract the core if the output device does not support DTS-HD-MA. You can have the same effect by running IEC version and just disable DTS-HD :-)
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
(2020-02-03, 21:50)fritsch Wrote: Yeah - under the hood if you select DTS-HD with RAW, Android will just extract the core if the output device does not support DTS-HD-MA. You can have the same effect by running IEC version and just disable DTS-HD :-)

I was running it like that before with dts-hd disabled so Kodi was sending the dts signal. Now Kodi is sending the dts-hd signal if Android is stripping I can't tell as my sound bar is the xiaomi tv 4. And unless you use its internal player you can't tell whats sound format is being played. From what I was able to translate it does support dts-hd and when playing a dts-hd file in its internal player it plays fine. It is just a sound bar though so dts or dts-hd doesn't sound different to my ears anyway. It's just I wanted to confirm if my sound bar supports dts-hd or not.
Reply
(2020-02-02, 06:36)fritsch Wrote: No permission to write to your storage. Fix the permissions properly.

Thanks :-)
Didn't found how to that easy, but an reinstall solved it:-)

BTW, is anyone get Shields screensaver to kick in?
Tried with all the Kodi screensavers, but nothing let the Shields screensaver to kick in.
Petter :-)
Many thanks for all the effort YOU all do! THANKS! :-)
nVidia Shield TV, Samsung QE75Q70R and Yamaha RX-V767
Reply
Getting tons of HD audio dropouts again with the latest Kodi Leia nightly on my 2017 Shield.

Very frustrating. Everything updated, etc.
Reply
(2020-02-13, 00:47)Wagg Wrote: Getting tons of HD audio dropouts again with the latest Kodi Leia nightly on my 2017 Shield.

Very frustrating. Everything updated, etc.

THis is what an nvidia shield dev had to say about this recently

Code:
A quick update on the issues in this thread. This report turned out to be 2 issues: 1. Random drops (replay the video and they don't repeat) 7.2 introduced some random audio drops with high latency networks which were addressed. 8.0 also added some random drops which was fixed in 8.0.2 2. Fixed location drops (replay the video and they repeat at the same location). This was due to an open source audio decoder SHIELD is using which has limited bandwidth and can only support audio below a certain bandwidth, above which droptouts happen. We have a fix for this now which I've been testing which solves this issue. We plan to include this fix in the next HotFix images for both 2015/2017 and 2018 devices. Note that the fix in #2 applies only to apps that use SHIELDs inbuilt audio support. Kodi has it's own and is subject to the same bug as SHIELD had so a fix in Kodi will be needed (we are working with them on this). So, when this fix comes, it'll work in Plex, the inbuilt photos & videos app in SHIELD and other apps which rely on SHIELDs audio support.
Reply
Sad 
Hi,

I have tested shield TV 2015, 2017 and now latest 2019 (tube version)
And once again, I guess I'm going to sell it less than 2 weeks after buying it ! Sad

With the 2015 and 2017 modesl, the main grief was poor upscaling and lip sync issue.
Now the upscaling is damn good, but the lip sync issue remains !

My others kodi players (rpi2, rpi3, odroid C1+ and c2, all running libreelec/coreelec) have perfect audio sync on my system. (FHD TV + sterero amp using TV optical out)
Tested on the same HDMI input and cable.

I have made ABX tests between my players, and the shield it clearly identifiable.
The audio delay is not huge (between 50 and 150ms) but definitively noticeable.
It's variable and seems to depend both on audio codec and video settings (refresh rate, interlaced, codec)

Maybe I missed a setting in the shield or kodi parameters ?
Reply
(2020-02-13, 17:10)mika91 Wrote: Hi,

I have tested shield TV 2015, 2017 and now latest 2019 (tube version)
And once again, I guess I'm going to sell it less than 2 weeks after buying it ! Sad

With the 2015 and 2017 modesl, the main grief was poor upscaling and lip sync issue.
Now the upscaling is damn good, but the lip sync issue remains !

My others kodi players (rpi2, rpi3, odroid C1+ and c2, all running libreelec/coreelec) have perfect audio sync on my system. (FHD TV + sterero amp using TV optical out)
Tested on the same HDMI input and cable.

I have made ABX tests between my players, and the shield it clearly identifiable.
The audio delay is not huge (between 50 and 150ms) but definitively noticeable.
It's variable and seems to depend both on audio codec and video settings (refresh rate, interlaced, codec)

Maybe I missed a setting in the shield or kodi parameters ?
In the Settings options, select Device Preferences→Display & Sound→Advanced sound settings→Audio video sync
Reply
In kodi's master branch or in my fritschfiretv builds a new sync method is integrated. This uses a more up2date syncing mechanism. Backport to Leia sadly not possible cause of the non-standard-firmware we still support in Leia and already dropped in Matrix.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
(2020-02-14, 06:38)psyburr Wrote:
(2020-02-13, 17:10)mika91 Wrote: Hi,

I have tested shield TV 2015, 2017 and now latest 2019 (tube version)
And once again, I guess I'm going to sell it less than 2 weeks after buying it ! Sad

With the 2015 and 2017 modesl, the main grief was poor upscaling and lip sync issue.
Now the upscaling is damn good, but the lip sync issue remains !

My others kodi players (rpi2, rpi3, odroid C1+ and c2, all running libreelec/coreelec) have perfect audio sync on my system. (FHD TV + sterero amp using TV optical out)
Tested on the same HDMI input and cable.

I have made ABX tests between my players, and the shield it clearly identifiable.
The audio delay is not huge (between 50 and 150ms) but definitively noticeable.
It's variable and seems to depend both on audio codec and video settings (refresh rate, interlaced, codec)

Maybe I missed a setting in the shield or kodi parameters ?
In the Settings options, select Device Preferences→Display & Sound→Advanced sound settings→Audio video sync
 
Hi,
The first thinkg I did when receiving the shield was to set the delay to 0ms (default 50ms)
So you suggest to set it to 50 ms ?
Reply
(2020-02-16, 21:03)fritsch Wrote: In kodi's master branch or in my fritschfiretv builds a new sync method is integrated. This uses a more up2date syncing mechanism. Backport to Leia sadly not possible cause of the non-standard-firmware we still support in Leia and already dropped in Matrix.

OK.
You make builds for the shield too? or only for firetv ?
Marix is usable or still very buggy ?
Thanks
Reply
The name is my branch name. They have nothing firetv special. Alle that work went into matrix already.

The only difference: it's Leia based, cause in my private builds I can just drop legacy support which modern devices don't need. That's the reason it did not go into Leia itself, we cannot just drop amlogic support for 5 year+ old boxes. Imagine the whining...
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
Ok.
I've try your build this morning, and still have to delay around 100ms ahead.

One strange thing is that system shield audio delay is not active during Kodi playback.
No matters I set 500ms or 0ms with the bouncing ball, the audio delay is not changed during Kodi playback.
Reply
Not sure your experience can be generalized. There are some measurements with professional equipment somewhere in this forum which had different results. But yeah, does not change the fact that it does not work for you.

Btw. do you have this delay everywhere? Youtube app and others as well?
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
  •   
  • 1
  • 130
  • 131
  • 132
  • 133(current)
  • 134
  •   
 
Thread Rating:
  • 8 Vote(s) - 3.38 Average



Logout Mark Read Team Forum Stats Members Help
nVidia Shield TV (2015 & 2017 Models) - UPDATED: May 25, 20183.388
This forum uses Lukasz Tkacz MyBB addons.