Solved 1080p 2D Not playing in Full Resolution
#1
All my 2D 1080p/720p files are not playing in full resolution, they are been display with small black bars of the left and right side of the screen,3D 1080p file display Full resolution.

Here is my Debug log.

Image


Any Help?
MY CURRENT MEDIA PLAYER | MY HOME THEATER
MINIX NEO U22-XJ COREELEC v19 MATRIX | EGREAT A10 | NVIDIA SHIELD | LG 75 NANO90 DV/HDR+ | Sony 43 Android TV HDR
XBOX SERIES X  | PS4 PRO 4K | JBL 9.1 System 5.1.4 DTS:X/ATMOS 
Reply
#2
Have you tried video calibration in both settings>system and in the OSD there is a video calibration while the film is up? Hit the keybaord 'z' a few times to ensure you are in normal mode? Suspect at this point is the scalier and rendering method.
Reply
#3
(2017-01-16, 17:43)PatK Wrote: Have you tried video calibration in both settings>system and in the OSD there is a video calibration while the film is up? Hit the keybaord 'z' a few times to ensure you are in normal mode? Suspect at this point is the scalier and rendering method.

Try all the modes and 2D playback is still displaying with those Black bars, I also try VLC and MPC and those display the proper resolution.

Image
MY CURRENT MEDIA PLAYER | MY HOME THEATER
MINIX NEO U22-XJ COREELEC v19 MATRIX | EGREAT A10 | NVIDIA SHIELD | LG 75 NANO90 DV/HDR+ | Sony 43 Android TV HDR
XBOX SERIES X  | PS4 PRO 4K | JBL 9.1 System 5.1.4 DTS:X/ATMOS 
Reply
#4
If VLC works well, then the big difference between Kodi and VLC is that in VLC they use software rendering by default. Suggestion try software rendering (toggle DXVA) and tell us how that works out.
Reply
#5
(2017-01-16, 23:30)PatK Wrote: If VLC works well, then the big difference between Kodi and VLC is that in VLC they use software rendering by default. Suggestion try software rendering (toggle DXVA) and tell us how that works out.

Try that option and all the other selectable options and still the same results,is there nothing in the debug log that determine why this causing an error?
MY CURRENT MEDIA PLAYER | MY HOME THEATER
MINIX NEO U22-XJ COREELEC v19 MATRIX | EGREAT A10 | NVIDIA SHIELD | LG 75 NANO90 DV/HDR+ | Sony 43 Android TV HDR
XBOX SERIES X  | PS4 PRO 4K | JBL 9.1 System 5.1.4 DTS:X/ATMOS 
Reply
#6
The issue starts at line 1207, driver issue? Try setting up in full screen border-less windowed mode, see if that works out.
Reply
#7
(2017-01-16, 10:10)movie78 Wrote: Any Help?
First of all, do not use forked version. I know which exactly version you are using Wink Please download the latest nightly/RC from https://kodi.tv/download/
Enable Debug Log via advancedsettings.xml.
Run Kodi in portable mode with default settings.
if the issue still exists provide a Debug Log.

(2017-01-17, 05:53)PatK Wrote: The issue starts at line 1207, driver issue? Try setting up in full screen border-less windowed mode, see if that works out.
just FYI The warning about scaling method isn't an issue at all. it's just a warning that scaling setting has a value which isn't supported by current renderer. In this case renderer selects a default scaling method.
Reply
#8
I actually have this issue with my Sony. It defaults the resolution to 1080P and I get a real pixelated display when going to windowed mode. When I set it back to full screen mode again, the Menu at center is across the entire screen, but the video is small and in the upper left side. I have to fix this by going into Settings and changing the resolution back to 1080i (and for some reason, it doesn't stay if I set to windowed mode again).
I've looked everywhere for the issue and tested my video card and no mention of anything like this. It's a minor inconvenience, so I deal with not going to windowed mode anymore. Hehe.
Reply
#9
Thanks, everyone your help, I did find a temporary fix for now unless there is better solution

The issue happens when I play a 4K file (3820X2160p), once I stop playback Kodi interface shrink with Black Bars on the left and right on the screen, the only way to get the Black Bars disappear and have the proper resolution for 2D playback is to play 3D MVC movie.

So playing a 3D MVC file seems to resolve the Black Bars on Kodi Interface and 2D playback.
MY CURRENT MEDIA PLAYER | MY HOME THEATER
MINIX NEO U22-XJ COREELEC v19 MATRIX | EGREAT A10 | NVIDIA SHIELD | LG 75 NANO90 DV/HDR+ | Sony 43 Android TV HDR
XBOX SERIES X  | PS4 PRO 4K | JBL 9.1 System 5.1.4 DTS:X/ATMOS 
Reply
#10
(2017-01-17, 10:38)afedchin Wrote:
(2017-01-16, 10:10)movie78 Wrote: Any Help?
First of all, do not use forked version. I know which exactly version you are using Wink Please download the latest nightly/RC from https://kodi.tv/download/
Enable Debug Log via advancedsettings.xml.
Run Kodi in portable mode with default settings.
if the issue still exists provide a Debug Log.

(2017-01-17, 05:53)PatK Wrote: The issue starts at line 1207, driver issue? Try setting up in full screen border-less windowed mode, see if that works out.
just FYI The warning about scaling method isn't an issue at all. it's just a warning that scaling setting has a value which isn't supported by current renderer. In this case renderer selects a default scaling method.

Ok my little trick stop working so i install the official RC3 and below is the debug log.


Shrink 2D playback
MY CURRENT MEDIA PLAYER | MY HOME THEATER
MINIX NEO U22-XJ COREELEC v19 MATRIX | EGREAT A10 | NVIDIA SHIELD | LG 75 NANO90 DV/HDR+ | Sony 43 Android TV HDR
XBOX SERIES X  | PS4 PRO 4K | JBL 9.1 System 5.1.4 DTS:X/ATMOS 
Reply
#11
(2017-01-18, 06:14)movie78 Wrote: Ok my little trick stop working so i install the official RC3 and below is the debug log.


Shrink 2D playback
please enable debug logging in advancedsettings.xml I need to see debug from the beginning.
Reply
#12
(2017-01-18, 08:44)afedchin Wrote:
(2017-01-18, 06:14)movie78 Wrote: Ok my little trick stop working so i install the official RC3 and below is the debug log.


Shrink 2D playback
please enable debug logging in advancedsettings.xml I need to see debug from the beginning.


Is this the correct advancesettings.xml?

Quote:<advancedsettings>
<loglevel>2</loglevel> <!-- Change this to "1" to hide the on-screen debug log text -->
<debug>
<extralogging>true</extralogging>
<setextraloglevel>64,1024, 16384</setextraloglevel>
<showloginfo>true</showloginfo> <!-- Change this to "false" to hide the on-screen debug log text -->
</debug>
</advancedsettings>
MY CURRENT MEDIA PLAYER | MY HOME THEATER
MINIX NEO U22-XJ COREELEC v19 MATRIX | EGREAT A10 | NVIDIA SHIELD | LG 75 NANO90 DV/HDR+ | Sony 43 Android TV HDR
XBOX SERIES X  | PS4 PRO 4K | JBL 9.1 System 5.1.4 DTS:X/ATMOS 
Reply
#13
yes it's correct.
Reply
#14
(2017-01-18, 16:12)afedchin Wrote: yes it's correct.

Copy the advancesettings.xml to AppData\Roaming\Kodi\userdata ?

Quote:<advancedsettings>
<loglevel>1</loglevel>
<debug>
<extralogging>true</extralogging>
<setextraloglevel>64,1024, 16384</setextraloglevel>
<showloginfo>false</showloginfo>
</debug>
</advancedsettings>

Is the xml correct?

Thanks!
MY CURRENT MEDIA PLAYER | MY HOME THEATER
MINIX NEO U22-XJ COREELEC v19 MATRIX | EGREAT A10 | NVIDIA SHIELD | LG 75 NANO90 DV/HDR+ | Sony 43 Android TV HDR
XBOX SERIES X  | PS4 PRO 4K | JBL 9.1 System 5.1.4 DTS:X/ATMOS 
Reply
#15
(2017-01-18, 17:26)movie78 Wrote: Copy the advancesettings.xml to AppData\Roaming\Kodi\userdata ?
correct.

(2017-01-18, 17:26)movie78 Wrote: Is the xml correct?
yes, it's correct.
Reply



Logout Mark Read Team Forum Stats Members Help
1080p 2D Not playing in Full Resolution1
This forum uses Lukasz Tkacz MyBB addons.