v17 Weird deinterlace artifacts
#16
Look at fonts on ticker from below. This shot from Kodi15 on 10 year old laptop with onboard radeon hd3200, that has average quality of deinterlacing. Now compare with PRi.
Image
Reply
#17
Я не вижу никаких проблем с этим файлом на своей RPi3. Бегущая строка идёт плавно, никаких необычных артефактов нет. Всё практически так же, как на этом скриншоте.
Reply
#18
А я вижу. Не видел бы, не писал. Всё познается в сравнении Big Grin
Reply
#19
Ну и в чём разница?

Image
Reply
#20
Не, земляк. У тебя 720, у меня 1080. Меньше лучше. Разница есть, её видно.
Reply
#21
1080 - https://s25.postimg.org/y2a3lkw3x/screenshot014.png

Возможно видеокарта делает апскейл до 1080 лучше. Но с деинтерлейсингом на Rpi по-моему всё в порядке.
Reply
#22
(2017-01-23, 17:04)smp1 Wrote: 1080 - https://s25.postimg.org/y2a3lkw3x/screenshot014.png
Но с деинтерлейсингом на Rpi по-моему всё в порядке.
Возможно. У меня дешевый ящик лучше деинтерлейсит на порядок. С русским давай завязывать, а то забанят как разведчиков Smile
Reply
#23
(2017-01-22, 21:19)popcornmix Wrote: Could you test this firmware?
https://drive.google.com/uc?id=0B-6zmEDJ...t=download

It has a fix for the green artefacts.

And this is it popcornmix! Everything looks very good on that firmware. Artefacts are gone and also image quality is better using adv(x2) deinterlacer.
Reply
#24
(2017-01-23, 18:11)Kolabor Wrote: And this is it popcornmix! Everything looks very good on that firmware. Artefacts are gone and also image quality is better using adv(x2) deinterlacer.

Good to hear. Fix will be in next Milhouse build and I'll make sure it gets into next Krypton beta builds.
Reply
#25
Very nice Smile How come nobody reported it before. I think the regression is since build #1119 (new firmware - updates for frambebuffer, debug_sym and deinterlace).
Reply
#26
(2017-01-23, 18:21)Kolabor Wrote: Very nice Smile How come nobody reported it before. I think the regression is since build #1119 (new firmware - updates for frambebuffer, debug_sym and deinterlace).

I believe it started in #1201. I'm surprised no one else has reported it in the Milhouse builds thread.
I don't tend to watch interlaced content (except when a bug is reported), but there are a number of PVR users in Milhouse thread.
Reply
#27
So it was this "firmware: di_adv: Add direct suppport for YUV420"?

Maybe other users are using bob deinterlacer or none? This bug was very annoying.
Reply
#28
(2017-01-23, 19:01)Kolabor Wrote: So it was this "firmware: di_adv: Add direct suppport for YUV420"?

Yes, deinterlace code was restructured to allow use on YUV420 frames (video decoded by ffmpeg) which introduced the problem.
Reply
#29
Which is the best deinterlace method to use? or does auto choose the best one.

Thanks
Reply
#30
(2017-01-26, 18:36)the_bo Wrote: Which is the best deinterlace method to use? or does auto choose the best one.

Auto is the default and recommended.
Reply



Logout Mark Read Team Forum Stats Members Help
Weird deinterlace artifacts0
This forum uses Lukasz Tkacz MyBB addons.