Android Kodi 17 app not installed error..
#1
Question 
M96X Android box. Marshmallow 6.0.1. Download 17 and try and install, does.its thing like it's installing then says not installed. Any suggestions?

TIA - missconduct
Reply
#2
I tried to update kodi today & it just downloads multiple times, then goes into an infinite installing & then a message comes up saying

Error

"Kodi" can't be updated. Try again, and if the problem continues, get help troubleshooting. (Error code: 963)

I've tried installing multiple times, I've restarted my device several times & kept trying & I had also removed my storage device it's installed on & then tried to install a fresh download & it still does the same thing.

My device is: NVIDIA Shield Android TV.
Reply
#3
So no help then?
Reply
#4
The key is in "updated". >>"Kodi" can't be updated<<. Uninstall original Kodi and install.
Kodi addons: Lanik repo
Reply
#5
So 17 is different? Cause I never had to Uninstall before.. sorry noob
Reply
#6
Probably chinese put some customized version of Kodi on your box. If the signature is not the same, it won't install.
Kodi addons: Lanik repo
Reply
#7
Thank you
Reply
#8
I reset my firestick with alexa to factory and while trying to reinstall Kodi 17 Kryton I now keep getting App not installed. I noticed a Kodi 18 Leia available. Is Kodi 17 dead? Please help
Reply
#9
Kodi 17 (Krypton) is the current release.

Kodi 18 (Leia) is the next version, and is currently in the early alpha stage.
| Banned add-ons (wiki) | Forum rules (wiki) | VPN policy (wiki) | First time user (wiki) | FAQs (wiki) | Troubleshooting (wiki) | Add-ons (wiki) | Free content (wiki) | Debug Log (wiki) | Free Movies/TV Shows |
Reply
#10
Sad 
I have an X96 (S905X) box with android (6.01) and kodi 16.1 (jarvis) installed. Tried several times to update to the latest version of Kodi (17 and 17.1) without any success. If I delete Kodi as mentioned on other posts, it will let you install, but all of my customization will disappear. Read several posts here and on the www, but none seems to pinpoint how to get around this.

Would like to update without loosing any customization. Has anyone come up with a tested procedure on how to accomplish this successfully? Please advice.
Reply
#11
Backup your settings (either use the backup add-on in the official repo or just manually copy your .Kodi folder (one level up from your userdata (wiki) folder). Then do your upgrade and restore the backup. All of Kodi settings are in that folder and its sub folders.
| Banned add-ons (wiki) | Forum rules (wiki) | VPN policy (wiki) | First time user (wiki) | FAQs (wiki) | Troubleshooting (wiki) | Add-ons (wiki) | Free content (wiki) | Debug Log (wiki) | Free Movies/TV Shows |
Reply
#12
Hello I'm also trying to upgrade to v17 and I'm getting the same error. I read your post and tried uninstalling v16 then reinstalling v17 and stilll get app not installed. Box is a c96x. Any advice would be greatly appreciated.
Reply
#13
Me too. Having M96X Android box. No lucky installing v17.
Kept... "App not installed."

Any advise...
Reply
#14
I'm having same problem with updating Kodi 17.Lost date and time,and can't fix. Other kodi in second room, works great... How to fix time, when no space for 2017.
Reply
#15
For the next guy = my Mxqpro (chinese) box running android tv I resolved the "App not installed" error by installing the 32-bit version of Kodi 17.1 even though its a 64-bit processor.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Kodi 17 app not installed error..00