[Kodi 17 Krypton] Is there a way to disable game controller support?
#1
Is there a way to disable game controller support on Kodi 17.0 Krypton?

To make it so Kodi does not try to interpret any of the commands from the game controller, and just passes though the mapping that OS already has?

I'm having problems on multiple devices because I believe Kodi is trying to interpret the controller. I believe in Isengard and Jarvis there was a way to shut off controller support, and allow a straight pass though of the OS commands.
I'm having issues on the Nvidia Shield, Steam OS, and Windows 7, when trying to use existing OS mappings that worked properly on Isengard and Jarvis.

The issues range from multiple buttons being recognized as the same button, or being completely unmappable, to having it randomly flip between the OS mapping and Kodi trying to interpret the Controllers.
I have tried disabling the controller support by Disabling Joystick in Peripheral libraries. But this does not resolve the issue.

I am at a loss as what to try next, other than roll back to Jarvis.

Edit: In Windows 7 I have found that if controller goes to sleep or powers off it will loose the OS mappings. Then start acting very strange in the case of the Steam controller or PS4 Controller. If I power off the controller, then power the controller back on it will eventually go back to the OS mappings, and work properly. But it seems random how may attempts it needs. My hypothesis is that a controller pass though would resolve this issue.
Reply
#2
Unfortunately it doesn't look like that you can, what you're looking for is in "My Add-ons -> Game Add-ons -> Controller Profiles -> Default Controller" but Disable is not selectable on my Windows build, maybe different on other OS's though.
Reply
#3
With windows 7 and Steam OS is will not allow me to disable it either. If I edit the XML files or remove them it crashes Kodi on launch.

I will have to wait to try it on the Nvidia Shield.

EDIT: Further investigation of the forums shows a similar problem here: http://forum.kodi.tv/showthread.php?tid=302835
It is described differently,but it sounds like the same root issue.
Reply
#4
Well I just tried the current nightly build Krypton 17.1 RC1 KodiSetup-20170203-ef7766e-Krypton

Unfortunately it did not solve my problem.

I've noted that on Steam OS and Windows 7: if I allow the Steam or PS4 Controllers to go into energy saving mode (power down), When I power them back on for a brief moment they work properly. But then internal mapping software (I'm guessing from Kodi) grabs them and scrambles the buttons and controls. If I force power off the Steam or PS4 Controller, then power the Controllers back on they resume the correct button mapping.

For the Nvidia Shield, since the controllers don't power down all that quickly, I just have to swap Nvidia controller while kodi is on, as I don't know how to force a Nvidia Controller to power off.

I'm betting if there was some way to disable Kodi mapping the controllers this would resolve the issue. Or if there was a way to tell Kodi not to try to configure or map certain controllers or inputs.
Reply
#5
I believe if you go to the add-on browser / my add-ons / peripheral libraries and disable "joystick support" add-on, it will accomplish what you need.

scott s.

.
maintainer of skin  Aeon MQ5 mods for post-Gotham Kodi releases:
Matrix see: Aeon MQ5 Mod Martix release thread
Leia see: Aeon MQ5 Mod Leia release thread
Aeon MQ 5 skin and addon repo
Reply
#6
(2017-02-06, 07:08)scott967 Wrote: I believe if you go to the add-on browser / my add-ons / peripheral libraries and disable "joystick support" add-on, it will accomplish what you need.

scott s.

.

Already tried that, mentioned it in the first post. It does not resolve the issue.
Reply
#7
Was this ever worked out? I am trying to bind a key to Exit using JoyToMe and Project 64 - and it works fine when I launch it from Windows, but if I launch it from Kodi, as the back button is already assigned within Kodi it seems to stop it from working.
Reply
#8
Disabling the Joystick Support add-on should prevent controllers from having any effects in Kodi. Alternatively you can selectively disable XInput or DirectInput controllers. If this is still broke, let me know.
Reply



Logout Mark Read Team Forum Stats Members Help
[Kodi 17 Krypton] Is there a way to disable game controller support?0
This forum uses Lukasz Tkacz MyBB addons.