Thread Rating:
  • 0 Vote(s) - 0 Average
Mac OS X - Cannot open kodi 17 on mac
#16
(2017-02-18, 19:22)oxerife Wrote:
(2017-02-13, 12:53)greenwellington Wrote: Re Smellin contribution:
1) is your Mac account password non-empty?

2) if you're not afraid of losing all your kodi settings you could try deleting the "Kodi" folder in "your_username/Library/Application Support" (or maybe back it up first)

2) Worked for me

2) isn't an option for me as there is no Kodi File created there..(#disturbed) lol
Reply
#17
(2017-02-06, 22:54)kingpin58 Wrote: I just installed Kodi 17 on my mac which is running sierra 10.12.2 It would not allow because it was from a undeveloped website,so I managed to change my gatekeeper to allow it,but when I try to open Kodi.I keep getting error message that kodi quit unexpectedly. I have reinstalled, restarted,and all the obvious things in order to resolve the issue,I even contacted mac,but was unable to find a fix.I had kodi 16.1 jarvis working flawlessly before this,but I removed it,and now I have nothing.Can anyone help me?

I'm having exact same problem on OS X yosemite 10.10.5. I am completely new to this so I don't really know how to do everything with the logs etc. But this is really annoying
Reply
#18
(2017-02-18, 19:22)oxerife Wrote:
(2017-02-13, 12:53)greenwellington Wrote: Re Smellin contribution:
1) is your Mac account password non-empty?

2) if you're not afraid of losing all your kodi settings you could try deleting the "Kodi" folder in "your_username/Library/Application Support" (or maybe back it up first)

2) Worked for me

There doesn't appear to be a Kodi folder in this location. I'm wondering if there are any other fixes anyone has found yet?
Reply
#19
I agree there does not appear to be a Kodi folder in this location.
As nothing was forthcoming on the forum I took the plunge and deleted Jarvis completely and installed Krypton without a problem.
However, be aware that SportsDevil does not appear to function correctly on Krypton
Reply
#20
I got it to work guys. I just went on finder, go to folder and copied and pasted this /Users/<your_user_name>/Library/Application Support/Kodi/userdata and enter (obviously change the your user name to your name) then click on database and then delete addons20 and addons26. Then reopen kodi and it should launch.
Reply
#21
(2017-02-20, 13:41)deekeylock Wrote: I got it to work guys. I just went on finder, go to folder and copied and pasted this /Users/<your_user_name>/Library/Application Support/Kodi/userdata and enter (obviously change the your user name to your name) then click on database and then delete addons20 and addons26. Then reopen kodi and it should launch.

you are a BOSS! Thanks very much! Back to Kodi life
Reply
#22
I have the same problem with kodi can someone help me?

i cannot find the file addons20 and addons26

http://pastebin.com/RV0r1qZf
Reply
#23
Need a debug log (wiki) in addition
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
#24
(2017-02-20, 13:41)deekeylock Wrote: I got it to work guys. I just went on finder, go to folder and copied and pasted this /Users/<your_user_name>/Library/Application Support/Kodi/userdata and enter (obviously change the your user name to your name) then click on database and then delete addons20 and addons26. Then reopen kodi and it should launch.

This worked! Thank you good Sir
I had to delete addons20 and addons27 (addons26 didn't exist). I also had to manually enter that path name, but once I found it and deleted those two addons then Kodi booted up first time
Reply
#25
(2017-03-13, 00:39)chuckstar Wrote:
(2017-02-20, 13:41)deekeylock Wrote: I got it to work guys. I just went on finder, go to folder and copied and pasted this /Users/<your_user_name>/Library/Application Support/Kodi/userdata and enter (obviously change the your user name to your name) then click on database and then delete addons20 and addons26. Then reopen kodi and it should launch.

This worked! Thank you good Sir
I had to delete addons20 and addons27 (addons26 didn't exist). I also had to manually enter that path name, but once I found it and deleted those two addons then Kodi booted up first time


please help me i cannot find addons20 and addons27...
Reply
#26
(2017-03-13, 09:25)joaomabiala Wrote: please help me i cannot find addons20 and addons27...

Post a debug log (wiki).
It seems like the reason kodi doesn't start is something different for you.
Reply
#27
(2017-03-13, 10:55)Rechi Wrote:
(2017-03-13, 09:25)joaomabiala Wrote: please help me i cannot find addons20 and addons27...

Post a debug log (wiki).
It seems like the reason kodi doesn't start is something different for you.

Sorry guys i have find addons20 and addons26 and have deleted and change name so kodi is working =D
Reply
#28
I need one of those corrupted DBs. Not sure in how many threads about this issue i have posted this now - but guys - for god sake...
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
#29
I have the same problem, please help me.
https://pastebin.com/27cUwAE8
Reply
#30
This isn't a Debug log (wiki), it's a crash report.
Looks like http://forum.kodi.tv/showthread.php?tid=311058 should solve your issue.
Reply



Cannot open kodi 17 on mac00