[krypton]Fullscreen/Windowed mode problem

  Thread Rating:
  • 2 Vote(s) - 4.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
dancaer69 Offline
Junior Member
Posts: 23
Joined: Jun 2014
Reputation: 1
Post: #1
Hello,
I installed krypton today and I found that I cannot have a custom window size mode. The only options is Fullscreen and maximized window. I tried to set the window size from advancedsettings.xml, but every time I return from fullscreen it changes to maximized window only. And there is no option to set a windows size from menu. Only in fullscreen I can change resolutions, but not window sizes. Is this improvement?
Is there any way to have the behaviour of previous versions?
Thanks in advance.
(This post was last modified: 2017-02-24 12:00 by dancaer69.)
find quote
PatK Offline
Team-Kodi Member
Posts: 8,332
Joined: Mar 2010
Reputation: 202
Location: Canada
Post: #2
When windowed Kodi should hold that window size for you next launch?

Moving this to Linux support. [PatK]

windows fresh start -> delete C:\Users\User Name\AppData\Roaming\Kodi First time user (wiki) Log file (wiki) Video management (wiki) Artwork (wiki) Supported hardware (wiki) Releases (wiki) Database versions (wiki) Skin features compatibility list (wiki) http://xbmc-skins.com
find quote
dancaer69 Offline
Junior Member
Posts: 23
Joined: Jun 2014
Reputation: 1
Post: #3
But it doesn't. It just resize the window to take full screen(except panel). This problem affects another user which I know and has debian. I'm running it in arch linux. Doesn't seem that affects windows users though.

EDIT:
Started with fresh .kodi folder the issue remains.
(This post was last modified: 2017-02-08 11:08 by dancaer69.)
find quote
ghostly Offline
Junior Member
Posts: 2
Joined: Feb 2017
Reputation: 1
Post: #4
I have a similar problem with Kodi 17. I didn't have this issue with Kodi 16.

Kodi will remember the window size as long as I don't switch to full screen. If I switch from full screen, the window will be maximized. I am using Mint.
find quote
dancaer69 Offline
Junior Member
Posts: 23
Joined: Jun 2014
Reputation: 1
Post: #5
We have the same problem. I have the same behaviour as well.
find quote
ghostly Offline
Junior Member
Posts: 2
Joined: Feb 2017
Reputation: 1
Post: #6
Looks like we're the only ones with the problem. Or nobody toggles fullscreen/window view.
find quote
fritsch Offline
Team-Kodi Developer
Posts: 17,922
Joined: Aug 2011
Reputation: 557
Location: Stuttgart*
Post: #7
Yeah - that's an Ubuntu bug. You can turn off compositing and it will work.

Btw. you should have exactly the same issue whenever you open a terminal, fullscreen it and resizing it, right?

"Your most vocal users are not reflective of your userbase" J.M.
"Of course, they [XP Users and people with outdated hardware] need to tell the world about the kind of hero they are, and block innovation for everyone else because their decades old OS / hardware needs to work =p" nevcairiel (ffmpeg)
No Debug Log no issue.
find quote
dancaer69 Offline
Junior Member
Posts: 23
Joined: Jun 2014
Reputation: 1
Post: #8
No, it isn't I have arch linux. And I didn't have this problem with jarvis or previous versions. This started with krypton and seems to be related with the new fullscreen/windowed mode option. If I set a window size in advancedsettings.xml, then kodi starts fine with this window size I set, but from the moment I use fullscreen option the problem starts. After that windowed mode is always a maximized window, no matter if I resize it manually. When I go to fullscreen and return to windowed mode again is maximize itself.
Also, I'm using XFCE. Turning off compositing doesn't make any difference. The problem still remains. Also doesn't have this problem with other apps/windows.

EDIT:
There is another issue which again started to happen on krypton and is very annoying. When a video plays and I am in fullscreen mode, there is no way to exit from fullscreen until the video stops. Pressing the key(/) to toggle to windowed mode just automatically returns to fullscreen mode.
(This post was last modified: 2017-02-24 13:24 by dancaer69.)
find quote
dancaer69 Offline
Junior Member
Posts: 23
Joined: Jun 2014
Reputation: 1
Post: #9
I just updated to 17.1 version, but these problems still exist. The only thing changed is that now when return from fullscreen the window, which still is maximized, can be restored, but in some other(default?) size and not the one I have set in advancedsettings.xml.
So to sum up:
1. still window return to maximized mode from fullscreen
2. window size when unmaximize it isn't the size which set in advancedsettings.xml
3. Impossible to exit from fullscreen when video is playing or is paused.
(This post was last modified: 2017-03-21 15:13 by dancaer69.)
find quote
fritsch Offline
Team-Kodi Developer
Posts: 17,922
Joined: Aug 2011
Reputation: 557
Location: Stuttgart*
Post: #10
Try from fluxbox _without_ a compositor.

"Your most vocal users are not reflective of your userbase" J.M.
"Of course, they [XP Users and people with outdated hardware] need to tell the world about the kind of hero they are, and block innovation for everyone else because their decades old OS / hardware needs to work =p" nevcairiel (ffmpeg)
No Debug Log no issue.
find quote
dancaer69 Offline
Junior Member
Posts: 23
Joined: Jun 2014
Reputation: 1
Post: #11
I've managed to bypass it using kwin with xfce and create a rool for kodi which force it to remember the window size after change to fullscreen. This works, but I think that it's kodi' s bug because in all previous versions worked. I'm using kodi 5-6 years, with different linux distros and desktops enviroments(with compositing enabled) and I never had this issue.
find quote
dancaer69 Offline
Junior Member
Posts: 23
Joined: Jun 2014
Reputation: 1
Post: #12
As I heard from another user, fluxbox without compositor doesn't "fix" this issue also. It's even worse in fluxbox because the maximized window retains the size/rersolution of fullscreen and it's bigger that the screen, so a part of it is off screen.
find quote
pemartins Offline
Member
Posts: 64
Joined: Oct 2013
Reputation: 2
Post: #13
I have this exact problem and it is the reason I'm not using Kodi 17 yet, I only have 17 installed in a virtualbox for testing. My OS is a distro based on Ubuntu 16.04.1 (LXLE 16.04.1, based on Lubuntu with LXDE desktop, Openbox and PCManFM). I make a lot of constant windowed<->fullscreen changes so this bug is a deal breaker for me.

Is there a fix for it, even if it is a temporary one?

Thank you very much in advance.
find quote
pemartins Offline
Member
Posts: 64
Joined: Oct 2013
Reputation: 2
Post: #14
This also happens in Kodi 18 Leia, just tried the latest nightly and the bug coming out of fullscreen is still there, it doesn't go back to previous windowed size but always to maximized window.
find quote
TheMechanist Offline
Junior Member
Posts: 35
Joined: Dec 2015
Reputation: 5
Post: #15
Can confirm the bug:

Switching between fullscreen and windowed mode doesn't work at all (only sometimes switching to a maximized window works, most time kodi simply hangs, when switching to windowed mode, independently if media plays or not) -

tested with: Xfce4 4.12 (xfwm WM) and Mate 1.12 (metacity WM) - with composition manager enabled/disabled
Ubuntun 16.04

The bug appeared in some older versions of kodi, but was fixed .. bug didn't appear in last stable release Jarvis.
find quote
Post Reply