XMLTV not working after upgrade
#1
HI there. I'm using the pvr.stalker addon and create my own xmltv file with mc2xml. The file has worked fine with Kodi 16 and now the log file is showing parse errors. The file is on another server but I have the location mounted aS a local folder. I'm running OSMC on an Rpi 3.
Reply
#2
ok, I won't be able to help you, but anyone who can will certainly ask for a debug log uploaded to e.g. pastebin.com
Reply
#3
I could post the full debug log but it is rather huge. There is only one message that concerns me, which could be the issue:

06:26:12.153 T:1583944688 DEBUG: AddOnLog: Stalker Client: Execute: {"js":{"data":{"msgs":0,"additional_services_on":"1"}},"text":"generated in: 0.017s; query counter: 4; cache hits: 0; cache miss: 0; php errors: 1; sql errors: 0; php err str: txt: mysqli_connect(): Headers and client library minor version mismatch. Headers:50552 Library:50633; file: \/var\/www\/stalker_portal\/server\/lib\/core\/mysql.class.php; line: 92; ;"}
06:26:12.846 T:1958859696 DEBUG: ------ Window Init (DialogExtendedProgressBar.xml) ------
06:26:12.850 T:1484780528 DEBUG: EPG - Load - no database entries found for table 'SKY SPORTS 4 HD '.
06:26:12.851 T:1484780528 DEBUG: EPG - UpdateFromScraper - updating EPG for channel 'SKY SPORTS 4 HD ' from client '21225959'
06:26:12.851 T:1484780528 DEBUG: AddOnLog: Stalker Client: GetEPGForChannel

How would I resolve that? I think it would need to be recompiled but I'm installed via packages and that would be a PIA.
Reply
#4
I saw this same error messages with my Kodi also and there was no guide info in mine "DEBUG: EPG - Load - no database entries found for table ....."
Reply
#5
Well, I can confirm it's not my install version, I have moved to an android box and in it I can't read the xmltv file either. Can anyone use xmltv with pvr stalker in Krypton?
Reply
#6
I turned debug on and it simply says it cannot parse the file. No other details. This same file reads fine into Kodi 16.

I'm using mc2xml to generate the file and nothing has changed there. I tried to change the language to UTF-8, no go, and tried to change the format to not put name first... I would be surprised if that worked since it does require the name only first for matching.

Any help would be appreciated.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
XMLTV not working after upgrade00