Ubuntu: update to Krypton broke Kodi
#1
Hi,

I have been running Kodi Jarvis under Ubuntu 14.0.4 on an Intel NUC for more than a year without any problems.

Today I updated to Krypton and Kodi crashes when I try to display any video.

The error I get is

libEGL warning: failed to create a pipe screen for i965
libva info: VA-API Version 0.35.0
libva info: va_GetDriverName() returns 0
libva info: Trying to open /usr/lib/i386-linux-gnu/dri/i965_drv_video.so
libva info: va_openDriver() returns 0
/usr/lib/i386-linux-gnu/kodi.bin: symbol lookup error: /usr/lib/i386-linux-gnu/kodi.bin: undefined symbol: vaAcquireBufferHandle

Here is some more system information:
Intel NUC Model DCCP847DYE
Intel Celeron CPU 847
Ubuntu 14.0.4.5 LTS
kernel 3.13.0-108-generic
GPU: Mesa DRI Intel® Sandybridge Mobile x86/MMX/SSE2
Open GL Vendor: Intel Open Source Technology Center
Open GL Version: 3.0 Mesa 10.1.3

Thanks for any suggestions.
Reply
#2
I noticed a very long possibly related discussion in these forums entitled:
"Intel VAAPI howto with Krypton v17 based on Ubuntu 16.04 server"
The developers there asked for the following information, which I provide below:

dpkg -l |grep mesa | pastebinit
http://paste.ubuntu.com/23970844/

DISPLAY=:0 vainfo | pastebinit
libva info: VA-API version 0.35.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/i386-linux-gnu/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_0_35
libva info: va_openDriver() returns 0
http://paste.ubuntu.com/23970855/

cat ~/.kodi/temp/kodi.log | pastebinit
http://paste.ubuntu.com/23970864/

dmesg | pastebinit
http://paste.ubuntu.com/23970871/

id | pastebinit
http://paste.ubuntu.com/23970874/

amixer | pastebinit
http://paste.ubuntu.com/23970877/
Reply
#3
Quote:19:30:46.011 T:2723646272 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type: <class 'ssl.SSLError'>
Error Contents: The read operation timed out
Traceback (most recent call last):
File "/home/zig/.kodi/addons/plugin.program.indigo/service.py", line 126, in <module>

Remove this script, please.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#4
Sorry, still crashes after removing the script.

Here are the new logs:

cat ~/.kodi/temp/kodi.log | pastebinit
http://paste.ubuntu.com/23973723/

dmesg | pastebinit
http://paste.ubuntu.com/23973729/
Reply
#5
I just noticed that there was a system update for Ubuntu 14.0.4.5:

Setting up libva-drm1:i386 (1.6.0~pre1~trusty) ...
Setting up libva1:i386 (1.6.0~pre1~trusty) ...
Setting up libva-egl1:i386 (1.6.0~pre1~trusty) ...
Setting up libva-x11-1:i386 (1.6.0~pre1~trusty) ...
Setting up libva-glx1:i386 (1.6.0~pre1~trusty) ...
Setting up libva-tpi1:i386 (1.6.0~pre1~trusty) ...
Setting up libva-wayland1:i386 (1.6.0~pre1~trusty) ...
Setting up libva-dev:i386 (1.6.0~pre1~trusty) ...
Setting up vdpau-va-driver:i386 (0.7.3-2ubuntu1.2) ...
Setting up va-driver-all:i386 (1.6.0~pre1~trusty) ...
Processing triggers for libc-bin (2.19-0ubuntu6.9) ...

After installing the update, Kodi doesn't crash any more. However when I try playing videos, I get normal audio, but only a black screen. When I exit Kodi, the terminal from which I launched it displays more or less the same error message:
libEGL warning: failed to create a pipe screen for i965
libva info: VA-API version 0.35.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/i386-linux-gnu/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_0_35
libva info: va_openDriver() returns 0

Here are the new logs:

cat ~/.kodi/temp/kodi.log | pastebinit
http://paste.ubuntu.com/23973825/

dmesg | pastebinit
http://paste.ubuntu.com/23973840/
Reply
#6
Sorry, I copied/pasted from the wrong screen. The new error message is:
libEGL warning: failed to create a pipe screen for i965
libva info: VA-API version 0.38.0 <------------------------------------
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/i386-linux-gnu/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_0_35
libva info: va_openDriver() returns 0
Reply
#7
Disable VAAPI in settings.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#8
Disabling VAAPI fixed the problem. However, I haven't checked for any undesireable side effects yet (e.g. stuttering).

Moreover I couldn't find anywhere in the Krypton GUI to toggle this setting. Under Jarvis/Confluence I could do it via the GUI under settings/system/video/acceleration (and to the best of my recollection it was set to "on").

I had to set it manually by editting the file:
~/.kodi/userdata/guisettings.xml

[email protected]:~/.kodi/userdata$ diff -c guisettings*
*** guisettings.bak 2017-02-11 11:07:55.470102098 -0500
--- guisettings.xml 2017-02-11 11:12:02.073855658 -0500
***************
*** 357,363 ****
<errorinaspect default="true">0</errorinaspect>
<hqscalers default="true">20</hqscalers>
<preferdefaultflag default="true">true</preferdefaultflag>
! <prefervaapirender default="false">false</prefervaapirender>
<quitstereomodeonstop default="true">true</quitstereomodeonstop>
<rendermethod default="true">0</rendermethod>
<seekdelay default="true">750</seekdelay>
--- 357,363 ----
<errorinaspect default="true">0</errorinaspect>
<hqscalers default="true">20</hqscalers>
<preferdefaultflag default="true">true</preferdefaultflag>
! <prefervaapirender>false</prefervaapirender>
<quitstereomodeonstop default="true">true</quitstereomodeonstop>
<rendermethod default="true">0</rendermethod>
<seekdelay default="true">750</seekdelay>
***************
*** 376,385 ****
<usemediacodecsurface default="true">true</usemediacodecsurface>
<useomx default="true">true</useomx>
<useomxplayer default="true">true</useomxplayer>
! <usevaapi default="false">false</usevaapi>
! <usevaapimpeg2 default="false">false</usevaapimpeg2>
! <usevaapimpeg4 default="false">false</usevaapimpeg4>
! <usevaapivc1 default="false">false</usevaapivc1>
<usevdpau default="true">true</usevdpau>
<usevdpaumixer default="true">true</usevdpaumixer>
<usevdpaumpeg2 default="true">true</usevdpaumpeg2>
--- 376,385 ----
<usemediacodecsurface default="true">true</usemediacodecsurface>
<useomx default="true">true</useomx>
<useomxplayer default="true">true</useomxplayer>
! <usevaapi>false</usevaapi>
! <usevaapimpeg2>false</usevaapimpeg2>
! <usevaapimpeg4>false</usevaapimpeg4>
! <usevaapivc1>false</usevaapivc1>
<usevdpau default="true">true</usevdpau>
<usevdpaumixer default="true">true</usevdpaumixer>
<usevdpaumpeg2 default="true">true</usevdpaumpeg2>
Reply
#9
I never got Krypton running properly on Ubuntu 14.04 x64. Got VAAPI going (on Krypton)

--You need Advanced or Expert Mode to access Settings>Video>Acceleration screen where the VAAPI and VDPAU options reside,--

but Indigo has never worked: Not from a fresh start, and not from an upgrade from Jarvis-->Krypton (this has it's own problems involving a missing Addons27.db)

So I went back to Jarvis using kodi-old repository and disabled version check to nix the Krypton update message.

I couldn't find any reference to the Indigo problem except for a Youtube video that is unsolved.
Reply
#10
One day someone will come here and en-route will actually have read the forum rules (wiki) and the banned add-ons (wiki) list, so they won't talk about that kind of malware.

You won't find any reference here as it's very definitely on the list and is about the worst 3rd party crap you can install. Consider yourself lucky that you couldn't do so, and that you dodged a bullet and all sorts of pain and problems (and your device being denied any help or support here).
|Banned add-ons (wiki) Forum rules (wiki)|VPN policy (wiki)|First time user (wiki)|FAQs (wiki) Troubleshooting (wiki)|Add-ons (wiki)|Free content (wiki)|Debug Log (wiki)|

My Blog Posts
Reply



Logout Mark Read Team Forum Stats Members Help
Ubuntu: update to Krypton broke Kodi0
This forum uses Lukasz Tkacz MyBB addons.