[Solved] Shortcut buttons broken
The latest version seems to have broken the buttons on the remote to quickly toggle subtitles, audio language etc.
They dont work anymore.
Nothing is broken, they work here. Some more details like kodi version that you are using? iOS version in use? iPhone or iPad? During a movie playback? A TV Show playback? An add-on playback?
Good to hear. or bad. Depends on the point of view :-(

I am still using kodi 12 and haven't updated ever since. Until recently the buttons have been working flawlessly. Until they didn't. The only change being automatic updates enabled for the iOS app. iOS Version 8 still running (which has worked before as well).

iOS 8.x on iPad, flaw appears during any type of video (both tv shows and full movies)
Ok, now I have some clues to be investigated. I will test the current remote app version with XBMC 12 and I see two options:

1. If I will be able to solve the issue, the fix will be included with the upcoming 1.5.7 version
2. If I will not be able to solve the issue, I will lift the minimum xbmc/kodi supported version because we are currently in version 17 and 12 is a bit too old to continuing its support.
Thank you for your answer which hints at the supported kodi versions being the reason for malfunction. This leads me to consider updating my kodi system.
Although I have learned from experience that you shouldn't change a running system I wouldn't like to miss out on certain features, even if they can be classified as comfort.
Maybe you can post your findings to this thread which I have subscribed. So I can think about the next steps.
Sure! I'll keep you updated.
I was finally able to test current app version, 1.5.6, with XBMC frodo 12.3 and everything seems working on my environment. When I tap on subtitles or audio streams buttons an action sheet where select a subtitle/audio stream appear as expected and they are working. What happens in your side when you tap on those buttons?
exactly nothing. when a file has more than one language a tap on the corresponding icon shows all the embedded streams. but when selecting one it doesn't change to that.
also the fullscreen button right on top is broken. if i touch it nothing happens
ok, same issue with a subtitle selection? I will continue the investigation. After that, I probably will ask you to provide me a xbmc debug log to see what is happening on xbmc side when the remote app tries to set an audio stream.
exactly the same. when i press the subtitle button to disable subs the action has no effect. when i push the button again the sub stream is still ticked and marked as being active.

i'd gladly send you the log if required
I have done another round of tests and I can confirm that both audio and subtitles switches work as expected with XBMC Frodo 12.3. It's time to link a full xbmc debug log to see what's happening on xbmc side from the log. You need to enable the "enable debug logging" option under System > Debugging to record the json calls that the remote app does.
Will take some time to reproduce. Please hang on
I havent been able to reproduce the misbehaviour since. Either kodi got stuck or an automatic update fixed the app? If i stumble upon a problematic file i will get a log. Thanks for the support.
No problem! Thread marked solved.
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
Shortcut buttons broken00