Ubuntu: kodi-pvr-dvbviewer broken

  Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
baderj Offline
Junior Member
Posts: 10
Joined: Feb 2012
Reputation: 0
Post: #1
I did a clean install of Ubuntu 16.04 and clean install of kodi 17
Quote:sudo apt-get install software-properties-common
sudo add-apt-repository ppa:team-xbmc/ppa
sudo apt-get update
sudo apt-get install kodi

That all worked fine. Then I tried to install the DVBViewer addon:

Quote:sudo apt-get install kodi-pvr-dvbviewer
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
kodi-pvr-dvbviewer : Depends: libkodiplatform17 but it is not installable
E: Unable to correct problems, you have held broken packages.

Because it is a clean system, most likely either kodi or kodi-pvr-dvbviewer are built wrong. So if you are on 16 better wait before you upgrade.

Are there any recommended workaround around this?[/quote]

EDIT:
The following worked for me, but I really dislike the idea of adding package from nightlies:
Quote:sudo add-apt-repository ppa:team-xbmc/xbmc-nightly
sudo apt-get update
sudo apt-get install kodi-pvr-dvbviewer
sudo add-apt-repository -r ppa:team-xbmc/xbmc-nightly
(This post was last modified: 2017-02-11 17:06 by baderj.)
find quote
manĂ¼l Offline
Moderator
Posts: 412
Joined: Mar 2013
Reputation: 27
Post: #2
Looks like kodiplatform17 isn't published yet. You can use a build from nightly repo: https://launchpad.net/~team-xbmc/+archiv...=published
find quote