Thread Rating:
  • 0 Vote(s) - 0 Average
<wrapmultiline> / alignment problems
#1
It seems that when I use <wrapmultiline> in conjunction with <aligny>center, the label concerned doesn't align properly. Specifically, it starts at the halfway point and then wraps downwards, as opposed to taking the entire wrapped label and centrally aligning that. Is this a known issue? If so, is it fixable?

Also, wrapmultiline doesn't seem to work in wraplists.
Reply
#2
djh_ Wrote:Also, wrapmultiline doesn't seem to work in wraplists.

I can verify this bug. Just ran into it myself. I have a wraplist control that i'm making, and wrapmultiline doesn't wrap. It just scrolls the label text. Even if scroll is set to false, it still scrolls.
Reply
#3
Ah, now it doesn't do that when I try it. No scrolling here.
Reply
#4
Ok I think I see the problem with the wrapping in the code. The lists appear to use a different label control, which doesn't have the code for passing on the wrap settings.

I'll take a look into getting this fixed today.
Reply
#5
Well unfortunately I just could not get this working. I was pretty sure I had found the problem, but no matter what I did it just would not wrap. Even when I hard coded it to wrap. So the problem may be deeper into the code than I realized.

I am fairly certain that one problem is the multiline option is not being passed from the skin xml to the underlying GUI code, but the problem seems to stem deeper than that as well.

So I guess for now it will just be broken, until someone has the free time to fix it. That is just the nature of open source Smile No worries.
Reply
#6
Alignment issues should be resolved. Still no wrapping in lists as yet.
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


Image
Reply
#7
jmarshall Wrote:Alignment issues should be resolved. Still no wrapping in lists as yet.

Thanks for taking a look at this JM!
Reply
#8
As far as I'm aware, the issue of wrapmultiline not working within wraplists still exists. Any chance of a fix?
www: deadendthrills.com
follow on twitter for updates, etc: @deadendthrills
Reply
#9
has this been resolved? I am running into the same issue with Babylon.
Reply
#10
okay, got a workaround by keeping the wraplist fixed and just laying the textbox over the wraplist. Not the ideal solution, but works for what i needed.
Reply
#11
Nmarconi Wrote:okay, got a workaround by keeping the wraplist fixed and just laying the textbox over the wraplist. Not the ideal solution, but works for what i needed.
Thanks, solved the problem I was having with a wrapmultiline control in a wraplist.
Reply
#12
A textbox will work inside a wraplist.
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


Image
Reply
#13
Indeed it does, thanks.
Reply



<wrapmultiline> / alignment problems00