DTS/AC3 Music tracks playback
#1
Hi, I might have posted this question very (VERY) long time ago. But I still haven't been able to find the answers.

I have many multi-channel music tracks (DTS & AC3 formats). When I playback these tracks in Kodi (even from XBMC days), the playback is equivalent of playing the tracks in a high speed mode. It's almost like it's playing in 3x speed. The music and human voice sound extremely high pitched. Nearly like cartoon voices.

I'm currently using a Fire TV with Kodi (Jarvis). I had exactly the same problem with my Apple TV and XBMC (Nitro). My receiver does show it's receiving DTS (or AC3 as with the tracks) signals and it's decoding as well.

What is the problem here? Is this some kind of config issues? I have been experiencing exactly the same behavior for many years thru multiple hardware platform and thru many versions.

I have no idea how to even begin to debug this.
Reply
#2
Movie audio with DTS/AC3 is normally 48khz sample rate, music however is normally 44.1khz so when encoded into DTS/AC3 it's usual to keep the sample rate. So the problem could be the FireTV sending 44.1khz DTS/AC3 at 48khz or the receiving device decoding thinking it's 48khz, as not all devices understand DTS/AC3 at 44.1khz as it's more unusual.
Reply
#3
I just checked the files (MediaInfo) and found the tracks are 44.1 and the receiver is showing as 48kHz. Now this makes sense but not sure how to fix this. Is this an issue with the receiver that it cannot receive DTS @ 44.1? This is a fairly capable receiver, I wouldn't call it high-end, but not an average hardware.

Is there any changes in Kodi to ensure it send the right encoding? My current hardware:

Fire TV
Onkyo NR809 (my previous 2 receivers had exactly the same issue too)
Reply
#4
First thing you could do is enable debug logging play something and look at the resulting log_file (wiki) this will then tell you want sample rates are supported by the FireTV and what we send the audio as. If it's being sent as 48khz then FireOS is at fault.

For DTS the workaround would be to disable DTS support, then make sure Number if Channels is set to 2, and then enable AC3 transcoding. This will nean your DTS files produce AC3 however during the transcode process we will resample to 48khz.
Reply
#5
I just checked the log file. The Kodi log says:

Output Device : android
Sample Rate : 48000
Sample Format AE_FMT_S16NE
Channel Count : 2
Channel Layout : FL,FR
Frames : 1536
Frame Samples : 3072
Frame Size : 4


Looks like Kodi reads the stream as 48kHz. But when I load the file in MediaInfo, I see the sample rate as 44.1kHz. Now I don't know which one to believe :-)
Reply
#6
Could you copy the log to pastebin or use the log uploader addon and post the link.
Reply
#7
The same track (from my above post) shows up like this in MediaInfo

Format : Wave
File size : 68.4 MiB
Duration : 6 min 46 s
Overall bit rate mode : Constant
Overall bit rate : 1 411 kb/s

Audio
Format : DTS
Format/Info : Digital Theater Systems
Mode : 14
Format settings, Endianness : Little
Codec ID : 1
Duration : 6 min 46 s
Bit rate mode : Constant
Bit rate : 1 411.2 kb/s
Channel(s) : 6 channels
Channel positions : Front: L C R, Side: L R, LFE
Sampling rate : 44.1 kHz
Frame rate : 43.066 FPS (1024 spf)
Bit depth : 24 bits
Compression mode : Lossy
Stream size : 68.4 MiB (100%)
Reply
#8
I'm having difficulty in dealing with the log file. I'm trying to figure out how to SSH into Fire TV to grab the log. Log Uploader is failing for whatever reason. Just before the DEBUG statements, I see one INFO line that says:

CAEStreamInfo::SyncDTS - dts stream detected (6 channels, 44100Hz, 14bit LE, period:1024)

Is there a simple way to access the log file thru computer? This is kind of perplexing how a log file access can be so complicated.
Reply
#9
If you have have a share on your pc or elsewhere you can copy to the you can use this method http://kodi.wiki/view/Log_file/File_manager_access
Reply
#10
Finally figured out a way to access the log file. Below is the full log content. Thanks for your link. I'll look into that as well.

http://paste.ubuntu.com/23984432/
Reply
#11
Did the log file help? I see that the file is 44.1kHz and 48kHz between the log entries. So this does seem like a Kodi issue. Should I change the default audio player from PAPlayer to DVDPlayer? Will that help?
Reply
#12
That's long fixed in v17. 16.1 selected the wrong Samplerate. Though on your firetv you need to download the shitty build as Amazon was not to be convinced to fix their firmware :-(

http://ftp.halifax.rwth-aachen.de/xbmc/t...bi-v7a.apk
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#13
Is there an explanation anywhere what the shitty and not-so-shitty builds are for, specifically? I'm still hoping for proper audio on my 2016 Philips Smart TV with Android 6.0.
Reply
#14
So if I get v17, this problem will be fixed? Am I the only one who had this issue and coincidentally got a fix in the upcoming release? I could not find any discussion on this. I'm still kind of confused about this.
Reply
#15
Background: http://forum.kodi.tv/showthread.php?tid=289735 don't forget the link at the bottom that explains it non technical.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply



Logout Mark Read Team Forum Stats Members Help
DTS/AC3 Music tracks playback0
This forum uses Lukasz Tkacz MyBB addons.