•   
  • 1
  • 299
  • 300
  • 301
  • 302
  • 303(current)
Mod Estuary MOD V2 - KODI 18 (UPDATED 17/01/19)
(2020-06-25, 05:30)hans5849 Wrote: I installed this on my RPi4 and it's throwing an error related to the skin helper and widget.

Code:
2020-06-25 06:11:38.962 T:2342777040   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.ImportError'>
                                            Error Contents: No module named functools_lru_cache
                                            Traceback (most recent call last):
                                              File "/home/pi/.kodi/addons/script.skin.helper.service/plugin.py", line 10, in <module>
                                                from resources.lib.plugin_content import PluginContent
                                              File "/home/pi/.kodi/addons/script.skin.helper.service/resources/lib/plugin_content.py", line 17, in <module>
                                                from metadatautils import MetadataUtils
                                              File "/home/pi/.kodi/addons/script.module.metadatautils/lib/metadatautils.py", line 9, in <module>
                                                import helpers.kodi_constants as kodi_constants
                                              File "/home/pi/.kodi/addons/script.module.metadatautils/lib/helpers/kodi_constants.py", line 9, in <module>
                                                from utils import KODI_VERSION
                                              File "/home/pi/.kodi/addons/script.module.metadatautils/lib/helpers/utils.py", line 13, in <module>
                                                import arrow
                                              File "/home/pi/.kodi/addons/script.module.arrow/lib/arrow/__init__.py", line 3, in <module>
                                                from .api import get, now, utcnow
                                              File "/home/pi/.kodi/addons/script.module.arrow/lib/arrow/api.py", line 10, in <module>
                                                from arrow.factory import ArrowFactory
                                              File "/home/pi/.kodi/addons/script.module.arrow/lib/arrow/factory.py", line 18, in <module>
                                                from arrow import parser
                                              File "/home/pi/.kodi/addons/script.module.arrow/lib/arrow/parser.py", line 15, in <module>
                                                from backports.functools_lru_cache import lru_cache  # pragma: no cover
                                            ImportError: No module named functools_lru_cache
                                            -->End of Python script error report<--

Doing some research I came across https://forum.kodi.tv/showthread.php?tid=350911 and https://forum.kodi.tv/showthread.php?tid...pid2893721 saying those modules are abandoned.

Check out this GitHub link, it could help. Please report back the results, it could help others if it fixes the problem.

From the link, it seems this error is caused by another module, arrow. To solve it, you have to downgrade arrow to a previous working version. I am not sure if it is possible to disable automatic update of a dependency like arrow, if it is, please disable automatic update.

I loved this skin so much but abandoned it when things started falling apart because the skin is not being maintained.

If you have not tried it, I recommend you give MQ 8 a try. It has most of the nice features of this skin and it will prepare you for MQ 9 for KODI 19 because this skin wont work in Matrix unless the dev comes back and updates it. Better still, check out the MQ 8 Mods by latts9923.
Reply
When you say must have lastest nightly build - is this of Kodi

I'm using the Libreelec package - does this mean V2 won't work on it?
Reply
Ok forget that - didn't realise it wasn't maintained anymore
Reply
2 bugs in file:
https://github.com/Guilouz/repository.gu...s_Home.xml

line 3482 and 3970

<visible>!String.IsEqual(listitem.dbtype,genre)]</visible>

should be:

<visible>!String.IsEqual(listitem.dbtype,genre)</visible>


Bracket at the end is wrong
Reply
Thank you for the Estuary Mod skin!

I have some questions for own menu design/functions:

1. When I build widgets for e.g. a playlist behind, I can't only decide for the view between posters, square's. I want also decide, that the view is only a list of files where I can scroll down. How I could get this work?

2. I like to build on widgets which refers to a folder/path with files behind. I didn't found this function in the Mod skin. Is it there?
Reply
hello

I installed Kodi on windows as well as on a shield
I put estuary mod v2 and the 2 installation presents the same problem I cannot change the fanarts or the thumbs when I click on the interface nothing happens I have filled some fields but nothing changes thank you


1
Reply
(Yesterday, 18:32)poulbot1977 Wrote: hello

I installed Kodi on windows as well as on a shield
I put estuary mod v2 and the 2 installation presents the same problem I cannot change the fanarts or the thumbs when I click on the interface nothing happens I have filled some fields but nothing changes thank you


1 

2

3

4

you will understand that above these are photos
sorry I'm not used to
Reply
  •   
  • 1
  • 299
  • 300
  • 301
  • 302
  • 303(current)



Logout Mark Read Team Forum Stats Members Help
Estuary MOD V2 - KODI 18 (UPDATED 17/01/19)17
This forum uses Lukasz Tkacz MyBB addons.