VDR 2.3.2 VNSI 1.5.2 EPG empty

  Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
dinor Offline
Junior Member
Posts: 4
Joined: Feb 2017
Reputation: 0
Post: #1
Hello guys, after searching for hours I couldn't find a solution so I'm asking anyone who knows.
I have compiled VDR 2.3.2. with VNSI 1.5.2 using FernetMenta guide
Then installed w-scan to scan for channels and everything works fine.

The only thing that is not working is EPG... I just can't figure out what I am doing wrong.
I have manually deleted epg.data and is autocreated but never receive any info.

My system is raspberry pi 3 with raspbian jessie, VDR server with VNSI, Kodi 17.0, kodi-pvr-vdr-vnsi 2.6.17
permissions are set correctly and in kodi "do not store in local db" checked

here is what is installed
vdr -V
Code:
vdr (2.3.2/2.3.2) - The Video Disk Recorder
epgtableid0 (2.2.0) - EPG handler for events with table id 0x00
hello (2.2.0) - A friendly greeting
osddemo (2.3.1) - Demo of arbitrary OSD setup
pictures (2.3.1) - A simple picture viewer
skincurses (2.3.2) - A text only skin
status (2.2.0) - Status monitor test
svccli (2.2.0) - Service demo client
svcsvr (2.2.0) - Service demo server
svdrpdemo (2.2.0) - How to add SVDRP support to a plugin
vnsiserver (1.5.2) - VDR-Network-Streaming-Interface (VNSI) Server

Maybe some settings that I am not aware?
on my understanding EPG should work out of the box, FernetMenta implemented it in VNSI 1.5.x, correct?
find quote
FernetMenta Online
Team-Kodi Developer
Posts: 6,190
Joined: Jul 2010
Reputation: 140
Location: Munich
Post: #2
Do you allow status updated for the vnsi addon? Please pastebin a kodi debug log.
find quote
dinor Offline
Junior Member
Posts: 4
Joined: Feb 2017
Reputation: 0
Post: #3
here is log after restarting kodi
http://pastebin.com/HKk2hNdf

I have not changed any config, how do I allow status to update?
(This post was last modified: 2017-02-13 13:43 by dinor.)
find quote
FernetMenta Online
Team-Kodi Developer
Posts: 6,190
Joined: Jul 2010
Reputation: 140
Location: Munich
Post: #4
hmm, kodi does request epg but seems to get nothing. are you sure epg.data on vdr machine gets populated? did you try svdrpsent to list epg on the server?
find quote
dinor Offline
Junior Member
Posts: 4
Joined: Feb 2017
Reputation: 0
Post: #5
the epg.data is created but empty 0kb
find quote
FernetMenta Online
Team-Kodi Developer
Posts: 6,190
Joined: Jul 2010
Reputation: 140
Location: Munich
Post: #6
have a look at this thread: http://forum.kodi.tv/showthread.php?tid=194710
find quote
dinor Offline
Junior Member
Posts: 4
Joined: Feb 2017
Reputation: 0
Post: #7
That topic provides no information

I tried command "svdrpsend -d localhost -p 6419 MESG HELLO" and I can see it in kodi as message

It seems like either is not grabbing epg data from channels or it doesn't put them in epg.data

is there a manual command to try for fetching epg data?

edit: I have also noticed that date on epg guide has been set to 1970... maybe that's the problem?
Is there a way to sync it with local time?
(This post was last modified: 2017-02-14 16:23 by dinor.)
find quote
UberG2 Offline
Junior Member
Posts: 1
Joined: Jun 2017
Reputation: 0
Post: #8
This is a ME TOO reply... I have the same problem as dinor. Curious if anyone has found a fix and/or if there are any suggestions on how best to diagnose this? Interestingly enough, if I run kaffeine on the same system with my tuner board (same OS/hardware, etc.) it IS able to pull the EPG data for my ATSC channels, so it seems to be an issue with VDR. I pulled all the latest source and successfully built VDR and use it successfully within Kodi w/o any issues with the exception of no EPG data. BTW the TIME for any recordings is defunct the same a dinor... mine actually show up 12/31/1969. Tried both enabling and disabling the time setting in the setup.conf file for VDR, but that doesn't seem to make any difference. Any tips and/or redirection appreciated!
find quote