•   
  • 1
  • 20
  • 21
  • 22
  • 23(current)
  • 24
  •   
Release Catch-Up TV & More
@wwark

Live TV - United Kingdom - Free Sports is not working
404 Client Error - Not Found for URL

Please have a look, thanks
Reply
Hi, 
thanks for the add-on, but it appears all the CCTV (Chinese TV) links are broken.
" [Catch-up-TV-&-More.support] Expecting value: line 1 column 1 (char 0) "
Could you look into this?

if I understand the error message correctly, the content that liveHtml5.do returns is now

" var html5VideoData = '{"ack":"no","status":"2"}';getHtml5VideoData(html5VideoData); "

without further information. 

thanks
Reply
On Kodi-19 I'm trying to replace the script.module.youtube.dl Kodi addon with script.module.yt-dlp since youtube-DL is dormant and not keeping up with changes which are breaking it. I want to share my experience to see if the behaviors are expected, if there is a workaround, or if it looks like I'm doing something very wrong.

I thought that I could do a simple replacement, but I have found some issues that require some rework. I'm testing using several applications, including this one. My success is spotty. I can fairly reliably download 'live TV shows that I can view' to disk. Live TV generally plays, but a number of shows are blocked due to geography, a license, etc. But I can play and download a few.

So far, I have been unable to play Website videos. I get various errors, which have changed through the day, which seems to be a youtube thing. At first I was getting errors about reusing a stream with a different server. Then, I noticed some urls which repeated the url prefix: 'https://youtube.../https://youtube... Now I'm getting no-permission (pasting url in browser gives same behavior). I have also seen what appears to be a few utf-8 issues, which I have tried to patch. Other than that I see "index out of bounds' errors while navigating some of the live-tv pages (which I don't think are related to yt-dlp).

I big challenge for me is that although I have used youtube-dl in my (unreleased) addon, I am not an expert at it. I find that I'm having to learn a lot in a short period of time (filters, internals, multiple apis) and I don't know how the apis should behave, other than through experimentation. (Welcome to programming)

Any comments are welcome
Reply
(2021-10-12, 00:28)kevwag Wrote: I'm having the same problems trying to use UKTVPlay with this addon. Unbound Local Error: local variable 'data_account' referenced before assignment.
Is the addon still maintained or is it now defunct? I see that people have been reporting this issue for several months now and there has been no response from the developer.
I've also noticed there's a problem with the EPG integration - the EPG shows no information for any UK channel, although the standalone guide within the addon DOES contain programme info.
Last of all, the feature that offers to upload your logfile when an error occurs, itself fails, saying "Unable to retrieve the paste url".

Is it even worth providing any more information, or is this addon dead in the water?

Same problem 4 months later: in Settings>Accounts I have provided my UKTV username and password, but I receive error messages as above. Is there any cure? Is there going to be any cure?
Reply
(2022-02-03, 11:04)ardeley Wrote:
(2021-10-12, 00:28)kevwag Wrote: I'm having the same problems trying to use UKTVPlay with this addon. Unbound Local Error: local variable 'data_account' referenced before assignment.
Is the addon still maintained or is it now defunct? I see that people have been reporting this issue for several months now and there has been no response from the developer.
I've also noticed there's a problem with the EPG integration - the EPG shows no information for any UK channel, although the standalone guide within the addon DOES contain programme info.
Last of all, the feature that offers to upload your logfile when an error occurs, itself fails, saying "Unable to retrieve the paste url".

Is it even worth providing any more information, or is this addon dead in the water?

Same problem 4 months later: in Settings>Accounts I have provided my UKTV username and password, but I receive error messages as above. Is there any cure? Is there going to be any cure?

There already IS a cure but I don't know if it's been merged into a downloadable release yet, It hasn't made it as far as the Kodi repo - I know that much!
I've been running the fixed version since December but I had to manually apply the fix which involves replacing a few lines of python code in one of the files and then replacing the file into the addon zip. You could just edit the file directly in the installed addon but any updates from the repo will just un-fix it until they've merged the fix into a release.

Here's what you need to do...
1. Install the addon from the Kodi repo and enter your UKTV Play login in the settings.
2. Go to the developer's GitHub page then change the branch from the Master branch to the Dev branch in the drop-down menu.
3. Download the zip file for latest developer release of the addon (Click the green "Code" drop-down and select "Download zip file".
4. Extract this file from the zip: /resources/lib/channels/uk/uktvplay.py
5. Open the file in a text editor (Notepad++ is best as it shows the line numbers which will make things easier)
6. Select everything between lines 254 and 266 and paste these four lines in their place:

  # Get data_account / data_player
  resp = session_requests.get(URL_ROOT)
  data_account = re.compile(r'//players\.brightcove\.net/([0-9]+)/[^_]+_default/').findall(resp.text)[0]
  data_player = re.compile(r'//players\.brightcove\.net/[0-9]+/([^_]+)_default/').findall(resp.text)[0]

Important: These lines of code must have the same number of spaces in front of them as the lines above (249/250) so that they line up vertically. This is not just for neatness - if they don't align, you'll get an error and it won't work.

7. Save the file and close Notepad++
8. Add the .py file back into the zip file (make sure it goes back to the same folder path and overwrites the original py file).
9. Open Kodi, Install the modified zip and enjoy!

Also fairly important: Although this method does fix the UKTV Play bug, the addon will no longer update from any online repo, either automatically OR manually. On the plus side, this means that it will never get "un-fixed" by an un-patched update but it also means that you will eventually fall behind on other fixes and updates as they are released. I would suggest checking back on the dev's GitHub page once a month, downloading the latest release from the Master branch and trying it out to see if the fix has been merged. If it works then just install the Master branch repo zip to receive updates / notifications directly from the developer's repo. If it still doesn't work then just re-install your modded zip (you won't lose any of your settings) and try again next month!
Reply
Hi I have been looking for support to access tv5monde+
It appears that in this forum this is the last post.

Is it possible to have with this pluggin somehow acces to tv5monde+ (its like a small netflix portal from tv5monde that is made availbe internationally - no geoblocking).
That would be great.

Additionnally I have seen that in the config there is a possibility to login for some UK TV station.
France Television now requires a email-login to access some content on their webseite (even in France) any chance to integrate to get access to that too?

Thank you so much for a response if that could be managed or if you can point me to some other add-on/solution
Reply
Hi all. I first came across Kodi several years ago. I gave up using it that time after several weeks of spending more time searching for something that worked, than actually watching anything.
I decided to try it again today on my Fire TV stick. And on the whole it does seem to be much improved now that rouge addons have been banned. I did however run into a couple of problems. One was a skin was causing Kodi to become unresponsive. The other is the same as mentioned above IE not being able to access UKTVPLAY. I note that the post above dates back to 2007. Yet looking on Github, the folders and files have been accessed within the last 2 years. I would be very surprised if in all this time the author of the addon hasn't come across this problem (of course he/she may not have an account with UKTVPLAY). And with addons being open source, I'm surprised no one with required knowledge has applied a fix to the code.

As the problem has been mentioned before I don't think there's any point posting an error log. And apart from that. I don't know how to get a log from my firestick to my laptop. I haven't been through all the addons yet. But if I do come across any more errors. I will try to post in the relevant places.

Almost forgot. Related to the above error. Kodi reported it couldn't send the log as it couldn't retrieve the paste url.
Reply
Tongue 
Sorry I don't seem to be able to edit my previous post. So please ignore what I wrote regarding dates. And please accept my apology. I read the date format wrong.
Reply
Hi!

Just wondering, the connection to IPTV Manager seems to be more and more distant.
That addon seems to slowly fade away.
Are there any plans to switch to something else or to get it to work again ?
Reply
Update manually to v0.2.37 or v0.2.38 beta (Beta Repository).

https://github.com/Catch-up-TV-and-More/...ag/v0.2.37

Beta Repository:
https://github.com/Catch-up-TV-and-More/...-0.0.6.zip
Reply
(2022-02-03, 11:04)ardeley Wrote:
(2021-10-12, 00:28)kevwag Wrote: I'm having the same problems trying to use UKTVPlay with this addon. Unbound Local Error: local variable 'data_account' referenced before assignment.
Is the addon still maintained or is it now defunct? I see that people have been reporting this issue for several months now and there has been no response from the developer.
I've also noticed there's a problem with the EPG integration - the EPG shows no information for any UK channel, although the standalone guide within the addon DOES contain programme info.
Last of all, the feature that offers to upload your logfile when an error occurs, itself fails, saying "Unable to retrieve the paste url".

Is it even worth providing any more information, or is this addon dead in the water?

Same problem 4 months later: in Settings>Accounts I have provided my UKTV username and password, but I receive error messages as above. Is there any cure? Is there going to be any cure?
I have the same problem
Reply
I Had the same problem today. I changed the 3 lines of code as suggested above and a couple more.
Line 27
URL_BRIGHTCOVE_DATAS = 'https://s3-eu-west-1.amazonaws.com/uktv-static/prod/play/%s.js'
change to
URL_BRIGHTCOVE_DATAS = 'https://s3-eu-west-1.amazonaws.com/uktv-static/fgprod/play/%s.js'
and Line 31
URL_BRIGHTCOVE_POLICY_KEY = 'http://players.brightcove.net/%s/%s_default/index.min.js'
change to
URL_BRIGHTCOVE_POLICY_KEY = 'https://players.brightcove.net/%s/%s_default/index.min.js'

I don't have a UK TV account and it works fine without one (today at least!).
This is the path in Windows 10
C:\Users\[UserName]\AppData\Roaming\Kodi\addons\plugin.video.catchuptvandmore\resources\lib\channels\uk\uktvplay.py
Change [UserName] to your username
Hope that helps.
Reply
When trying to open videos from Japan I get following message.
None Type object has no attribute Find All
Worked fine previously. Live tv still is fine. Catch up tv videos from other countries work. At least from the limited number I've opened.
Started from Leia and I reinstalled Kodi and it is now 19.4. Tried reloading latest Catch-Up TV both stable and beta with no luck.
Reply
@Lawrence65 - your thread/post above has been merged into the Catch-up TV & More support thread (this current one).

This is just a courtesy post to let you know where it went, just in case you couldn't find it.
|Banned add-ons (wiki)|Forum rules (wiki)|VPN policy (wiki)|First time user (wiki)|FAQs (wiki) Troubleshooting (wiki)|Add-ons (wiki)|Free content (wiki)|Debug Log (wiki)|

Kodi Blog Posts
Reply
Is STV (Catch-up TV, United Kingdom) still working for anyone?

I'm getting a TypeError message trying to watch content, was fine up until a week ago.

Relevant error in log seems to be:
Code:
ERROR <general>: EXCEPTION: argument "path" for method "setPath" must be unicode or str
Reply
  •   
  • 1
  • 20
  • 21
  • 22
  • 23(current)
  • 24
  •   



Logout Mark Read Team Forum Stats Members Help
Catch-Up TV & More1
This forum uses Lukasz Tkacz MyBB addons.