•  Previous
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 61
  • Next 
 
Thread Rating:
  • 10 Vote(s) - 4.8 Average
EMINENCE 2 MOD (REVIVED)
#16
Updated the first post with a new version.

2.2.1
1. Added a clickable seekbar.
2. Added new colour themes.
3. Shortened the skin name.
4. Added new icons.
5. Tweaked the subtitles menu.
6. Small fixes.

I've finally added a clickable seekbar, should work in all cases, including when the info on pause is enabled. Clicking on the bar that normally shows the progress and cache, and it should work. For this to be effective, however, I've had to tweak the subtitle pop-up. It's not automatic anymore, you now have to click on the subtitle button in the OSD bar to make the menu appear. All the other buttons work as before.

I've also added icons and colour themes from Eminence. Instead of using the dark shadowed interface, you can use the "Black Glass" colour theme for a similar effect, though not skinned with that definition. You can also mix and match the colour schemes with the existing options for interesting combos. Anyways, it's just another thing you can tweak to your preference.


@GuRu23: That's strange, I've looked at the code, and it really shouldn't be happening. Nevertheless, I've added more verbatim conditions in this update, just in case. Please check it out.

@majeida: As far as your other question is concerned, you need to edit the position of the Home_NowPlaying include, that's located in Includes_Home.xml, starting with line 1610. There are no long tiles in the skin originally, so be careful what you change. That might've caused the slowdowns you mentioned, since the skin is as fast for me as it's ever been.
Eminence 2 MOD, Revived & Improved

If you've found me helpful, eh, maybe press the thanks button? If you like, you can click here for donations. :)
Reply
#17
Quote:@majeida: As far as your other question is concerned, you need to edit the position of the Home_NowPlaying include, that's located in Includes_Home.xml, starting with line 1610. There are no long tiles in the skin originally, so be careful what you change. That might've caused the slowdowns you mentioned, since the skin is as fast for me as it's ever been.
@Alanon thx Smile for slowdowns mentioned before I use v2.2 skin without any change. i will try v 2.2.1 maybe fix my issue
Reply
#18
@Alanon i think the problem for slowdowns mentioned before is related to Busy Spinners selctor in skin setting,

<setting id="SkinHelper.SpinnerTexture" type="string">Tube Pressure</setting>
<setting id="SkinHelper.SpinnerTexture.org" type="string"></setting>
<setting id="SkinHelper.SpinnerTexturePath" type="string"></setting>
<setting id="SkinHelper.SpinnerTexture.label" type="string">Images multiples personnalisées (dossier)</setting>
<setting id="SkinHelper.SpinnerTexture.name" type="string">Images multiples personnalisées (dossier)</setting>
<setting id="SkinHelper.SpinnerTexturePath" type="string">special://skin/extras/busy_spinners/Tube Pressure</setting>
Reply
#19
(2017-02-22, 02:43)majeida Wrote: @Alanon i think the problem for slowdowns mentioned before is related to Busy Spinners selctor in skin setting,

<setting id="SkinHelper.SpinnerTexture" type="string">Tube Pressure</setting>
<setting id="SkinHelper.SpinnerTexture.org" type="string"></setting>
<setting id="SkinHelper.SpinnerTexturePath" type="string"></setting>
<setting id="SkinHelper.SpinnerTexture.label" type="string">Images multiples personnalisées (dossier)</setting>
<setting id="SkinHelper.SpinnerTexture.name" type="string">Images multiples personnalisées (dossier)</setting>
<setting id="SkinHelper.SpinnerTexturePath" type="string">special://skin/extras/busy_spinners/Tube Pressure</setting>

A while back a lot of the spinner textures were relegated to the resource add-on. The strings you have in your settings are very old, so that indeed might be a part of the problem, though I don't know why it would appear just now. Try to install the resource add-on, and select a spinner from it, or otherwise reset the path to the spinners available in the skin.
Eminence 2 MOD, Revived & Improved

If you've found me helpful, eh, maybe press the thanks button? If you like, you can click here for donations. :)
Reply
#20
@Alanon: I still see the WebDL icon .. but don't get me wrong - this is not very important to me Smile

Image
Reply
#21
Hi. I love your skin. Is it possible to add a bit more transparant theme?
Now the video player OSD is black. It would be great if you could make an option where I can change that. Or maybe there already is, but I couldn't find it. Thanks
Reply
#22
(2017-02-22, 21:29)Aaiemron Wrote: Hi. I love your skin. Is it possible to add a bit more transparant theme?
Now the video player OSD is black. It would be great if you could make an option where I can change that. Or maybe there already is, but I couldn't find it. Thanks

You can toggle the transparency in the skin settings. Under 'Home bar color and opacity' for instance.....
Reply
#23
Hi Alanon,

Is it possible to change the default language for the media info? I've selected to search for movie info in dutch, but the widget and movie menu still shows the movie info in english.
Reply
#24
(2017-02-22, 22:04)SkywalkerPD Wrote: Hi Alanon,

Is it possible to change the default language for the media info? I've selected to search for movie info in dutch, but the widget and movie menu still shows the movie info in english.
Umm, technically, it should already be done just by changing the scraper settings and rescraping. There's nothing in the code defining specific languages, it's just the values.

The only thing I can think of is that the Kodi cache somehow wasn't cleared properly, and continued displaying the previous info. This can be tested if you add a movie that wasn't in your library before, or if you remove, restart and then rescrape an existing item.
Eminence 2 MOD, Revived & Improved

If you've found me helpful, eh, maybe press the thanks button? If you like, you can click here for donations. :)
Reply
#25
(2017-02-22, 21:53)SkywalkerPD Wrote:
(2017-02-22, 21:29)Aaiemron Wrote: Hi. I love your skin. Is it possible to add a bit more transparant theme?
Now the video player OSD is black. It would be great if you could make an option where I can change that. Or maybe there already is, but I couldn't find it. Thanks

You can toggle the transparency in the skin settings. Under 'Home bar color and opacity' for instance.....

Yes I know, but that,'s only for the homebar. What I mean is if it's possible to make the menu and the player osd more transparant?
Reply
#26
(2017-02-22, 20:44)GuRu23 Wrote: @Alanon: I still see the WebDL icon .. but don't get me wrong - this is not very important to me Smile

Well, if it were me and I had just that one icon standing there, I'd be annoyed. xD So I'll keep looking into it, but I'd appreciate some more info in order to reproduce the bug. For instance, are all the titles with the icon actual web-dl files, or is it in anyway random? Also, if you enable hub flags, does the webdl display or not? Basically, I'm looking for any pattern.

(2017-02-22, 21:29)Aaiemron Wrote: Hi. I love your skin. Is it possible to add a bit more transparant theme?
Now the video player OSD is black. It would be great if you could make an option where I can change that. Or maybe there already is, but I couldn't find it. Thanks

First off, you're right, there's currently no setting for the osd colouring of any kind. However, there are some considerations to be made. First, the upper set on infos is a mish-mash of content re-used in many other parts of the skin, so any tweaking there would require quite a bit of overhauling, and I'm not sure on just how nice large, near-transparent text would look on during video playback.

Second, while it shouldn't be too much trouble to add something like it, I'm worried about the potential for bad colour combinations and the consequences for overall legibility. A bad combo of accents and main colour coupled with a near-transparent or ill-coloured back could quickly render things unreadable.

Basically, I think it might turn out to be an interesting option to have. I'm inclined to keep the colours and the top elements as they are, but perhaps add an option for the OSD and info-on-pause that's semi-transparent (off the top of my head, something like 25-35% seems appropriate)? Perhaps even add an opacity slider of sorts? These are all just projections of course, as I've no idea as to how good it would actually look, and a lot would depend on that.
Eminence 2 MOD, Revived & Improved

If you've found me helpful, eh, maybe press the thanks button? If you like, you can click here for donations. :)
Reply
#27
(2017-02-22, 21:29)Aaiemron Wrote: Hi. I love your skin. Is it possible to add a bit more transparant theme?
Now the video player OSD is black. It would be great if you could make an option where I can change that. Or maybe there already is, but I couldn't find it. Thanks

First off, you're right, there's currently no setting for the osd colouring of any kind. However, there are some considerations to be made. First, the upper set on infos is a mish-mash of content re-used in many other parts of the skin, so any tweaking there would require quite a bit of overhauling, and I'm not sure on just how nice large, near-transparent text would look on during video playback.

Second, while it shouldn't be too much trouble to add something like it, I'm worried about the potential for bad colour combinations and the consequences for overall legibility. A bad combo of accents and main colour coupled with a near-transparent or ill-coloured back could quickly render things unreadable.

Basically, I think it might turn out to be an interesting option to have. I'm inclined to keep the colours and the top elements as they are, but perhaps add an option for the OSD and info-on-pause that's semi-transparent (off the top of my head, something like 25-35% seems appropriate)? Perhaps even add an opacity slider of sorts? These are all just projections of course, as I've no idea as to how good it would actually look, and a lot would depend on that.
[/quote]

That sounds great if you can add such an option. Thanks in advance.
Reply
#28
(2017-02-22, 22:41)Alanon Wrote:
(2017-02-22, 20:44)GuRu23 Wrote: @Alanon: I still see the WebDL icon .. but don't get me wrong - this is not very important to me Smile

Well, if it were me and I had just that one icon standing there, I'd be annoyed. xD So I'll keep looking into it, but I'd appreciate some more info in order to reproduce the bug. For instance, are all the titles with the icon actual web-dl files, or is it in anyway random? Also, if you enable hub flags, does the webdl display or not? Basically, I'm looking for any pattern.

Hi Alanon,

it seems that the Movies in question are actual WebDLs. But if I toggle the hub flags setting on, the WebDL logo don't show up here (or any other file format logo for this matter)
Reply
#29
The first link was updated with a new option.

2.2.2
1. Added an opacity setting for the OSD.

You can now find a setting controlling the opacity of the OSD. I've opted for four options ranging from 60-90% of the original opacity. The default should always be the same as before. IMHO, 90% and 80% work best, adding just a tinge of transparency and lightness to the interface, while the latter two are bordering on non-readable layouts, but they still look good if you're not using the info screen.



@GuRu23: I'm a bit stumped. I've rechecked the code that controls the flags, and all is in order. But, since the code is correct, this might be a case of a bugged-out setting, especially if you've experienced the flags disappearing after you've toggled the setting on. The settings file has a bad habit of simply listing every string and variation that ever entered the skin set-up at any point.So the longer you've had it, the bigger the potential for trouble.

Try to go to settings.xml, located in the userdata folder of your Kodi installation, then find and delete the value "furniture.showhubflags" from the file. This should at least allow for the setting to properly re-populate itself. If this doesn't work, deleting the entire settings.xml might do better. It wouldn't mess with the menus and submenus, only the skin settings, which you'd have to recreate. Perhaps even placing the widgets in their places again would help. All these suggestions are a shot in the dark, though. Confused
Eminence 2 MOD, Revived & Improved

If you've found me helpful, eh, maybe press the thanks button? If you like, you can click here for donations. :)
Reply
#30
Thanks a lot for adding the opacity setting for the OSD.
Reply
  •  Previous
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 61
  • Next 



EMINENCE 2 MOD (REVIVED)4.810