•   
  • 1
  • 78
  • 79
  • 80
  • 81
  • 82(current)
EMINENCE 2 MOD (REVIVED)
To have an easy access on remote to info page (movie, serie or All other info) you can just use keymap editor addon. With this one you can set any kodi Link on any key of your remote.
Reply
Thanks for the reply, remote only has 4 buttons lol. I'll keep tinkering.
Reply
Hi Alanon
Just been re-installing my Kodi/Eminence setup and notice that some of the links at item #1, above, are now dead. Should they be deleted?

Under
Skin Dependencies: Script Image Resource Select
Additional Add-ons: Global Search, Youtube, cu.lrclyrics, Script PlayAlbum

Cheers
Reply
@Vitruvius3 Good catch! ronie moved all his content from github to gitlab, I changed all the links, they should work now!
Eminence 2 MOD, Revived & Improved

If you've found me helpful, eh, maybe press the Like button? If you like, you can click here for donations. :)
Reply
Thanks Alanon!  I have now downloaded fresh copies of all the ZIP files referred to at item #2, above.

On a separate issue, I’ve tried to install Eminence (skin.eminence.2.mod-master.zip) on Leia Alpha 3 (Windows 64bit version), but get an error message: 
“Failed to install add-on from zip file.  The dependency on script.shortcuts version 1.10.18”.
This is despite repository.alanon-1.02.zip and repository.marcveldt-1.0.1.zip being installed.

I’ve tried unpacking and pasting the Eminence zip as you suggested at #2, but to no avail. Is this something that you are still developing?
I notice that Leia Beta 1 seems to be at an advanced stage so may be about to be released. https://github.com/xbmc/xbmc/milestones
Cheers
Reply
@Vitruvius3 The skin should be fully functional. I'm currently running Leia x64, one of the nightly builds from a few days ago. This version is the latest one released to the repo. I have worked on some minor fixes since then, but nothing that would cause install issues. The skin requires skinshortcuts version 1.0.18, and that is the latest version in marcel's repo. By now, it's also very old, so that shouldn't be the problem either. I have noticed problems with Leia on windows when downloading many dependencies, and this applies mainly to fresh installs. Basically, during first installs of complex add-ons, Kodi needs to install not just, for example, skinshortcuts, but all the dependencies that skinshortcuts needs, which are usually small add-ons and Python modules. Kodi needs to do it before installing the add-on itself, and so there can potentially be dozens of add-ons that all have to be downloaded and installed that very first time. Subsequent updates are much faster and easier, as these small dependencies are usually not updated that often.

Anyway, it's possible that for whatever reason Kodi had issues downloading one of these files, causing the skinshortcuts dependency to fail to install, which in turn aborted the skin installation, which is the usual reason for such notifications. The problem is, if skinshortcuts doesn't have its proper dependencies installed for whatever reason, the add-on itself won't work properly if pasted in the addons folder, and the skin won't work without the add-on, like a chain reaction. I'm not sure how all this was handled in Krypton, but it seems that something changed in Leia which complicates things, at least for Windows users. Basically, you need to confirm that all the Eminence dependencies managed to install properly (along with their own dependencies), which you can do by installing them one by one from within Kodi (install as zip). That should make sure that, even if previous attempts were incomplete, the add-on itself tracks down its own dependencies and installs them. In the end, you can try and install the skin itself.

As a side note, when you paste a skin directly in the folder, it's automatically disabled. In order to get it to appear in the skin selection menu, you have to enable it from the add-on browser.
Eminence 2 MOD, Revived & Improved

If you've found me helpful, eh, maybe press the Like button? If you like, you can click here for donations. :)
Reply
Thanks for the detailed reply. All sounds like a bit of a headache.

I don’t know whether it is helpful, but for info, I loaded a clean install of Leia (Windows) nightly build dated 17 August 03:48, and then attempted to individually install all the zips from within Kodi that are referred to at item #2.
The following failed to install, citing problems with various scripts and dependencies:
  script.extendedinfo-master.zip
  plugin.program.autocompletion-master.zip
  service.library.data.provider-master.zip
  service.nextup.notification-master.zip
  script.artistslideshow-master.zip
  script.colorbox-master.zip
  script.cu.lrclyrics-master.zip
  script.toolbox-master.zip
Selecting Eminence via ‘Get more skins’ showed that dependency was not satisfied for Eminence 2MOD with script.module.simplejson v 3.3.0, and for Eminence 2.0MOD with XBMC.gui v 5.12.0

I then re-tried a similar clean install of Leia Alpha 3 (Windows 64 bit).
Script.colorbox-master.zip and plugin.program.autocompletion-master.zip failed, while the Eminence skin still showed the "script.shortcuts version 1.10.18" error. 

I’m afraid I lack the expertise to offer any practical advice on all this, but I would be happy to carry out any routine tests if that helps.  
Thanks again for all your input.  Much appreciated!
Reply
@Vitruvius3 Sorry for the late reply. I've been trying to replicate your issues by installing a fresh copy of Leia and setting it all up from scratch. I set up two installations, one portable on my machine, and a regular install on a PC without any previous Kodi installation, all running the latest Win10 x64 with all the updates. It all went pretty much smoothly from start to finish with only the two repos. After starting Eminence installation, I was greeted with a list of all the add-ons that would be installed, and pretty much all of them were retrieved without any trouble, with the whole process over in just a couple of minutes. 

As far as what you are describing, it makes sense that the skin won't work, as it needs at least some of those add-ons to even start up properly. So, the issue is with all the dependencies of the add-ons you tried to install initially. At this point, the only thing I can think of that might cause that number of errors is if you can't connect to the Kodi servers to retrieve all those dependencies the add-ons need. I'd check and make sure that Kodi connects to the internet properly, that you're running it as Administrator, without firewall restrictions or anything like that.

Unless it's a firewall issue, I'm not sure why the Alpha would achieve different results. Incidentally, since you managed to install most of the add-ons on the Alpha, did you perhaps try and paste the skinshortcuts and colorpicker folders in their appropriate location, and then enable/install Eminence?
Eminence 2 MOD, Revived & Improved

If you've found me helpful, eh, maybe press the Like button? If you like, you can click here for donations. :)
Reply
Success!!!  But I’m afraid I don’t know why, as I am using the installation I created a few days ago and haven’t made any changes to Windows or Kodi.  I can only think it was some sort of Firewall or Server issue, as you suggested, so apologies, and thanks for your time.   
I’ve shown below what I did on the off chance that it might be helpful to someone else. 
I’m running a fully updated version of Windows 64 Pro.  

Last week’s Eminence installation
I installed all the ZIP files at item #2 (above) using the ‘Install from ZIP file’ menu. I did not perform any pastings.
I checked the progress after installing the 3 main Eminence ZIP files, and only proceeded to install the ‘Additional’ and ‘Skin Dependency’ ZIP files when that installation failed.
Rebooting the PC and waiting did not fix it 

Today
Did not install/reinstall any Eminence ZIP files
All I did was open up last week’s installation and chose ‘Get More Skins’.
Was given the choice of Eminence 2MOD and Eminence 2.0MOD
Selected the first. It ran, but reported that the installation had failed as it had failed to install various (listed) dependencies.
Rebooted the PC and selected Eminence 2MOD again.  This time it opened without any problems.
Fantastic. Switched to that skin. 

Returned to ‘Get More Skins’.  This now only showed Eminence 2.0MOD
Tried to install that skin but it showed ‘dependency on XBMC.GUI version 5.12.0 could not be satisfied’.
Installed the script duration zip as a possible solution
Rebooted the PC.
Windows message appeared requesting Firewall clearance for Kodi.exe
OK to that
Rebooted
Eminence 2MOD OK, but Eminence 2.0MOD still failing.  I presume (?) that this must be the Krypton version. 
Hope that’s helpful 

Cheers
Reply
  •   
  • 1
  • 78
  • 79
  • 80
  • 81
  • 82(current)
 
Thread Rating:
  • 13 Vote(s) - 4.85 Average



Logout Mark Read Team Forum Stats Members Help
EMINENCE 2 MOD (REVIVED)4.8513