Kodi reduced in UI reduced to quarter size in top left corner after
#1
Hi guys I am hoping someone can help me with an issue i keep having. When I switch my tv back on after leaving kodi (v17.0 problem also occured under v16) running on my win 10 htpc sometimes it is reduced to a quarter size in the top left corner of the screen (not just when playing video). It is solved by changing the system settings > display > Fullscreen to windowed and back again. But it is driving my wife (and me) mad.

the GFX card (AMD Radeon HD 6450) has upto date drivers (15.201.1151)

Here is a paste bin of my log file http://pastebin.com/NtApFe6p


around 9.23 (line 2193) switched the tv back on and had to reset the display properties to fix the quarter screen issue.

Quote:08:59:53.061 T:6248 NOTICE: VideoInfoScanner: Finished scan. Scanning for video info took 00:13
09:23:51.236 T:10752 ERROR: PERIPHERALS::CPeripheralCecAdapter::OnTvStandby - Unexpected [standby_pc_on_tv_standby] setting value
09:23:52.692 T:1408 NOTICE: Found screen: Dummy Monitor on AMD Radeon HD 6450, adapter 0.
09:23:52.725 T:7508 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer
09:23:52.757 T:1408 NOTICE: Primary mode: [email protected] 60.00 - Full Screen
09:23:52.778 T:1408 NOTICE: Additional mode: [email protected] 60.00 - Full Screen
09:23:52.781 T:1408 NOTICE: Additional mode: [email protected] 60.00 - Full Screen
09:23:52.783 T:1408 NOTICE: Additional mode: [email protected] 59.94 - Full Screen
09:23:52.784 T:1408 NOTICE: Additional mode: [email protected] 60.00 - Full Screen
09:23:52.785 T:1408 NOTICE: Additional mode: [email protected] 60.00 - Full Screen
09:23:52.786 T:1408 NOTICE: Additional mode: [email protected] 60.00 - Full Screen

Any help with this would be much apreciated. I am thinking it is to do with the tv being seen as a dummy monitor?
Reply
#2
This? (See item 5.1). Blocking pin 19 with a tiny sliver of tape fixed this issue for me.

http://kodi.wiki/view/Displays

There's a commercial product that does the same thing, too: http://monitordetectkiller.com/
Reply
#3
This is a long-standing problem, I guess has to do with how Windows announces display changes to apps. I use a mini-keyboard device to control Kodi and default key "\" pressed twice fixes it. I can see if you don't have a keyboard it can be a bit more of a PITA.

scott s.
.
maintainer of skin  Aeon MQ5 mods for post-Gotham Kodi releases:
Matrix see: Aeon MQ5 Mod Martix release thread
Leia see: Aeon MQ5 Mod Leia release thread
Reply
#4
does your HTPC run into an amp, then into the TV?
Reply
#5
It is going into a Sony Bravia TV (Pulse eight USB - CEC Adapter , not a AV Amp). I am surprised this isn't a bigger issue for more people. I am not sure I like the idea of sticking tape to the pin in case it comes off inside my exspensive tv and I suspect it will stop the tv remote controlling the tv (the reason I have a pulse eight cec adapter. I also dont feel this is a great answer.

I like the quick fix of the "\" button but it is a hassle doing it each time and getting the wireless keyboard out. I have mapped it to a key on my tv remote using the "Keymap editor" addon. but i still consider this a quick fix not a solution.

Has anybody fixed this issue in the past? It does seam to happen more since I upgraded to v17
Reply
#6
This was a huge irritation to me until I ran across the pin 19 trick. The other option that worked for me (for a while) was to leave my receiver on 24/7, but of course that wasn't ideal. If you get the monitor detect killer hdmi dongle you won't risk losing a sliver of electrical tape into the innards of your hardware.
Reply
#7
snarfo: Did you loose CEC control with disabling the pin 19 / monitor killer dongle?
Reply
#8
I had this issue as well. It happens when switching from Window'd Mode to Full Screen. It's a Windows 10 issue with some video cards. I never had this problem until I upgraded to Windows 10 from 7. If you see this, just go to settings and switch to your display size. Mine would show as 1080p, I'd set it to 1080i and all was well.
Reply
#9
Yeah..if I change my TV (LG LM7600) screen to 1280X720 no problem Kodi stays there like it should when the TV gets powered off/on. Any higher resolution and the problem reappears.

Maybe at lower settings pin 19 isn't functional?
Reply
#10
I appreciate that this problem was introduced by a Windows 10 update, but I am not having this issue with any other application. Isn't this therefore a bug that should be fixed in KODI?
Reply
#11
Have you tried Launcher4Kodi to keep Kodi in focus when it launches and close it automatically when the PC is put to sleep? Using a Harmony remote and sending commands to open and close Kodi when you're not using it might also help.
Reply
#12
(2018-08-17, 19:37)Warner306 Wrote: Have you tried Launcher4Kodi to keep Kodi in focus when it launches and close it automatically when the PC is put to sleep? Using a Harmony remote and sending commands to open and close Kodi when you're not using it might also help.
Hi, yes I did give that a go but it didn't resolve the issue. I can't remember the details now but I ended up having to uninstall it.
Reply
#13
Some time ago i ran into this issue and didn’t like the ‘pin19’ trick.

I found a method where one extracts the edid information of your hardware so that it would create a .inf driver that, as i understood it, would simulate an ‘always on’ situation independant of the actual state.

Never went through with it in the end because i have switched to linux where the issue doesn’t occur for me, but it might be worth a try in your case.

Have a look here:

https://forum.kodi.tv/showthread.php?tid=251833

It’s describing the procedure for audio issues, but it should take care of any hdcp handshake issues. Apply it and see if it accomplishes a screen fix.

I am actually curious if it will since i never got around to it.

Hope it helps.
Reply
#14
This is an old solution, I don't know if it's even relevant still..?

Source.
Quote:I was having similar issues with an ATI card with an HDMI connection, when I would turn off the tv, or change inputs. My issue was due to HDMI handshake issues when i would come back to my HTPC input. My fix was to stop and disable the AMD external events service. Seems like i had to reboot before it recognized i disabled it however.
Reply
#15
@WeirdH 

It might work, would depend on the hardware (mostly AMD, doubt Nvidia or Intel) and if the software included the ability to turn off AMD external events service. The real issue is the hadshaking and HDCP and in that there have been many work-rounds, and the wiki and threads contain various solutions.
Reply



Logout Mark Read Team Forum Stats Members Help
Kodi reduced in UI reduced to quarter size in top left corner after0
This forum uses Lukasz Tkacz MyBB addons.