Lost websocket connection
#1
I am getting a websocket error while using chorus 2. It happens nearly every time I use chorus 2 to control my kodi installation. Any ideas how to resolve this?
Reply
#2
Same issue.

Update - I found the cause of my issue. My webserver port was set to 9090, which is the same port Kodi uses for the websockets server.
Cange your webserver port to something else in the services settings and see if that helps.
Platforms: Windows 10 - OS X - iOS - OSMC (Vero 4K)
Reply
#3
Unfortunately that isn't the same issue for me Sad
Some more information
Windows 10 x64
Kodi 17.1RC

I have tried multiple ports
opening both the web port and 9090 in the firewall
disabling the firewall

I get better results on chrome and edge(lost web sockets connection followed by a reconnecting message) after a few seconds the currently playing song will update.
Safari and IE(heh) never seem to reconnect or update the currently playing track.
Reply
#4
I'm also having this issue:

Kodi 17.1 final
macOS 10.12.3

Working correctly in Safari 10.0.3 (no websocket error message)

All of the following browsers show "Lost websocket connection":
  • Firefox 52.0.1 ("Firefox can’t establish a connection to the server at ws://192.168.0.50:9090/jsonrpc?kodi.")
  • Chrome 57.0.2987.110 ("WebSocket connection to 'ws://192.168.0.50:9090/jsonrpc?kodi' failed: Error in connection establishment: net::ERR_CONNECTION_REFUSED")
  • Opera 44.0.2510.857 (same console error message as chrome)
  • Vivaldi 1.7.735.46 (same console error message as chrome)

Possibly related to this bug
Reply
#5
I've got the same issue with Kodi v17.1 on Firefox v52.0.2...

Being a newbie, I guess I'll do more watching than contributing on this one Tongue
Reply
#6
Also here on a rpi3 + LibreElec 8.1.0 (Kodi 17.4), 1Gb LAN.
Doesn't matter which Browser i use. Any hint?
RPi3 | LibreElec Kodi
Reply
#7
Reverting to 17.3 fixes the websocket problem. So, looks like a change between 17.3 and 17.4 and not really related to Chorus2.
Image
AWXi - Ajax web interface. Wiki
Reply
#8
Still having this same issue with Kodi 17.6. Seeing repeated messages with both chrome and firefox. Any movement or solutions at all??
Reply
#9
Same here for v 18.1 running on mac os.
Happens with all Browsers all the time.
Reply
#10
I get the same in my Docker Kodi.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Lost websocket connection00