v17 Problem scanning library
#1
I have an issue where KODI hangs when updating my video library, it runs for anywhere between 10 and 60 seconds and then hangs, the interface remains responsive for another couple of minutes or so and then that freezes too, however the under lying OS is still running as I can browse the filesystem via ftp and download the log files.

I have 3 RPi's (2 RPi3 & 1 RPi2+) all running from a central MySQL database which is running on a Synology NAS which also holds the files, this setup has worked really well until recently, but I'm not sure whats changed to be causing this issue. I've monitored the resources/load on the SQL and NAS and they're not even close to breaking a sweat, I have restarted the NAS and only had a single RPi connected but still on joy.

Any help/advice would be greatly appreciated.

Bodi
Reply
#2
I have similar problems on my s905 box on libreelec.

Any updates? Smile I dont use external mysql database and i have problem only on one box :/ I got 3.
Reply
#3
From personal experience, it's usually a corrupted database that causes this. Find and delete the relevant database, rescan and all is generally well.
Reply
#4
(2017-03-26, 13:54)mcelliott Wrote: From personal experience, it's usually a corrupted database that causes this. Find and delete the relevant database, rescan and all is generally well.

Sometimes, yes Smile but for me its happen all the time also on new database. It happen on randomly file, sometimes scan without a problem, but hang on next source and corrupt database. It must be some hardware problem, but how to check it? All other functions work correctly, i mean live tv watching, movies etc. never hang up, i use it all the time. Only on library scan it hang (on two difference scrapers).
Reply
#5
Are you overclocking? If so try disabling.
How is power supply? Do you ever get warning symbols in top right corner of display?
What distribution and version of kodi are you running?
Reply
#6
(2017-03-27, 12:56)popcornmix Wrote: Are you overclocking? If so try disabling.
How is power supply? Do you ever get warning symbols in top right corner of display?
What distribution and version of kodi are you running?

1. Not overclocked.
2. Will check, never saw warning symbols.
3. [8.0.1a] LibreELEC 8.0 for S905/S905X by kszaq. Actually i use 3 device, wetek hub, and two mxq pro 4k. I have problem on one of mxq pro 4k box.
Reply
#7
(2017-03-27, 13:19)skupi Wrote: 3. [8.0.1a] LibreELEC 8.0 for S905/S905X by kszaq. Actually i use 3 device, wetek hub, and two mxq pro 4k. I have problem on one of mxq pro 4k box.

This is a raspberrypi thread so your issue may not be related to original poster's.
Reply



Logout Mark Read Team Forum Stats Members Help
Problem scanning library0
This forum uses Lukasz Tkacz MyBB addons.