epg and scandic characters

  Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
mr_kane Offline
Junior Member
Posts: 11
Joined: Mar 2017
Reputation: 0
Post: #1
I am running libreelec in my mxv s805 android box with great success, thanks to all contributors.

However, there is problem with epg, and this problem is seen in all my kodi installations (android, linux). I live in finland where we use nordic/swedish keyboard layout with few special scandic characters (ä, ö, å). They does not show up in epg information in kodi. Of cource they work fine in my mythtv frontends. As this problem appears in all my kodi frontends, I assume this is kodi or mythtv pvr addon problem.

I have checked all kodi language settings without luck. My friend runs kodi with argus backend and there characters are shown ok, so maybe this is myth pvr addon related?
find quote
raptorjr Offline
Fan
Posts: 503
Joined: Aug 2012
Reputation: 0
Post: #2
I use MythTV and have no problem with åäö in the EPG. Maybe you use a skin which use some font that don't have åäö? I use Estuary, Kodi default skin.
(This post was last modified: 2017-03-12 21:08 by raptorjr.)
find quote
mr_kane Offline
Junior Member
Posts: 11
Joined: Mar 2017
Reputation: 0
Post: #3
Thanks. I have jarvis, and use confluence default skin. Good to know that this should work.
But in settings menu there is äö present..
(This post was last modified: 2017-03-13 08:28 by mr_kane.)
find quote
mr_kane Offline
Junior Member
Posts: 11
Joined: Mar 2017
Reputation: 0
Post: #4
I tried different skin, but no difference.
Any advice where I could start looking for this problem?
find quote
janbar Offline
Posting Freak
Posts: 902
Joined: Sep 2012
Reputation: 49
Location: France
Post: #5
The root cause, as it couldn't show, is in your mythtv backend.
Since MythTV 0.25 the database mythconverg must to be configured using character set UTF-8. Also the host should use this character set to allow noconf convertion from external program.
You don't see any issue using mythfrontend because your front is on the same host as the backend and uses same character set rules.
So you should go to MythTV documentation/help wiki to know how to convert the database and backend host to the right charset.
find quote
janbar Offline
Posting Freak
Posts: 902
Joined: Sep 2012
Reputation: 49
Location: France
Post: #6
Once the database migration competed, the mythfilldatabase program will load guide data using the right character set (UTF-8).
find quote
janbar Offline
Posting Freak
Posts: 902
Joined: Sep 2012
Reputation: 49
Location: France
Post: #7
One thing more. Many guys missing this point also misses to configure time data in their database to enable UTC/local time convertion. You will find the help/doc about in same place : MythTV wiki.
find quote
mr_kane Offline
Junior Member
Posts: 11
Joined: Mar 2017
Reputation: 0
Post: #8
Thanks Janbar.
This was really helpful. Unfortunately it still does not work. First, I checked database charset:
Quote:mysql> SELECT default_character_set_name FROM information_schema.SCHEMATA WHERE schema_name = "mythconverg";
+----------------------------+
| default_character_set_name |
+----------------------------+
| utf8 |
+----------------------------+
1 row in set (0.00 sec)

Still I did this procedure to change charset:
Quote:mysqldump -umythtv -pmythtv -c -e --default-character-set=utf8 --single-transaction --skip-set-charset --add-drop-database -B mythconverg > dump.sql

sed 's/DEFAULT CHARACTER SET latin1/DEFAULT CHARACTER SET utf8 COLLATE utf8_unicode_ci/' <dump.sql | sed 's/DEFAULT CHARSET=latin1/DEFAULT CHARSET=utf8/' >dump-fixed.sql

mysql -umythtv -pmythtv < dump-fixed.sql
Also I added charset information to my.conf. Restarted mysql and mythbackend. Then I cleared kodi epg cache and restarted it. But still epg is missing scandic.

Is it possible that epg data is still in wrong format in database? I use EIT, not mythfilldatabase. Maybe backend collects future eit in right format? Or is there any other things I should check?

Edit. There is new inserts in epg database. There still is no scandic Confused
(This post was last modified: 2017-03-14 11:40 by mr_kane.)
find quote
janbar Offline
Posting Freak
Posts: 902
Joined: Sep 2012
Reputation: 49
Location: France
Post: #9
If all work then the following query SQL (using client mysql in the backend) should show awaited scandic characters:
Code:
select description from program where starttime > now()

Else, Is mythfrontend show scandic characters for those new inserts ?
find quote
mr_kane Offline
Junior Member
Posts: 11
Joined: Mar 2017
Reputation: 0
Post: #10
(2017-03-14 23:36)janbar Wrote:  If all work then the following query SQL (using client mysql in the backend) should show awaited scandic characters:
Code:
select description from program where starttime > now()

Yes, I tested it and scandic is ok.

(2017-03-14 23:36)janbar Wrote:  Else, Is mythfrontend show scandic characters for those new inserts ?

Yes it does.

I have no idea what to try next Confused
find quote
janbar Offline
Posting Freak
Posts: 902
Joined: Sep 2012
Reputation: 49
Location: France
Post: #11
You could try in your favorite browser the API call the addon uses as the following:
Code:
http:://[backend_ip]:6544/Guide/GetProgramGuide?StartTime=2017-03-15T00:00:00Z&EndTime=2017-03-15T23:59:00Z
The response should show the retrieved data by the addon. Please check scandic characters.
find quote
mr_kane Offline
Junior Member
Posts: 11
Joined: Mar 2017
Reputation: 0
Post: #12
Thanks for help, janbar.

I did that and scandic is ok. Below is one program listing as example.

Code:
<Program>
<StartTime>2017-03-15T07:30:00Z</StartTime>
<EndTime>2017-03-15T08:00:00Z</EndTime>
<Title>Puoli seitsemän</Title>
<SubTitle/>
<Category>Sosiaali/politiikka/ekonomia</Category>
<CatType>tvshow</CatType>
<Repeat>false</Repeat>
<VideoProps>2</VideoProps>
<AudioProps>1</AudioProps>
<SubProps>2</SubProps>
<Recording>
<Status>0</Status>
<Priority>0</Priority>
<StartTs xsi:nil="true"/>
<EndTs xsi:nil="true"/>
<RecordId>0</RecordId>
<RecGroup/>
<PlayGroup/>
<StorageGroup/>
<RecType>0</RecType>
<DupInType>1</DupInType>
<DupMethod>1</DupMethod>
<EncoderId>0</EncoderId>
<Profile/>
</Recording>
<Artwork>
<ArtworkInfos/>
</Artwork>
</Program>

It looks like mythbackend puts scandic ok. Could it be kodi setting somewhere? Sounds strange as I have android tablets, libreelec and linux computers with kodi and all have same problem. Also with jarvis and krypton.
(This post was last modified: 2017-03-16 09:32 by mr_kane.)
find quote
janbar Offline
Posting Freak
Posts: 902
Joined: Sep 2012
Reputation: 49
Location: France
Post: #13
It could be linked with the used skin. How scandic characters are displayed ? Are they missed or replaced by others ?
(This post was last modified: 2017-03-17 21:23 by janbar.)
find quote
mr_kane Offline
Junior Member
Posts: 11
Joined: Mar 2017
Reputation: 0
Post: #14
(2017-03-17 19:38)janbar Wrote:  It could be linked with the used skin. How scandic characters are displayed ? Are they missed or replaced by others ?
They are just missing. I have tried confluence and aeonlux themes in jarvis and krypton with default skin. None of them displays scandic in epg data. Otherwise scandic is ok in menus etc.
find quote
mr_kane Offline
Junior Member
Posts: 11
Joined: Mar 2017
Reputation: 0
Post: #15
Any ideas what is problem? Is there possible to log information somewhere and investigate it?
find quote
Post Reply