Windows - Kodi audio settings, where stored? Losing audio selection on restart

  Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
markm75 Offline
Junior Member
Posts: 34
Joined: Mar 2013
Reputation: 0
Post: #16
Its been about a week or more, still holding strong with success here.. happy to report.. thanks all (i didnt need to do anything in the kodi profile folder.. it was all about making sure i had the correct waspi device id in the file to begin with, i think), it definitely prevents you from seeing the audio settings on the audio settings page though.
(This post was last modified: 2017-03-29 16:24 by markm75.)
find quote
jjd-uk Offline
Team-Kodi Member
Posts: 6,199
Joined: Oct 2011
Reputation: 152
Post: #17
Did you copy the whole block of audio settings?

If so, then in case you didn't realise you only needed to add the two device settings to the advancedsettings.xml for example

Code:
<advancedsettings>
    <audiooutput>
        <audiodevice>WASAPI:{BE537087-5CB0-45C2-B436-3CC1F55A8CD5}</audiodevice>
        <passthroughdevice>WASAPI:{BE537087-5CB0-45C2-B436-3CC1F55A8CD5}</passthroughdevice>
    </audiooutput>
</advancedsettings>

that way you retain access to the other settings.

My previous replies were brief as I was answering on my phone.
(This post was last modified: 2017-03-29 16:40 by jjd-uk.)
find quote
markm75 Offline
Junior Member
Posts: 34
Joined: Mar 2013
Reputation: 0
Post: #18
(2017-03-29 16:39)jjd-uk Wrote:  Did you copy the whole block of audio settings?

If so, then in case you didn't realise you only needed to add the two device settings to the advancedsettings.xml for example

Code:
<advancedsettings>
    <audiooutput>
        <audiodevice>WASAPI:{BE537087-5CB0-45C2-B436-3CC1F55A8CD5}</audiodevice>
        <passthroughdevice>WASAPI:{BE537087-5CB0-45C2-B436-3CC1F55A8CD5}</passthroughdevice>
    </audiooutput>
</advancedsettings>

that way you retain access to the other settings.

My previous replies were brief as I was answering on my phone.

No problem.. yeah i did the whole block.

Ill try switching to just those two... but once again last nite.. i lost the setting somehow.. it seems to be silently reverting to the other device though no way to tell other than when i play a dolby digital mkv, i dont get the red light on the receiver (again).. when this is working and set to the correct waspi i do.

I checked (again) the date on the advanced settings file.. it was still set to 3/20, the correct waspi device id was listed.

I'm not sure what is overriding it (randomly).. this time it took about 10 days to break.
find quote
markm75 Offline
Junior Member
Posts: 34
Joined: Mar 2013
Reputation: 0
Post: #19
I think i found the ACTUAL source of the issue why my sound was changing..

What was happening was.. if kodi was left open for some time.. for some reason Steam would come back alive and steal the sound source.. (I have a taskkill in a batch file when i launch kodi to kill any open steam instances)..

I finally discovered this the other night (so i'm 98% sure this was the cause).

Still good to go on the settings in the xml though.
find quote
Post Reply