v17 "fullscreen" not really full screen.
#1
Kodi version: 2:17.0+dfsg1-3
OS: Ubuntu Mate 17.04
Nvidia proprietary drivers

Kodi starts out not filling the entire 1920x1080 monitor. It's always the very bottom that is left blank. This is more of an issue with video playback since it ends up shrinking the horizontal to maintain the aspect ratio of the video and I end up losing several inches of TV real estate. If I drop out to the DE, that is using the full screen so back in Kodi, I noticed that if I change the device, from either HDMI or default--it doesn't matter what it's set at our to, the issue comes up for both and changes when the other is chosen--Kodi then fills the whole screen for both the GUI and playback. Problem is, it sometimes reverts after a video ends and I have to cycle the display device again.
I've now created an xorg.conf file to see if making things more static would help but it didn't change anything.
Reply
#2
Press "\" - mate and the compositor are not supported by kodi. In fact we disable it upon starting.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#3
That doesn't do anything. It believes it is Fullscreen already. I do have a workaround in the form of cycling the video device, but I was looking for a more permanent fix.
Reply
#4
Hmm. Pretty quiet. I guess I'm the only one with this problem.

Still using the same workaround: cycle video monitor. Same behavior: at startup, GUI and video leaving several hundred pixels worth of space at the bottom of the screen. Still looking/hoping for a permanent fix.
Reply
#5
Can you have your desktop fill the display top to bottom? Wondering if this is an overscan/underscan issue with a standard display and perhaps some adjustments inside the graphic driver/panel display will give you 1080p full expansion. Once this is set, Kodi in windowed mode should utilize the o/s desktop display routines.

Quote:several hundred pixels worth of space
That's less than one line of resolution?
Reply
#6
Thanks for stopping by.

Yeah, the desktop uses the full screen if I exit, and Kodi will too; just alternating between output devices (there's really only one: switching between hdmi0 and default) makes Kodi fill as well. It's just when Kodi starts (using lightdm to start right into Kodi Fullscreen, not windowed).

I was just throwing a rough number out there. The blank space at startup is about 2 inches on a 55".
Reply
#7
Try full windowed mode, see if that offers any satisfaction. Otherwise as fritsch mentioned.

Quote:The blank space at startup is about 2 inches on a 55
Thousands of pixels.
Reply
#8
Yeah, neither of those things do anything. There's not so much as a flicker. Absolutely nothing changes. I even restarted after changing Kodi to windowed. It said"windowed", but still had the blank space at the bottom, looked exactly the same. Switching the setting back to fullscreen did fill the screen just as it does with changing the monitor setting.

Well, thanks anyway. Nothing's perfect. I guess this will be the way it is.
Reply
#9
Well, I don't know what to say except that it's (at the moment) working.

I had resigned myself to just living with it but after a few test restarts it's still behaving. All I had done was try the windowed mode like you suggested, switch back to fullscreen, as I said above, and it seems to have "stuck" this time.

Thanks for your help, you two.
Reply
#10
Depending on how you start the set-up, I'll bet you lose it again when Kodi defaults when it can't find the display (suspect HDCP, insert displays (wiki) pin 19)
Reply
#11
Could be, but shouldn't be too much of a problem. One button on the Harmony remote turns everything on. The order never changes; the TV is on by the time Kodi starts. I fully expect something will revert at some point but when that happens I'll just play around with the display settings, just switching back and forth, until it settles down.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
"fullscreen" not really full screen.00