Backed up and now cannot restore

  Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
sunsetsunrise Offline
Junior Member
Posts: 5
Joined: Apr 2016
Reputation: 0
Post: #1
Hello Everyone,
I installed Krypton, but before I did, I backed up my Jarvis data and placed them in a file on my computer. When I went to restore, it won't give me any options to browse to the file I saved in. Just has a cancel button.

These are the instructions I followed:
1. Go to “System” > “Add-ons” > “Install from repository” > “Kodi Add-on repository” > “Program add-ons” > select “Backup”. Click install.
2. Next, go to “Programs” and launch “Backup” add-on. Choose “Open Settings”.
3. In the “General” settings, type the remote path where Kodi settings will be copied. Then in the “File Selection” choose what data you wish to be copied.
4. Finally, launch the Backup add-on again and choose “Backup” to copy settings to the remote path.

In order to restore your settings to a new Kodi device, simply install Backup add-on to the new device. Then, copy the files to be restored to the new device and select “Restore” in the Backup app.
(This post was last modified: 2017-03-19 05:26 by sunsetsunrise.)
find quote
pagali Online
Donor
Posts: 198
Joined: Feb 2013
Reputation: 6
Post: #2
Did you set the Backup directory exactly the same on the new device as it was on the original? Point the new Backup folder to that location. You don't have the option of browsing around on the computer or LAN when you're restoring.
find quote
sunsetsunrise Offline
Junior Member
Posts: 5
Joined: Apr 2016
Reputation: 0
Post: #3
In Krypton, it was the first thing I did, so I could restore before doing anything else and I did the exact same location in the backup directory. That is why I thought it was funny I have nothing in the restore screen.
(This post was last modified: 2017-03-20 17:55 by sunsetsunrise.)
find quote
PatK Offline
Team-Kodi Member
Posts: 8,332
Joined: Mar 2010
Reputation: 202
Location: Canada
Post: #4
When you go to restore do you see the file folder as a date + numbers e.g. 201703201243 if you don't see this, then use settings and browse to the folder, exit settings and then choose restore. If you don't have a folder starting with the date, then it's likely that you don't have a back-up to restore.

windows fresh start -> delete C:\Users\User Name\AppData\Roaming\Kodi First time user (wiki) Log file (wiki) Video management (wiki) Artwork (wiki) Supported hardware (wiki) Releases (wiki) Database versions (wiki) Skin features compatibility list (wiki) http://xbmc-skins.com
(This post was last modified: 2017-03-20 19:23 by PatK.)
find quote
sunsetsunrise Offline
Junior Member
Posts: 5
Joined: Apr 2016
Reputation: 0
Post: #5
yes it saved as a date + numbers e.g. 201703201243
I will try what you posted after work and let you know if that worked
(This post was last modified: 2017-03-20 19:35 by sunsetsunrise.)
find quote
sunsetsunrise Offline
Junior Member
Posts: 5
Joined: Apr 2016
Reputation: 0
Post: #6
well that did not work again, still cannot see a way to restore.
the "ORIGINAL" instructions I followed above gave me all the correct responses for achieving the date + numbers e.g. 201703201243.
Its the restore that is not functioning properly.

Heck I even added the file to the file manger to see if that would help
(This post was last modified: 2017-03-21 06:35 by sunsetsunrise.)
find quote
PatK Offline
Team-Kodi Member
Posts: 8,332
Joined: Mar 2010
Reputation: 202
Location: Canada
Post: #7
Inside that folder 201703201243 should be two sub folders "userdata" and "addons", I suspect you could install Kodi, run it... then replace the existing folders with those from your back-up. I've always handled my back-ups by copying out the "userdata" and "addons" manually, it's pretty fool proof method.

windows fresh start -> delete C:\Users\User Name\AppData\Roaming\Kodi First time user (wiki) Log file (wiki) Video management (wiki) Artwork (wiki) Supported hardware (wiki) Releases (wiki) Database versions (wiki) Skin features compatibility list (wiki) http://xbmc-skins.com
(This post was last modified: 2017-03-21 07:42 by PatK.)
find quote
sunsetsunrise Offline
Junior Member
Posts: 5
Joined: Apr 2016
Reputation: 0
Post: #8
Just as an FYI. I so appreciate the work the folks have done on this software. Thank You!
I was hoping the "restore" would have worked to make my life easy. It also would have been a recognizable way to do it.

For anyone else who has had the same problem as I have.
The solution now, is to do the manual restore.

If this works for me I will let you know

Thanks PatK for all your help and suggestions, very much appreciated
find quote
pagali Online
Donor
Posts: 198
Joined: Feb 2013
Reputation: 6
Post: #9
Just for another viewpoint... I've used the Backup addon's backup and restore functions many times, never had a problem. Saved my bacon more than once after computer malfunctions. It's made it very easy to upgrade Kodi versions, replace hard drives, or whatever else needed to be done. I'm mystified why the original poster had so much trouble. Hope it doesn't happen to me!
find quote