Get Artist photo from Audiodb
#1
My music collection is generally nicely scraped by Kodi, however there are a couple of artists for which there is no image or description.

Reading here I'm lead to believe the nice guy thing to is to create an entry for those artists at the audiodb site if they are not listed there, so that everyone can benefit. So I've done that for a few artists.. but it hasn't benefited me!

I've done a "Refresh info for all artists" in Kodi numerous times at different times of the day and days of the week. No joy. I've removed the artist folder from my music share then removed them from Kodi library and forced a library clean. Then returned the artist folder to the music share and had Kodi rescan. Still without joy.

The new artist is there on audiodb.. I don't get it.

FYI, as an example one of the artists I added is the band "Stump".

RLW
Reply
#2
Are your scraper settings set to fetch art from TADB?
Reply
#3
TADB data looks correct so it should at least find an artist image. Try refreshing from the artist page.

http://www.theaudiodb.com/artist/stump

Also make sure you have the universal scraper settings to download artwork. You might also want to try out the specific TheAudioDB artist scraper which doesnt use musicbrainz for its search (which can be unreliable)
Image Image
Reply
#4
@ DaveBlake - Yes, using the Universal Artist Scraper with all default settings which includes TADB enabled under the Artwork, Thumbs section.

@ docwra - Yes, set up to download artwork - all other artists thumbnails are showing since when I orginally added and scanned my music source folder, with the exception of those artists not listed in TADB. Thanks for the suggestion re: TheAudioDB Artist Scraper. I've just now installed it and set it as the default for Artist information. Still does not pickup the newer added artists like Stump.

Note that when I select "Query info for all artists" from the context menu I see a Kodi pop-up which says "Preparing..." and a little status bar. This lasts less than a second then disappears with the status bar never having moved. Seems like a problem. Note that all Kodi library updates of Movies, TV Shows are set to happen every 2 hours by the Library Auto Update addon. The Music library is set to be updated every 24 hours. On the off chance that this was causing an issue, I disabled this and retested this issue with new artist thumbnails on TADB running updates manually. Made no difference.

Cheers,
RLW
Reply
#5
"Query info for all artists" will only fetch info for artists it does not think it has scraped already. I know that you tried removing artist, clean, and then adding their music again, so that should not be the issue. But I do wonder.

If you are happy to get more hands on then have a look at your music db using a SQL browser, find the artists in the artists table and check the last scraped date. If it is not null then scraping will not happen. You could just change it to null while you are there, and then try "Query info for all artists" again.

But obviously that dirty approach is not a solution (if indeed "already scraped" is the issue), and I am half aware that sometimes users have issues getting artwork to update. It is on my job list to dig deeper.

Otherwise a debug log of "Query info for all artists" might show something, but my bet would be on the last scraped date not being null.
Reply
#6
Thank you DaveBlake.

So, impatient guy that I am, I decided to simply remove my music source from Kodi and re-add & scrape it. Removed the source, dropped the database from MySQL, restarted Kodi to get a new empty MyMusic56 DB, re-added my music source and had Kodi do a fresh scrape of all music. It completed fine and I see all my Albums and Artists just like before... only Stump still does not show up with Artist information or thumbnail picture. Huh. Note that Stump is just an example, there are a couple others I added to TADB that also won't scrape.

I know roughly zero about SQL, so bear with me here - I do have the MySQL hosted on my NAS and have phpAdmin installed there also. I verified that the entry for Stump has the same ID number that is shown on MusicBrainz, so: both strMusicBrainzArtistID and the MBID are 79d2e41d-aede-49e8-9e18-9074056de7b4. With respect to your suggestion about scrape date, you'll have to clarify what you would like me to try as I'm not familiar with how to use this phpAdmin tool. Do I just tick the box here and click Go, then Save?

Image

Note there are several more rows between these two screen shots, all with empty fields.

Image

Note also that the above new library scrap was done with the TheAudioDB scraper suggested by docwra set as the Artist scraper.

Cheers,
RLW
Reply
#7
I figured out the problem.

Turns out there was an artist.nfo file in the \Stump folder and the other ones I had recently added to TADB. Removed those files and then I could refresh them from the Artist Information page.

Sometimes the simplest things...

Thank you both for your ideas!

Cheers,
RLW
Reply
#8
Doh, NFOs! Should have thought of that, well done for spotting it and for feeding back here.
Reply
#9
Next time take a debug log as that would have shown Kodi was seeing a NFO file.
Reply



Logout Mark Read Team Forum Stats Members Help
Get Artist photo from Audiodb0
This forum uses Lukasz Tkacz MyBB addons.