v15 MKV embedded subtitles not shown on raspberry PI (SOLVED)
#1
Hi everyone!

I am now 3 days trying to solve this issue, so you are my last resort Smile

I hope this is the right thread for this.

I am setting up Kodi 15.2 on Raspbian (wheezy):

Image

I have troubles getting embedded .mkv subtitles to get working. I've read that this might be caused by missing support of SSA/AAS/ASS subtitles.

I've tried the following (as per this thread https://discourse.osmc.tv/t/cant-get-sub...a-2/213/12):

Code:
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade

sudo apt-get install libass-dev

Which run successfully, then I rebooted the raspberry PI and tried again with no avail. I made sure the subtitles are enabled in the on-screen menu under the Sound icon.

I also tried this, but it fails with an error:
Code:
sudo apt-get install libass5

Error:

Code:
Package libass5 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libass5' has no installation candidate

I also tried installing the opensubtitles plugin, but this didn't work (probably the watched anime isn't available on there).

In the Kore android applications, when checking the subtitles sub-menu when a video is playing, it shows up as "eng |".

Here are the video details:

Image


EDIT: Trying now this: 258382 (thread)
FINAL EDIT: The link just above works. Don't compile your own libass package, just do the following:

Download:

http://www.mediafire.com/download/ycbp3t...0.1.tar.xz

unpack and install

Code:
sudo dpkg -i libass4_0.10.1-1_armhf.deb
sudo apt-get install -f

reboot or kodi restart not required
note: the above uninstalled libass-dev - there was probably a conflict

Any pointers would be incredibly appreciated!
Thanks in advance,
jokob
Reply
#2
You know we're in Kodi 17.x now ?
Not sure if it is fixed/working with the new version but you could give it a try
LibreElec Kodi | Aeon MQ ?
Reply
#3
Hi TRaSH,

Yes, I know, I'll try it if everything else fails... I just found this https://github.com/xbianonpi/xbian/issues/722 so I am giving it one last try... as far as I know however raspbian only supports 15.2 (http://kodi.wiki/view/HOW-TO:Install_Kod...i#Raspbian)
Reply
#4
You can lock this thread - solved, see original post for solution
Reply
#5
Please note that as a Team of volunteers we only ever provide official support on the latest stable version, so that will now be v17. I you want to stay with v15 for now for whatever reason then you can of course still raise questions to this forum, but you maybe reliant on other users being helpful, as most likely any response from a Team member, depending on type of query, would be to upgrade to the latest stable version.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
MKV embedded subtitles not shown on raspberry PI (SOLVED)00