Rotten Tomatoes ratings scraping is broken
#1
UPDATE: So I decided to test this on another Kodi install, just to make sure it wasn't just my Raspberry Pi. The issue affects both.

The debug log shows the following when trying to scrape the movie "The Founder" with Universal Movie Scraper:

Quote:12:08:13.353 T:8920 DEBUG: scraper: GetRTRatingById returned <details><url function="ParseRTTomAll" cache="4276820-omdbapi.html">http://www.omdbapi.com/?i=tt4276820&r=json&tomatoes=true</url></details>

12:08:13.353 T:8920 DEBUG: CurlFile::Open(19CE6FC0) http://www.omdbapi.com/?i=tt4276820&r=js...atoes=true

12:08:13.399 T:8920 DEBUG: CScraperUrl::Get: Using "UTF-8" charset for "http://www.omdbapi.com/?i=tt4276820&r=json&tomatoes=true"

12:08:13.403 T:8920 DEBUG: scraper: ParseRTTomAll returned <details><rating max="100">N/A</rating><votes>N/A</votes></details>

It also returns similar N/A results for other movies.

Does anybody know why this is suddenly borked? I checked out the omdb api site, but there was no mention of any problems there as far as I could see.

ORIGINAL POST:

Hi there,

Encountered an issue in the last couple weeks where I've noticed that the Universal Movie Scraper is no longer pulling rating information from Rotten Tomatoes.

Anyone else having the same issue? Is there a fix on the way?

Cheers
Reply
#2
I just want to confirm that this is happening across multiple places for me as well :/. Hopefully there's a fix on the way. I'll post in the UMS thread as well
Reply
#3
https://www.patreon.com/posts/rating-changes-8417367

There's been changes to the OMDB API that will require an update to UMS for Rotten Tomatoes scraping to work again.
Reply
#4
HeHe I thought it was just only me !!! Tongue
clearArt Concept
cdArt Concept

*If like, thank user
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Rotten Tomatoes ratings scraping is broken00