Solved Issue - STEP-BY-STEP SOLUTION - Kodi 17.1 Krypton fails to launch in Mac OSX

  Thread Rating:
  • 2 Vote(s) - 3.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Closed
Rechi Offline
Team-Kodi Member
Posts: 336
Joined: Feb 2015
Reputation: 4
Location: Austria
Post: #46
Correct path is ~/Library/Application Support/Kodi
find
Bjpcameron Offline
Junior Member
Posts: 2
Joined: Dec 2013
Reputation: 0
Post: #47
It worked ! Thank you Smile
find
b7000 Offline
Junior Member
Posts: 17
Joined: Apr 2017
Reputation: 2
Post: #48
(2017-04-09 11:44)Memphiz Wrote:  @b7000 i have the feeling i have posted this multiple times now but here i go again. I need basically the files the user deletes atm to get it working. For being save this would be all Addons .db files (Addons*.db where "*" means all numbers the user might have).

Providing the files can be done by any public accessible file hoster (dropbox for example). Tell me what else is unclear and i try to be mor specific. Thx.

@Memphiz - I've amended the original post to include these instructions. What you didn't include is how users can notify developers of the link to their files (may be obvious to you but not a lot of users). I included this too. I'ts also far more efficient to ask users to send you the folder containing the .db files, instead of asking for a specific range of files as most users are not developers. Cheers

@Rechi - I have amended the OP to include your suggested method for locating the correct folder. Cheers

Peace
(This post was last modified: 2017-04-17 06:32 by b7000.)
find
Acealmansori Offline
Junior Member
Posts: 4
Joined: Apr 2017
Reputation: 0
Post: #49
Hello all,
I've done them all till number 7, but I can't seem to find a file by either names, kodi and xmbc. Help please.
find
b7000 Offline
Junior Member
Posts: 17
Joined: Apr 2017
Reputation: 2
Post: #50
(2017-04-17 06:34)Acealmansori Wrote:  Hello all,
I've done them all till number 7, but I can't seem to find a file by either names, kodi and xmbc. Help please.

They are not files nor are referred to as files in the instructions. These are folders in a file destination path. Each title in between the / / is a folder title. Use the finder window to click into each folder in order.
find
Acealmansori Offline
Junior Member
Posts: 4
Joined: Apr 2017
Reputation: 0
Post: #51
Folders, yea. I clicked in each until the Application support, no folder inside it by either names. Could you look into it more @b7000? Thank you
find
takoi Offline
Team-Kodi Member
Posts: 1,226
Joined: Oct 2009
Reputation: 25
Location: Norway
Post: #52
(2017-04-17 06:21)b7000 Wrote:  
(2017-04-09 11:44)Memphiz Wrote:  @b7000 i have the feeling i have posted this multiple times now but here i go again. I need basically the files the user deletes atm to get it working. For being save this would be all Addons .db files (Addons*.db where "*" means all numbers the user might have).

Providing the files can be done by any public accessible file hoster (dropbox for example). Tell me what else is unclear and i try to be mor specific. Thx.

@Memphiz - I've amended the original post to include these instructions. What you didn't include is how users can notify developers of the link to their files (may be obvious to you but not a lot of users). I included this too. I'ts also far more efficient to ask users to send you the folder containing the .db files, instead of asking for a specific range of files as most users are not developers. Cheers

@Rechi - I have amended the OP to include your suggested method for locating the correct folder. Cheers

Peace
Can you please instead ask users to make a zip of their entire userdata folder? We've already receiver several supposedly 'bad' db files but they're all perfectly fine. It's most likely something else in the users environment that is causing the issue.
find
bchase Offline
Junior Member
Posts: 3
Joined: Apr 2017
Reputation: 0
Post: #53
So strangely I appear not to have either a

~/Library/Application Support/XBMC

or
~/Library/Application Support/KODI

directory even though I've got the same symptoms as above. Any ideas?
(This post was last modified: 2017-04-17 20:57 by bchase.)
find
soothsayer Offline
Junior Member
Posts: 1
Joined: Apr 2017
Reputation: 0
Post: #54
(2017-04-02 19:23)Waltman Wrote:  
(2017-04-02 19:13)Reffo Wrote:  I followed the steps but it still shows :ERROR [Addons27.db] SQL error or missing database
I restarted Kodi but I guess he redownloads the corrupted file

In that case see step 8. above.
Delete all files with addonsxx.db. So addons27.db, addons26.db, addons20.db.....
Restart Kodi to rebuild the databases

This worked perfectly - thanks
find
jenesanne34 Offline
Junior Member
Posts: 1
Joined: Apr 2017
Reputation: 0
Post: #55
Big help, thank you!

https://www.dropbox.com/sh/fz9ub1klia3dj...6UnTa?dl=0
find
Waltman Offline
Senior Member
Posts: 294
Joined: Dec 2012
Reputation: 6
Location: below sea level
Post: #56
(2017-04-18 14:38)jenesanne34 Wrote:  Big help, thank you!

https://www.dropbox.com/sh/fz9ub1klia3dj...6UnTa?dl=0
@Memphiz, this is the one you have been waiting for. I hope you will be al le to find out what is causing the problem.

How to post a debug log ; MacOS acces the hidden userdata folder ; How to post a question ; How to fix gatekeeper issues
(This post was last modified: 2017-04-18 21:13 by Waltman.)
find
Memphiz Offline
Kodi MVP
Posts: 16,094
Joined: Feb 2011
Reputation: 227
Location: germany
Post: #57
@jenesanne34 and those files contain the state before you did the workaround mentioned here in this very thread for sure? Because there seems to be an addons27.db in there already (which means you have run krypton successfully already i guess)

AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
find
Acealmansori Offline
Junior Member
Posts: 4
Joined: Apr 2017
Reputation: 0
Post: #58
(2017-04-17 20:55)bchase Wrote:  So strangely I appear not to have either a

~/Library/Application Support/XBMC

or
~/Library/Application Support/KODI

directory even though I've got the same symptoms as above. Any ideas?

Can you guys help with this please?
find
Memphiz Offline
Kodi MVP
Posts: 16,094
Joined: Feb 2011
Reputation: 227
Location: germany
Post: #59
Damn - i looked into reproducing the issue with the files kindly provided by jenesanne34.

Sadly there was no way for me to get it into the crashing condition.

I tried.
1. Wiped my Kodi directory in Application Support
2. Started Kodi 16.1 to generate a clean Kodi directory in Application Support
3. closed Kodi 16.1
4. Copied all database files from jenesanne34 but not Addons27.db
5. Started Kodi 17.1
6. Nothing bad happend - Addons27.db was created and worked
7. Started Kodi 17.1 a dozens of times - no crash.

So the databases might only be a part of this annoying behavior. No idea how to further investigate.

Someone who has this issue would have to provide me the complete Kodi folder from Application Support before(!!!!!) applying the workaround here.

AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
find
schroef Offline
Junior Member
Posts: 4
Joined: Apr 2017
Reputation: 0
Post: #60
Im seeing tons of erros. I used to have 2 kodi version and all run fine. Now ive updated to 17.1 on OSX 10.11.6 and Kodi 17.1 stops working a lot. In the log file i see tons of directory errors aswell as errors i get in Kodi it cant connect to interner.
find