Win -  Can't get PS1/PSX emulation to work. Black screen.
#1
Whenever I attempt to load a .cue file with "Playstation (Mednafen PSX) I simply get a black screen with a play time of 0:00/1:00 bar.
Nothing ever happens beyond that. Further attempts crash Kodi all together.

What am I missing?
Reply
#2
You're likely missing the BIOS files (SCPHxxxx.bin). Google for them, as they're not something Sony likes to see linked to.
They need to be put in the system folder of the Mednafen/PCSX plugins.
Reply
#3
I have placed that file in "/Userdata/Addon_data/game.libretro.beetle-psx/resources/system" using SCPH-5501.BIN. Still the same problem. The cue file points to the correct file as well.
Reply
#4
The Game add-ons wiki article mentions that the Lakka wiki has a table of acceptable BIOS file names for retroarch cores. Looks like you need to rename your BIOS to scph5501.bin.
Reply
#5
That was the issue, didn't realize it would be case sensitive. Thank you for helping me find the solution.
Reply
#6
Hello, I am experiencing similar situation. I have my bios files (md5sum checked, all are lowercase, path is ~/.kodi/userdata/addons_data/game.libretro.pcsx-rearmed/system), but everytime I start the game, it complains about missing bios file. Some games show something (intro video), but as soon as I am going into game, it turns black. Some games display black screen from the very begining.

I can hear sound. Any ideas? Full log

Interesting part:
Quote:13:29:16.780 T:1941655984 INFO: AddOnLog: PlayStation (PCSX ReARMed): Invalid settings detected, generating new settings and language files
13:29:16.790 T:1941655984 INFO: AddOnLog: PlayStation (PCSX ReARMed): Settings and language files have been placed in /storage/.kodi/userdata/addon_data/game.libretro.pcsx-rearmed/generated/language/English
13:29:16.792 T:1941655984 DEBUG: AddOnLog: PlayStation (PCSX ReARMed): Loading libretro buttonmap /storage/.kodi/addons/game.libretro.pcsx-rearmed/resources/buttonmap.xml
13:29:16.794 T:1941655984 DEBUG: AddOnLog: PlayStation (PCSX ReARMed): No version detected, defaulting to version 1
13:29:16.795 T:1941655984 ERROR: AddOnLog: PlayStation (PCSX ReARMed): <feature> tag has invalid "mapto" attribute: "strong"
13:29:16.849 T:1941655984 DEBUG: CAddonCallbacksAddon - QueueNotification - PlayStation (PCSX ReARMed) - Info Message : 'No PlayStation BIOS file found - add for better compatibility'
Reply
#7
(2018-01-20, 14:28)gnaag Wrote: 13:29:16.849 T:1941655984 DEBUG: CAddonCallbacksAddon - QueueNotification - PlayStation (PCSX ReARMed) - Info Message : 'No PlayStation BIOS file found - add for better compatibility'
  
This looks like your issue. Normally, at this point I would load PCSX in a debugger and figure out exactly what filename/path it's looking for.

I would ask you to open a GitHub issue, but it looks like someone already has: https://github.com/kodi-game/game.libret...d/issues/9 . I added a link to your debug log.

The next step is to get your game working in RetroArch (possibly via RetroPie). This will tell us if it's a problem with RetroPlayer or the core.
BTC: 1JtXwJdGdE9YnYgThWBT2StFCU5sEYkbVD (personal), https://kodi.tv/contribute/donate-bitcoin (foundation). Donations in the form of controllers, especially ones that don't work in Kodi, are also appreciated.
Reply
#8
I wonder if it might be worth showing users a BIOS Missing error (along with a note that Kodi doesn't provide those) for cores that need BIOSes in the future. If that is the only issue here, it could prevent a lot of future threads.
Reply
#9
The bug report on github is mine actualy. The game is working fine on retroarch on my linux pc, even on my steam link device. There is probably some bios path problem with retroplayer.
Reply
#10
Gotchya. Yea, the path seems to be the issue. Can you get crash working with Beetle PSX?

BIOS support is next on my list of Leia features after the player manager: https://github.com/garbear/xbmc/issues/80 . Not sure when I'll finish the player manager, but I'll definitely get BIOS support in for Leia.
BTC: 1JtXwJdGdE9YnYgThWBT2StFCU5sEYkbVD (personal), https://kodi.tv/contribute/donate-bitcoin (foundation). Donations in the form of controllers, especially ones that don't work in Kodi, are also appreciated.
Reply
#11
I haven't tried. It is RPi3 device and beetle PSX is x86 only, as far as I know. Maybe someone with another device can try. It is actually very similar with every game I tried on retroplayer's pcsx (crash2, crash3, spyro, tomb raider). So it is probably not game-related.
Reply
#12
Quote:Yea, the path seems to be the issue
Would you please post here the correct path, that bios should be in? I would like to test the emulator before you get to bios issues solving. Thanks
Reply
#13
/storage/.kodi/userdata/addon_data/game.libretro.pcsx-rearmed/resources/system is the system directory where PCSX should be looking for BIOses
BTC: 1JtXwJdGdE9YnYgThWBT2StFCU5sEYkbVD (personal), https://kodi.tv/contribute/donate-bitcoin (foundation). Donations in the form of controllers, especially ones that don't work in Kodi, are also appreciated.
Reply
#14
(2018-01-28, 23:49)garbear Wrote: /storage/.kodi/userdata/addon_data/game.libretro.pcsx-rearmed/resources/system is the system directory where PCSX should be looking for BIOses
Thanks. I have finally managed to get rid of "Missing bios" warning. But it actually didn't help with black screen problem. However I have observed some new behaviour.

1. I start the game - black screen (doesn't matter how long I wait)
2. I exit the game.
3. I start the same game again - black screen (doesn't matter how long I wait)
4. I exit the game.
5. I start the same game again - I can see video
6. I wait for the game's main menu.
7. My controller simply doesn't work. I have tried every possible combinations in PCSX setup (multitap and Pads - no difference). My controller is setup up for playstation the same way as for the SNES. The SNES works.

Isn't it possible that the new Kodi settings together with abovementioned errors in kodi.log resulting in generating new settings.xml may be the culprit? PCSX obviously expects different set of settings to what it gets.


This is the generated settings in .kodi/userdata/addon_data/game.libretro.pcsx-rearmed/generated/settings.xml

<?xml version="1.0" encoding="utf-8" standalone="yes"?>
<settings>
    <category label="30000">
        <setting label="30001" type="select" id="pcsx_rearmed_dithering" values="enabled|disabled" default="enabled"/>
        <setting label="30002" type="select" id="pcsx_rearmed_drc" values="enabled|disabled" default="enabled"/>
        <setting label="30003" type="select" id="pcsx_rearmed_duping_enable" values="enabled|disabled" default="enabled"/>
        <setting label="30004" type="select" id="pcsx_rearmed_frameskip" values="0|1|2|3" default="0"/>
        <setting label="30005" type="select" id="pcsx_rearmed_inuyasha_fix" values="disabled|enabled" default="disabled"/>
        <setting label="30006" type="select" id="pcsx_rearmed_multitap1" values="auto|disabled|enabled" default="auto"/>
        <setting label="30007" type="select" id="pcsx_rearmed_multitap2" values="auto|disabled|enabled" default="auto"/>
        <setting label="30008" type="select" id="pcsx_rearmed_neon_enhancement_enable" values="disabled|enabled" default="disabled"/>
        <setting label="30009" type="select" id="pcsx_rearmed_neon_enhancement_no_main" values="disabled|enabled" default="disabled"/>
        <setting label="30010" type="select" id="pcsx_rearmed_neon_interlace_enable" values="disabled|enabled" default="disabled"/>
        <setting label="30011" type="select" id="pcsx_rearmed_pad1type" values="default|none|standard|analog|negcon" default="default"/>
        <setting label="30012" type="select" id="pcsx_rearmed_pad2type" values="default|none|standard|analog|negcon" default="default"/>
        <setting label="30013" type="select" id="pcsx_rearmed_pad3type" values="default|none|standard|analog|negcon" default="default"/>
        <setting label="30014" type="select" id="pcsx_rearmed_pad4type" values="default|none|standard|analog|negcon" default="default"/>
        <setting label="30015" type="select" id="pcsx_rearmed_pad5type" values="default|none|standard|analog|negcon" default="default"/>
        <setting label="30016" type="select" id="pcsx_rearmed_pad6type" values="default|none|standard|analog|negcon" default="default"/>
        <setting label="30017" type="select" id="pcsx_rearmed_pad7type" values="default|none|standard|analog|negcon" default="default"/>
        <setting label="30018" type="select" id="pcsx_rearmed_pad8type" values="default|none|standard|analog|negcon" default="default"/>
        <setting label="30019" type="select" id="pcsx_rearmed_pe2_fix" values="disabled|enabled" default="disabled"/>
        <setting label="30020" type="select" id="pcsx_rearmed_region" values="Auto|NTSC|PAL" default="Auto"/>
        <setting label="30021" type="select" id="pcsx_rearmed_show_bios_bootlogo" values="disabled|enabled" default="disabled"/>
        <setting label="30022" type="select" id="pcsx_rearmed_spu_interpolation" values="simple|gaussian|cubic|off" default="simple"/>
        <setting label="30023" type="select" id="pcsx_rearmed_spu_reverb" values="enabled|disabled" default="enabled"/>
        <setting label="30024" type="select" id="pcsx_rearmed_vibration" values="enabled|disabled" default="enabled"/>
    </category>
</settings>

This is the saved one in .kodi/userdata/addon_data/game.libretro.pcsx-rearmed/settings.xml

<settings version="2">
    <setting id="pcsx_rearmed_duping_enable" default="true">enabled</setting>
    <setting id="pcsx_rearmed_frameskip" default="true">0</setting>
    <setting id="pcsx_rearmed_inuyasha_fix" default="true">disabled</setting>
    <setting id="pcsx_rearmed_multitap1">enabled</setting>
    <setting id="pcsx_rearmed_multitap2">disabled</setting>
    <setting id="pcsx_rearmed_pad1type" default="true">default</setting>
    <setting id="pcsx_rearmed_pad2type" default="true">default</setting>
    <setting id="pcsx_rearmed_pad3type" default="true">default</setting>
    <setting id="pcsx_rearmed_pad4type" default="true">default</setting>
    <setting id="pcsx_rearmed_pad5type" default="true">default</setting>
    <setting id="pcsx_rearmed_pad6type" default="true">default</setting>
    <setting id="pcsx_rearmed_pad7type" default="true">default</setting>
    <setting id="pcsx_rearmed_pad8type" default="true">default</setting>
    <setting id="pcsx_rearmed_pe2_fix" default="true">disabled</setting>
    <setting id="pcsx_rearmed_region" default="true">Auto</setting>
    <setting id="pcsx_rearmed_show_bios_bootlogo" default="true">disabled</setting>
    <setting id="pcsx_rearmed_spu_interpolation" default="true">simple</setting>
    <setting id="pcsx_rearmed_spu_reverb" default="true">enabled</setting>
    <setting id="pcsx_rearmed_vibration">disabled</setting>
</settings>
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Can't get PS1/PSX emulation to work. Black screen.00