HOW TO INSTALL KODI FROM WEBSITE/URL - read if having problems doing this

  Thread Rating:
  • 1 Vote(s) - 1 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
jjd-uk Offline
Team-Kodi Member
Posts: 6,256
Joined: Oct 2011
Reputation: 158
Post: #1
If you have problems installing Kodi from https://kodi.tv/download then please try and use the direct link to where the downloads are hosted, so for Android this is:

http://mirrors.kodi.tv/releases/android/

[Image: s536nuw.png]

You need to select the type of processor you device has

[Image: U9FyUmO.png]


Then select the version you want.

Note - This shows the downloads for the current stable release, if you want a previous release then select the old/ folder and from there select the apk you want, however be aware that this also contains the pre-release Release Candidate (rc1, rc2, etc) and Beta (beta1, beta2 etc) versions so please ignore these.

[Image: U9FyUmO.png]


HOW TO LOAD KODI ON AMAZON DEVICES GUIDES
(can be followed for any device without access to Google Play Store or a browser such as Chrome)


How to sideload apps like Kodi or SPMC on the Amazon Fire TV & Stick using Downloader

Ultimate Sideloading Guide for Amazon Fire TV & Fire TV Stick

The above are external links that take you to guides written by http://www.aftvnews.com
(This post was last modified: 2017-04-13 11:33 by jjd-uk.)
find quote
sefmyster Offline
Junior Member
Posts: 1
Joined: Nov 2016
Reputation: 0
Post: #2
I totally vouch. I ran into this issue last night and sure enough Jarvis 16.1 fired right on up for me...


Sent from my iPhone (typie typie)
find quote
Arclite Offline
Junior Member
Posts: 1
Joined: Apr 2017
Reputation: 0
Post: #3
This version of Kodi is not compatible with this device!
Device= Archos Xenon 101 v2

Can I have Jarvis back please? This does work - until the cause of this, 17.1 incompatibility is found?
find quote
Gracus Offline
Moanbag
Posts: 1,305
Joined: Jun 2016
Reputation: 48
Location: Saint-Brieuc, France
Post: #4
(2017-04-04 11:21)Arclite Wrote:  This version of Kodi is not compatible with this device!
Device= Archos Xenon 101 v2

Can I have Jarvis back please? This does work - until the cause of this, 17.1 incompatibility is found?

Incompatibility because kodi 17 need at least android 5.0 and your Archos device seems to run android 4.4

2 solutions:
-try to find an android update for your device
-download jarvis from here: http://mirrors.kodi.tv/releases/android/arm/old/

Moanbag is in da place!
find quote
Mitymouse1371 Offline
Junior Member
Posts: 2
Joined: Apr 2017
Reputation: 0
Post: #5
Can anyone please help. X96 android box 6.0 can't seem to upgrade to 17 at all. Google play shows no upgrade when I select uninstall it says Jodi not installed by Google. But I have tried the 32 bit 64 bit and x86. Really confused and need some help people.
find quote
Wiki Offline
Junior Member
Posts: 4
Joined: Apr 2017
Reputation: 0
Post: #6
I am attempting to load Kodi onto an older box with android 4.1, using the es explorer app. It keeps saying there is a problem "parsing" . Is it even possible to load Kodi to android 4.1 or do I need to buy a new box? Thanks.
(This post was last modified: 2017-04-07 14:17 by Wiki.)
find quote
DarrenHill Offline
Team-Kodi Minion
Posts: 5,882
Joined: Oct 2014
Reputation: 136
Location: UK, except when I'm not.
Post: #7
Krypton requires Android Lollipop (v5.0) or higher. You'll need to download an older version from the download link at the top of the forum pages and sideload that instead.

| Banned add-ons (wiki) | Forum rules (wiki) | First time user (wiki) | FAQs (wiki) | Troubleshooting (wiki) | Add-ons (wiki) | Free content (wiki) | Debug Log (wiki) | Free Movies/TV Shows
find quote
Gracus Offline
Moanbag
Posts: 1,305
Joined: Jun 2016
Reputation: 48
Location: Saint-Brieuc, France
Post: #8
(2017-04-07 13:52)Wiki Wrote:  I am attempting to load Kodi onto an older box with android 4.1, using the es explorer app. It keeps saying there is a problem "parsing" . Is it even possible to load Kodi to android 4.1 or do I need to buy a new box? Thanks.

Kodi 17 need at least android 5.0

Moanbag is in da place!
find quote
Rickt1962 Offline
Fan
Posts: 320
Joined: Oct 2013
Reputation: 1
Post: #9
Silly question how come OSMC can update it self in Kodi but on Firestick can't ? From 17.0 to 17.1

One HTPC Windows 7 pro 64x running WMC with HDhomeRun on Comcast 3 tuners with MCEbuddy sending everything to WD MyCloud 16 tb over netgear gig network shared to
Four Raspberry Pi-2 and one Raspberry Pi-3
Second source of live TV
4 STB Vigica with 8' C-band and 3' ku band dvb-s2 FTA
Third source of live TV
1 STB Vigica ATSC OTA with RCA antenna ANT3037XR
find quote
jjd-uk Offline
Team-Kodi Member
Posts: 6,256
Joined: Oct 2011
Reputation: 158
Post: #10
OSMC has a full debian OS underneath which utilities a package manager for updates, so for Android the equivalent would be one of the stores (Google Play, Amazon).
find quote
Wiki Offline
Junior Member
Posts: 4
Joined: Apr 2017
Reputation: 0
Post: #11
(2017-04-07 14:19)DarrenHill Wrote:  Krypton requires Android Lollipop (v5.0) or higher. You'll need to download an older version from the download link at the top of the forum pages and sideload that instead.

No, older versions won't work. I ordered a new box. Thanks!
find quote
Wiki Offline
Junior Member
Posts: 4
Joined: Apr 2017
Reputation: 0
Post: #12
(2017-04-07 14:20)Gracus Wrote:  
(2017-04-07 13:52)Wiki Wrote:  I am attempting to load Kodi onto an older box with android 4.1, using the es explorer app. It keeps saying there is a problem "parsing" . Is it even possible to load Kodi to android 4.1 or do I need to buy a new box? Thanks.

Kodi 17 need at least android 5.0

Thanks!
find quote
DarrenHill Offline
Team-Kodi Minion
Posts: 5,882
Joined: Oct 2014
Reputation: 136
Location: UK, except when I'm not.
Post: #13
(2017-04-10 14:05)Wiki Wrote:  No, older versions won't work. I ordered a new box. Thanks!

Why won't they work?

| Banned add-ons (wiki) | Forum rules (wiki) | First time user (wiki) | FAQs (wiki) | Troubleshooting (wiki) | Add-ons (wiki) | Free content (wiki) | Debug Log (wiki) | Free Movies/TV Shows
find quote
ClumpyOyster Offline
Junior Member
Posts: 5
Joined: Apr 2017
Reputation: 0
Post: #14
I've got an M8 couple years old. I removed the kodi 15.4 and trying to get kodi 16.1 on it. I have always used google store to get the download and have never manually installed kodi. I have found the downloads but there is six or seven items listed for Jarvis 16.1. How do I know which one to use?

I currently have 4.4.2 on the box, I know you need upgraded firmware on the box to run 17 but couldn't find the firmware needed for an m8 so decided to just put 16.1 on it.

Thanks for the help everyone
(This post was last modified: 2017-04-11 03:29 by ClumpyOyster.)
find quote
DarrenHill Offline
Team-Kodi Minion
Posts: 5,882
Joined: Oct 2014
Reputation: 136
Location: UK, except when I'm not.
Post: #15
Go for the 16.1 version that's not listed as RC# (it should be near the top of the block of Jarvis ones). That's the final version, the RC's are the prior release candidates.

| Banned add-ons (wiki) | Forum rules (wiki) | First time user (wiki) | FAQs (wiki) | Troubleshooting (wiki) | Add-ons (wiki) | Free content (wiki) | Debug Log (wiki) | Free Movies/TV Shows
find quote
Post Reply