Kodi v17 or 17.1 won’t launch...Help
#1
The forum has been flooded with requests to help solve the same problem... Addons27.db.

It is frustrating that people seem unable to read the 15 other posts on the first page regarding that same issue, but feel the need to post the problem again.

And all we are doing is repeating the same information over and over again.

So I created a help guide. If approved, it could be a sticky and we can just refer people to it, rather than repeating endlessly the same information.

The base is there, maybe just a few tweaks from the more experienced...

See next post...
Reply
#2
Have you recently updated your existing Kodi installation to v17 or v17.1 and now Kodi will no longer launch?

Before posting on the Forum, please follow these simple instructions to fix the most common cause of this issue.


Why won’t Kodi start on my Windows machine?
Some users on Windows systems are experiencing difficulties because blah blah blah. Maybe a team kodi member could explain why?


What do I have to do to fix it?
The fix is fairly simple, and should only take a few minutes of your time.
All that needs to be done is to navigate to ...\userdata\database and delete the file named Addons27.db


I can’t find this userdata directory
The location depends upon where you downloaded Kodi from...

If you downloaded from the official Kodi website, then the location of Addons27.db can be found at
%appdata%\Roaming\Kodi \userdata\database

If you downloaded from the Windows store, then the location of Addons27.db can be found at
%localappdata%\Packages\XBMCFoundation.Kodi_4n2hpmxwrvr6p\LocalCache\Roaming I don't have this version... is this the full address?

If you originally downloaded Kodi from TVAddons then that is a modified version of Kodi and we are unable to assist you. You will need to contact TVAddons for assistance.


What is %appdata%
It is a shortcut to navigate to the userdata folder. To access it, follow these steps...

1. Right click on the Start Button (bottom left of the screen)
2. Select “Run”
3. Type %appdata% and press OK
4. Windows Explorer will open in the Roaming folder, then continue navigating to Addons27.db as explained in the previous section.


I found Addons27.db and deleted it. Now what?
Great. Now that it is deleted, you can exit out of Windows Explorer and start Kodi as you normally would. In most cases, if you have followed these directions, the issue will have been resolved.


I followed the instructions and Kodi still won’t start.

Now you will need to create a thread explaining the problem. Please read the following links to familiarise yourself on posting about a problem...
http://forum.kodi.tv/showthread.php?tid=42708

Team-Kodi.
Reply
#3
What we actually need are examples of addons27.db plus the previous version (addons20.db or whatever) and a debug log (wiki) stored and uploaded to a suitable cloud storage site and a link offered so that we can analyse them towards actually fixing the problem. By all means delete them from the local device afterwards to implement the fix (where it works), but we would like to understand and solve the problem as well Wink
|Banned add-ons (wiki) Forum rules (wiki)|VPN policy (wiki)|First time user (wiki)|FAQs (wiki) Troubleshooting (wiki)|Add-ons (wiki)|Free content (wiki)|Debug Log (wiki)|

My Blog Posts
Reply
#4
Ok. By "examples" you mean that you need a copy of both those files sent to you from someone having those problems?

Out of curiosity, does the team yet know what caused the problem?
Reply
#5
Made available rather than sent, but yes.

As of yet despite all the reports and all the requests for them, to my knowledge we haven't had many (or perhaps even any) examples made available so we can actually troubleshoot what's going wrong. Hence the request (again) for material to work with, as none of us are suffering this issue ourselves so we can't get it first-hand.
|Banned add-ons (wiki) Forum rules (wiki)|VPN policy (wiki)|First time user (wiki)|FAQs (wiki) Troubleshooting (wiki)|Add-ons (wiki)|Free content (wiki)|Debug Log (wiki)|

My Blog Posts
Reply
#6
(2017-04-06, 08:33)DarrenHill Wrote: What we actually need are examples of addons27.db plus the previous version (addons20.db or whatever) and a debug log (wiki) stored and uploaded to a suitable cloud storage site and a link offered so that we can analyse them towards actually fixing the problem. By all means delete them from the local device afterwards to implement the fix (where it works), but we would like to understand and solve the problem as well Wink

(2017-04-06, 09:19)DarrenHill Wrote: Made available rather than sent, but yes.

As of yet despite all the reports and all the requests for them, to my knowledge we haven't had many (or perhaps even any) examples made available so we can actually troubleshoot what's going wrong. Hence the request (again) for material to work with, as none of us are suffering this issue ourselves so we can't get it first-hand.

Will probably be a tricky one to fix!

Just try 10 times to migrate from 16.1 to 17.1 on windows with portable mode and each time the db conversion works flawlessly

Hope we will be able to catch someone who have this issue and did not delete the db file already...
Moanbag is in da place!
Reply



Logout Mark Read Team Forum Stats Members Help
Kodi v17 or 17.1 won’t launch...Help0
This forum uses Lukasz Tkacz MyBB addons.