v17 Unable to use any addons to download subtitles
Hi there !

Since a few days ago, I have been unable to use any addons from the official Kodi repository to download subtitles. Everytime I try to load a subtitle after a search on any addons, I receive the message "Failed to load the subtitle".

The problem appeared suddenly, and I can not figure out why or how it's happening since searching and downloading subtitles worked for me just a few days ago. I tried fixing the problem by moving the default location from next to the video (.strm) file, to another folder.

Here's the log: https://pastebin.com/rdZpv76C

14:32:01.401 is where the first failure to load the subtitle happens

Please tell me if there's anything else that could be of help, thanks !
Looks to be a storage permissions issue. I've seen this before with Android 6.x where the permissions seem to stop working, especially if you're using adopted storage.

Unfortunately there's not really any single way to fix it, if that's the case, other than doing a factory reset.

You can try using a file explorer and writing a file to the same location to see if spits out a error or change the location where the files are written, like /storage/emulated/0/Movies/. Also, make sure that you still have enough free storage space, even almost full can cause issues.

Forum Rules (wiki) | Banned add-ons (wiki) | Wiki (wiki) | Quick start guide (wiki)
Thank you ! I will try that tonight and come back with the results.

I do think that I've been able to save files on my devices recently, so it would be weird if Kodi was the only app that wasn't able to write files. I'll try to look into the permissions of the file system and for the app itself
After a few minutes of testing, it seems like all the folders where I've been trying to write the subtitles have the right sets of permissions that would should allow Kodi to download the subtitles, so you might be right that something iffy is happening with Kodi's permissions. I tried disabling and re enabling its permissions through the Android settings, but that did not seem to have any impact.

So you're saying that there might not be a way to fix this issue in my case and that a factory reset might be the only way? Ouch. I guess I'll have to look into that. But if you have any ideas or other suggestions I would love to hear them, as making a factory reset is a pretty decent deal.

By the way, I am running Android 6.0.1 on my box, if that's any help.
The easiest way to test Kodi is through it's built in file manager and see if you can manually copy files into the same location using it.

As for doing a factory reset, I don't know if it will fix your issue or not. I haven't had this issue crop up on any of my devices, but I have seen others have the same issue where write permissions will suddenly stop working on Android 6 & 7 and the only thing that fixed it for them was a factory reset.

But there could be any number of reasons that the .srt file isn't being written to your selected folder. A logcat might reveal more.

Forum Rules (wiki) | Banned add-ons (wiki) | Wiki (wiki) | Quick start guide (wiki)
Ahahah I was a little too hot headed. I actually ended up doing a factory reset before you answered, and it turns out that it didn't fix the subtitle problem either :p

I just tried what you said with the file manager. I am able to copy and paste files with Kodi to and from all the folders that I tried.
Ha! Well, at least now you have a fresh system and know that it won't solve the issue. Wink

If you're able to copy the files with Kodi's file manager, then the issue isn't specific to Kodi. Either there is an issue with the Subtitle add-on or there could be an issue with the .srt file that you downloaded.

I would post your issue in the Subtitle sub-form (actually I'm going to move this thread there for you so you don't have to repost) and/or contact the add-on author, I don't have your debug log up now but I think I remember you were using BS.Player.

You should also try a different Subtitle add-on and see if you are getting the same issue.

Moved to Subtitles.

Forum Rules (wiki) | Banned add-ons (wiki) | Wiki (wiki) | Quick start guide (wiki)
Thank you for moving the thread!

The teeny tiny problem is that this issue is manifesting on all subtitle add-ons I've tried. Subscene, OpenSubtitle, and BSPlayer. I tried saying that in the first post but maybe it didn't really come across. I'm not a native English speaker but I'm trying my best :p

In the first debug log, I try three times with the three different add-ons to use them to get subtitles, but each time it fails. All of those times are in the debug log.

I tried again with the clean install, and the issue is the same with those add-ons. I'll try with others to see if they work
Yeah, as I said I didn't have the debug log up and could only remember seeing BSPlayer. My memory isn't what it use to be, not that it was that great before.Big Grin

Anyway, your in the right part of the forum now where someone who might have better advice for you will see it.

Forum Rules (wiki) | Banned add-ons (wiki) | Wiki (wiki) | Quick start guide (wiki)
Thanks again for the help! I hope somebody here has an idea about my issue
Hi, same problem here since I upgraded my Linux box running kodi 17.0 to 17.1.

Any subtitle add-on I try to download a new subtitle freezes kodi. Sometimes it ends up crashing, other ones I have to manually restart the process. I can attach a debug file, but everything seems to go fine until it reaches a point like the following one (for the Subscene subtitle add-on):

22:45:12.021 T:139828293228288 DEBUG: ### [SubsceneUtilities] 0.030576 - Getting url: https://subscene.com/subtitles/title?q=Fences&r=true

Everything else seems to work OK in this box. Any ideas?

On second thought, here you have the crash log: https://pastebin.com/k6Hpbzn7

As you can see, something is wrong with python+urllib2+libssl...
OTOH, python properly executes this equivalent code in the interpreter:

[email protected]:~$ python
Python 2.7.12 (default, Nov 19 2016, 06:48:10)
[GCC 5.4.0 20160609] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import urllib2
>>> request = urllib2.Request('https://subscene.com/subtitles/title?q=Fences&r=true')
>>> request.add_header('Accept-encoding', 'gzip')
>>> request.add_header('User-Agent', 'Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:41.0) Gecko/20100101 Firefox/41.0')
>>> response = urllib2.urlopen(request)
>>> response.get_data()

So the problem seems linked to kodi invoking the add-ons through its CPythonInvoker.
OK, after checking a few more posts I found this is a known issue around add-ons using cryptography (for example, to access an https url), and [SOLVED] the problem with my Linux box by updating the python cryptography module as suggested in this thread: 2525622 (post)
I just found out what was causing the issue, and I feel pretty stupid not having looked into that earlier. I am using the Onedrive for Kodi add-on, and it seems to be the issue for the failure of the subtitles, even if the subutitles are specifically set to download in a local folder.

I did not have any local video files at all, so it never occured to me to try offline, but I tried today to download and play Big Buck Bunny to see if subtitles could be downloaded while playing a local movie, and it worked.

I am going to go to the add-on's thread and try there to see if the problem can be solved. Thank you for your help !
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
Unable to use any addons to download subtitles00