[Kodi 17 Krypton] Have to change video refresh rate back and forth to get HDMI audio working

I'm trying to set up a new NUC with Kodi and I keep running into a rather strange HDMI audio problem.

The problem is that when I start Kodi, whether it is from command line or on startup, the audio over HDMI does not work, it is completely silent.

Now, I have found one workaround that work, but I have to do it every time I start Kodi:
  1. Go into System settings/Audio
  2. Change Audio output device to something else (does not seem to matter which)
  3. Change it back to the correct value (In my case "HDA Intel PCH, SAM SAMSUNG on HDMI #0")
  4. Go to Display settings
  5. Change Refresh rate from the default 60 to 30 (might work with other values, not sure).
  6. Change it back to 60 (or simply answer 'no' to the question to persist the change
  7. Now audio is working perfectly

Strangely enough it is not enough to simply do one of the above steps, I actually have to change BOTH the audio output device and the video refresh rate back and forth for it to start working. And as soon as I close kodi and start it again, I have to redo it. I run kodi as a systemd service if that makes any difference (so starting and stopping with systemctl stop kodi). Here is the guide I used to set it up with Fedora, for reference http://kodi.wiki/view/HOW-TO:Install_Kod...n_packages.

I have tried three different reinstalls with different linux systems now, all with exactly the same problem and workaround: Fedora 25, LibreElec 8.0.1 and Ubuntu 17.04. Right now I'm on the last of the three, but I don't really mind which linux flavour I end up using if one seems more stable than others.

I'm attaching the debug log from kodi start to having completed the steps above (the menu sounds are enabled so I notice immediately when the sound starts working).

System information:
System: Intel NUC7i3BNK
TV: Samsung UE46F5005XXE (HDMI 1.3)
Kodi version: 17.1

Debug log:

Any ideas? I've been trying to go through the debug log to understand what changes after having gone through the workaround steps, but as far as I can see it does open the correct output device both on kodi start and in the end of the log, and all of the ALSA sink stuff looks identical...

If it wasn't working at all then I would be posting at the Intel site, but seeing as I found a workaround that I have to redo every time kodi is restarted and not just on boot it starts feeling like it might be a Kodi issue...

No ideas at all?
Make sure sync playback to display is uncheckedin 17.1

It can cause some audio issues but not sure to what extent.
Hi Derek and thanks for answering.

Unfortunately 'Sync playback to display' is already unchecked. Also note that the problem also includes the interface sounds, not only playback audio.
ah sorry bud was hoping it was a simple one with what you mentioned.

Im sure someone with more expertise and knowlege of audio/fedora can help, how come you chose that flavour of linux? (Just interested).
I started off with Fedora just out of curiosity tbh, I hadn't tried it out before. I run Debian and Ubuntu on my other machines and was curious to try something new.

As I wrote in the post I went back to Ubuntu after getting this problem in though, just hoping that it was a problem with only that distribution, but no such luck. Since I get the same problem in both fedora and Ubuntu (not to mention LibreElec that l tried in between) I was hoping that it would be a well-known problem, but apparently not.
Ah so prob. to do with your hardware then, anything unusual? Never seen this problem before, i take it jarvis was fine?

Oh i just noticed something :

Starting Kodi from Debian (17.1 Debian package version: 2:17.1+dfsg1-1)

Use the Kodi PPA from the wiki thats your problem no doubt - Never use an unofficial build

Get rid of that version of Kodi then,

sudo apt-get install software-properties-common
sudo add-apt-repository ppa:team-xbmc/ppa
sudo apt-get update
sudo apt-get install kodi
It's the new Intel NUC (http://www.intel.com/content/www/us/en/n...i3bnk.html) which I figured should be relatively common as a kodi media center. So I think you're right, or at least that kodi and the hardware not playing well together. Since it does start working after doing that display rate reset, and it continues working after for example a suspend (it's only on kodi start that I have to go through the workaround).

I am using the kodi ppa, so that is unfortunately also a dead end.

Any other ideas?
that log says otherwise though?

19:51:12.048 T:140668862300352 NOTICE: Starting Kodi from Debian (17.1 Debian package version: 2:17.1+dfsg1-1). Platform: Linux x86 64-bit
19:51:12.048 T:140668862300352 NOTICE: Using Release Kodi from Debian x64 build
19:51:12.049 T:140668862300352 NOTICE: Kodi from Debian compiled from 2:17.1+dfsg1-1 by GCC 6.3.0 for Linux x86 64-bit version 4.10.8 (264712)
19:51:12.049 T:140668862300352 NOTICE: Running on Ubuntu 17.04, kernel: Linux x86 64-bit version 4.10.0-19-generic

Also the new ubuntu may cause problems
You are right, I never looked closer at the version actually being installed.

[email protected]:/home/user# apt-cache policy kodi
  Installed: 2:17.1+dfsg1-1
  Candidate: 2:17.1+dfsg1-1
  Version table:
*** 2:17.1+dfsg1-1 500
        500 http://se.archive.ubuntu.com/ubuntu zesty/universe amd64 Packages
        100 /var/lib/dpkg/status
     2:17.1~git20170325.1710-final-0zesty 500
        500 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu zesty/main amd64 Packages
        500 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu zesty/main i386 Packages

The PPA package seems to be broken for zesty though, it depends on packages that no longer exit. At least libbluray1 appears to have changed name to libbluray2, and I guess something similar has happened to libva-intel-vaapi-driver, see below.

[email protected]:/home/user# apt-get install kodi=2:17.1~git20170325.1710-final-0zesty kodi-bin=2:17.1~git20170325.1710-final-0zesty
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
kodi : Depends: libbluray1 but it is not installable
        Recommends: libva-intel-vaapi-driver but it is not installable
E: Unable to correct problems, you have held broken packages.

I will reinstall the system with an older ubuntu version and give it a try, just to rule things out.
try 16.10 ubuntu with 17.1 from the PPA works perfectly
Sorry for the late reply, work has taken a lot of time these past few days.

It works with Ubuntu 16.10!

Now when I start Kodi I immediately have the interface sound, and it works fine while playing video as well.
I noticed that if I change some of the audio settings, like turn Audio Passthrough on and off, then the audio disappears and I have to go through my workaround again to change display rate back and forth to get the audio back. But that I can live with, I don't go around changing the sound settings all that often.

Thanks a lot for your helpful suggestions!
remember you need to have sync playback to display disabled or unchecked to be able to use passthrough in 17.1.

Hope ive been of some help

best regards

fyi, I fixed the ubuntu 17.04 package in the stable PPA a few days ago
yeah but ive been having other problems non kodi related with 17.04 which is why i said might be better to leave alone?

Ive got it on a test PC and it dosent repond well and spits out lots of crashing doing day to day things.
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
Have to change video refresh rate back and forth to get HDMI audio working00