Thread Rating:
  • 0 Vote(s) - 0 Average
Linux - Kodi 17 something is wrong
#1
After having to reinstall kodi 17, (it asked for a password that I didn't have and after giving it the only two that were used on the client and server I figured I'd just reinstall and start afresh) No biggie really as I'd just installed it to check it out. I've mainly used Mythtv as my pvr but felt like a change.
So after purging the system of the kodi install and making sure all config files etc had been wiped I did a reboot and re-installed kodi using the same install method as the first time.
Though this time nothing worked.No kodi icon,
Code:
/usr/bin/kodi
didn't work.
Code:
/usr/bin/kodi-standalone
and got this error
Code:
/usr/bin/kodi-standalone: 45: /usr/bin/kodi-standalone: /usr/bin/kodi: not found
/usr/bin/kodi-standalone: 45: /usr/bin/kodi-standalone: /usr/bin/kodi: not found
/usr/bin/kodi-standalone: 45: /usr/bin/kodi-standalone: /usr/bin/kodi: not found
/usr/bin/kodi --standalone  has exited in an unclean state 3 times in the last 0 seconds.
Something is probably wrong

The client machine has a fresh install of Elementary that has been updated while installing the original kodi install and my second attempt.
Any help appreciated. thanks
BrianmBlacke
Reply
#2
debug log (wiki)
If I have helped you or increased your knowledge, click the 'thank user' button to give thanks :) (People with less than 20 posts won't see the "Thank you" button.)
Reply
#3
dpkg -l | grep kodi | pastenbinit

please
"Your most vocal users are not reflective of your userbase" J.M.
"Of course, they [XP Users and people with outdated hardware] need to tell the world about the kind of hero they are, and block innovation for everyone else because their decades old OS / hardware needs to work =p" nevcairiel (ffmpeg)
No Debug Log no issue.
Reply
#4
I installed the manual debug log file from the kodi wiki and then like an idiot I deleted the .log and .log.old files so that I could get a more recent debug report. But after trying to start kodi using <CODE>/usr/bin/kodi</CODE> -bash: /usr/bin/kodi: No such file or directory<CODE>/usr/bin/kodi-standalone</CODE> /usr/bin/kodi-standalone: 45: /usr/bin/kodi-standalone: /usr/bin/kodi: not found
/usr/bin/kodi-standalone: 45: /usr/bin/kodi-standalone: /usr/bin/kodi: not found
/usr/bin/kodi-standalone: 45: /usr/bin/kodi-standalone: /usr/bin/kodi: not found
/usr/bin/kodi --standalone has exited in an unclean state 3 times in the last 0 seconds.
Something is probably wrong
No debug report was generated. I'd like to keep at this to learn more about working with kodi but it's been a few weeks. So I'm going to delete everything that <CODE>find</CODE> turns up and start again.
Thanks for your replies
brianmblacke
Reply
#5
Please post what I asked for
"Your most vocal users are not reflective of your userbase" J.M.
"Of course, they [XP Users and people with outdated hardware] need to tell the world about the kind of hero they are, and block innovation for everyone else because their decades old OS / hardware needs to work =p" nevcairiel (ffmpeg)
No Debug Log no issue.
Reply
#6
pretty obvious that kodi is not installed
Reply
#7
Just want to make it ovious for the OP, too :-)
"Your most vocal users are not reflective of your userbase" J.M.
"Of course, they [XP Users and people with outdated hardware] need to tell the world about the kind of hero they are, and block innovation for everyone else because their decades old OS / hardware needs to work =p" nevcairiel (ffmpeg)
No Debug Log no issue.
Reply
#8
For reference to install kodi; those are the messages you'd expect if you didnt install kodi Smile

sudo apt install software-properties-common
sudo add-apt-repository ppa:team-xbmc/ppa
sudo apt update
sudo apt install kodi
Reply
#9
Is that so on the OS he uses?
If I have helped you or increased your knowledge, click the 'thank user' button to give thanks :) (People with less than 20 posts won't see the "Thank you" button.)
Reply
#10
It's Elementary according to the OP, if that's correct then yes it uses apt and PPA's.

Although I think you have to enable PPA's first they don't work out of the box.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Kodi 17 something is wrong00