Windows - Deinterlace-method not working properly?

  Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
satand Offline
Junior Member
Posts: 28
Joined: Apr 2017
Reputation: 0
Location: Austria
Post: #1
hello,

i have installed kodi 17.1 on my windows 10 HTPC (core i5 4670k, gigabyte b85, geforce gtx970) and i'm using dvbviewer recording service to watch TV with kodi. under settings/PVR&TV i have set the display refresh rate to 50 Hz according to a setup tutorial. a display refresh rate of 59,9 Hz is not working on my samsung TV.

but when i'm watching SD TV (mpeg2video, 720x576) the picture is jittering, especially the upper border of the screen and text/words are jittering ~1-2mm up and down on the screen. if i switch the deinterlacing method from DXVA to inactive (there are these two options only), the jittering is gone, but the picture quality is bad (you can see horizontal lines). i tried several video scaling methods but no change.

do you have an advice?
(This post was last modified: 2017-04-21 15:28 by satand.)
find quote
PatK Offline
Team-Kodi Member
Posts: 8,323
Joined: Mar 2010
Reputation: 202
Location: Canada
Post: #2
Have you tried software rendering? A proper debug log might show something, but the suspect is the video driver.

windows fresh start -> delete C:\Users\User Name\AppData\Roaming\Kodi First time user (wiki) Log file (wiki) Video management (wiki) Artwork (wiki) Supported hardware (wiki) Releases (wiki) Database versions (wiki) Skin features compatibility list (wiki) http://xbmc-skins.com
find quote
thunderK Offline
Junior Member
Posts: 9
Joined: Sep 2016
Reputation: 0
Post: #3
Hi Satand, I am experiencing the same issue with Kodi 17 on windows 10 and a nvidia geforce gtx960:
http://forum.kodi.tv/showthread.php?tid=291610
Two workarounds
1 disable DXVA2 hardware acceleration in the settings then all decoding and deinterlacing is done in software on the cpu.
But then the load on the cpu will be much higher.
2 go back to Kodi 16.1

Post a Debug Log so a Kodi developer can have a look at the issue.
find quote
satand Offline
Junior Member
Posts: 28
Joined: Apr 2017
Reputation: 0
Location: Austria
Post: #4
I disabled DXVA2 hardware acceleration but I do not get a smooth picture with activated deinterlacing. i thought my i5 @ 4,3ghz should be good enough?!?

deactivated deinterlacing results in bad picture quality...
find quote
thunderK Offline
Junior Member
Posts: 9
Joined: Sep 2016
Reputation: 0
Post: #5
The i5 4670K should be more than fast enough. Maybe it is another issue.
You could test with a different setting at player settings - videos - playback:
- adjust display refreshrate
- sync playback to display
find quote
satand Offline
Junior Member
Posts: 28
Joined: Apr 2017
Reputation: 0
Location: Austria
Post: #6
enabling "adjust display refreshrate" causes a completely broken picture on my tv. sync playback to display has no effect Sad
find quote
thunderK Offline
Junior Member
Posts: 9
Joined: Sep 2016
Reputation: 0
Post: #7
Hmm not good. No other ideas anymore atm. Sorry!
find quote
fritsch Offline
Team-Kodi Developer
Posts: 17,922
Joined: Aug 2011
Reputation: 557
Location: Stuttgart*
Post: #8
Can you try on Linux with e.g. LibreELEC? Want to rule out a driver issue.

"Your most vocal users are not reflective of your userbase" J.M.
"Of course, they [XP Users and people with outdated hardware] need to tell the world about the kind of hero they are, and block innovation for everyone else because their decades old OS / hardware needs to work =p" nevcairiel (ffmpeg)
No Debug Log no issue.
find quote
satand Offline
Junior Member
Posts: 28
Joined: Apr 2017
Reputation: 0
Location: Austria
Post: #9
@thunderK
thanks for your effort!

@fritsch
sorry, I'm not familiar with linux. can I do or try something else on windows? today I tried the latest nightly, but no change.
find quote
satand Offline
Junior Member
Posts: 28
Joined: Apr 2017
Reputation: 0
Location: Austria
Post: #10
today I tried to watch TV in dvbviewer and the picture has perfect quality on every channel. but in kodi the deinterlacing is not working properly.
find quote
Djewell Offline
Junior Member
Posts: 2
Joined: Apr 2017
Reputation: 0
Post: #11
I am having the same issue on a mygica atv586 box using fork Kodi. when watching videos the picture is jerky or studdering as some people have called it. I seen to use the deinterace-method but when I go to the menu option it is greyed out and not accessible. Everything worked fine with Kodi 16 but this is a bit of a mess now as nothing is watchable.
find quote
fritsch Offline
Team-Kodi Developer
Posts: 17,922
Joined: Aug 2011
Reputation: 557
Location: Stuttgart*
Post: #12
No you don't. Android is using a completely different infrastructure. Don't highjack other people's threads, please.

"Your most vocal users are not reflective of your userbase" J.M.
"Of course, they [XP Users and people with outdated hardware] need to tell the world about the kind of hero they are, and block innovation for everyone else because their decades old OS / hardware needs to work =p" nevcairiel (ffmpeg)
No Debug Log no issue.
find quote
wonderwomanfx Offline
Junior Member
Posts: 11
Joined: Apr 2017
Reputation: 0
Post: #13
I think from the sound of it I am having the same problem with my Nvidia 1060 on Windows 10 & Kodi 17.1, I need to switch De-interlacing/DXVA off to stop the picture juddering.
http://forum.kodi.tv/showthread.php?tid=312850
(This post was last modified: 2017-04-29 01:43 by wonderwomanfx.)
find quote
satand Offline
Junior Member
Posts: 28
Joined: Apr 2017
Reputation: 0
Location: Austria
Post: #14
yep, I think we are having the same problem...as many other nvidia users. but it seems to be a kodi problem because with dvbviewer pro and ffmpeg are no issues.
find quote
satand Offline
Junior Member
Posts: 28
Joined: Apr 2017
Reputation: 0
Location: Austria
Post: #15
The problem is still not solved. Any ideas?
find quote
Post Reply