Thread Rating:
  • 1 Vote(s) - 5 Average
Android - KODI 17.1 NON NEON FOR Tegra 2 and Android 4.0.3
#16
Android Version 4.1. SW/HW not work for amlogic.
Reply
#17
@tetramarreta
you are spot on it really seems to be a 4.4.4 rom problem on xoom
i tried with a 5.1 omnirom and it does work!
unfortunately any rom above 4.4.4 on xoom has other problems
are u sure MediaCodec is working on android 4 (what device are u using i guess its asus transformer?)
Reply
#18
(2017-05-04, 03:20)chon Wrote: Android Version 4.1. SW/HW not work for amlogic.
How to send the log?

Enviado de meu MotoG3 usando Tapatalk
Reply
#19
(2017-05-05, 10:21)andPS2 Wrote: @tetramarreta
you are spot on it really seems to be a 4.4.4 rom problem on xoom
i tried with a 5.1 omnirom and it does work!
unfortunately any rom above 4.4.4 on xoom has other problems
are u sure MediaCodec is working on android 4 (what device are u using i guess its asus transformer?)
I did not understand your question

Enviado de meu MotoG3 usando Tapatalk
Reply
#20
well my question is do you know any (non tegra) device where your special version of kodi works with hardware acceleration?
what device are u using to test - asus transformer tablet?
maybe the call MediaCodec doesnt work at all under 4.4.4?
Reply
#21
(2017-05-05, 14:01)andPS2 Wrote: well my question is do you know any (non tegra) device where your special version of kodi works with hardware acceleration?
what device are u using to test - asus transformer tablet?
maybe the call MediaCodec doesnt work at all under 4.4.4?

Yes, my phone is a G3 motorola with android 6.0 and it works.

I'm going to change the name since Team Kodi complained and I'm going to evaluate it, but you have to send me the log so I can understand what's going on.
Reply
#22
here is a log of "tetramarreta media center" 17.1 running on android 5.1 on xoom
https://paste.ubuntu.com/24516942/
seems like the MediaCodec call doesnt work either but it falls back to FactoryCodec which seems to work
but u are the expert...
take your time its not urgent as 16.1 still runs fine
Reply
#23
It's the log says where, I'll compare it with 16.1 to try to know what it is:
13: 16: 10,765 T: 1454926112 ERROR: CDVDVideoCodecAndroidMediaCodec :: Failed to create Android MediaCodec
13: 16: 10,765 T: 1454926112 DEBUG: FactoryCodec - Video: amc-h264 - Failed

I'm completing another work and then I come back to Kodi 17.1

Hugs
Reply
#24
Thank you for your effort.
Reply
#25
It won't be long until ... LOL
Reply
#26
aparently a security flaw was just discovered in kodi <17.3. Could you please update kodi to 17.3?
Reply
#27
Kodi 17.3 for non neon rename for KodiDroid

http://forum.kodi.tv/showthread.php?tid=315348
Reply



KODI 17.1 NON NEON FOR Tegra 2 and Android 4.0.351