android compiled on Mac OS issue

  Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
kraka40 Offline
Donor
Posts: 69
Joined: May 2014
Reputation: 3
Post: #16
Went back to compiling from kodi-android branch. Repaired the tools/zlib/configure file and compilation completed successfully. I'll look to next repair the configuration script so this isn't a hack in the future. I have yet to test the build, so might still be issues. more to come.
find quote
kraka40 Offline
Donor
Posts: 69
Joined: May 2014
Reputation: 3
Post: #17
spoke *wrote* too soon. cmakebuildsys failed. Looks like more digging to do ..

Code:
make -C tools/depends/target/cmakebuildsys
mkdir -p /Volumes/android-dev/kodi/kodi-android/build
cd /Volumes/android-dev/kodi/kodi-android/build; /Volumes/android-dev/kodi/kodi-depends/x86_64-darwin16.5.0-native/bin/cmake -DCMAKE_TOOLCHAIN_FILE=/Volumes/android-dev/kodi/kodi-depends/arm-linux-androideabi-android-21-debug/share/Toolchain.cmake -DCMAKE_INSTALL_PREFIX=/Volumes/android-dev/kodi/kodi-depends/arm-linux-androideabi-android-21-debug -DCMAKE_BUILD_TYPE=Debug -DENABLE_INTERNAL_CROSSGUID=OFF -DENABLE_INTERNAL_FFMPEG=OFF /Volumes/android-dev/kodi/kodi-android
-- Source directory: /Volumes/android-dev/kodi/kodi-android
-- Build directory: /Volumes/android-dev/kodi/kodi-android/build
-- Generator: Single-configuration: Debug (Unix Makefiles)
-- CMake Version: 3.6.2
-- System type: Android
-- Core system type: android
-- Platform:
-- CPU: armeabi-v7a, ARCH: arm
-- Cross-Compiling: TRUE
-- Execute build artefacts on host: FALSE
-- Depends based build: 1
-- Could not find hardware support for SSE (missing:  _SSE_TRUE _SSE_OK)
-- Could not find hardware support for SSE2 (missing:  _SSE2_TRUE _SSE2_OK)
-- Could not find hardware support for SSE3 (missing:  _SSE3_TRUE _SSE3_OK)
-- Could not find hardware support for SSSE3 (missing:  _SSSE3_TRUE _SSSE3_OK)
-- Could not find hardware support for SSE4.1 (missing:  _SSE41_TRUE _SSE41_OK)
-- Could not find hardware support for SSE4.2 (missing:  _SSE42_TRUE _SSE42_OK)
-- Could not find hardware support for AVX (missing:  _AVX_TRUE _AVX_OK)
-- Could not find hardware support for AVX2 (missing:  _AVX2_TRUE _AVX2_OK)
-- NEON optimization enabled
-- Could NOT find Alsa (missing:  ALSA_LIBRARY ALSA_INCLUDE_DIR)
-- Could NOT find Avahi (missing:  AVAHI_CLIENT_LIBRARY AVAHI_COMMON_LIBRARY AVAHI_CLIENT_INCLUDE_DIR AVAHI_COMMON_INCLUDE_DIR)
-- Could NOT find Bluetooth (missing:  BLUETOOTH_LIBRARY BLUETOOTH_INCLUDE_DIR)
-- Could NOT find CAP (missing:  CAP_LIBRARY)
-- Could NOT find CCache (missing:  CCACHE_PROGRAM)
-- Could NOT find DBus (missing:  DBUS_LIBRARY DBUS_INCLUDE_DIR DBUS_ARCH_INCLUDE_DIR)
-- Could NOT find LCMS2 (missing:  LCMS2_LIBRARY LCMS2_INCLUDE_DIR)
-- Could NOT find PulseAudio (missing:  PULSEAUDIO_LIBRARY PULSEAUDIO_MAINLOOP_LIBRARY PULSEAUDIO_INCLUDE_DIR) (Required is at least version "2.0.0")
-- Could NOT find UDEV (missing:  UDEV_LIBRARY UDEV_INCLUDE_DIR)
-- Could NOT find VAAPI (missing:  VAAPI_libva_LIBRARY VAAPI_libva-x11_LIBRARY VAAPI_libva-drm_LIBRARY VAAPI_INCLUDE_DIR) (Required is at least version "0.38.0")
-- Could NOT find VDPAU (missing:  VDPAU_LIBRARY VDPAU_INCLUDE_DIR)
-- Could NOT find LIBUSB (missing:  LIBUSB_LIBRARY LIBUSB_INCLUDE_DIR)
CMake Error at cmake/scripts/android/Macros.cmake:85 (string):
  string sub-command REPLACE requires at least four arguments.
Call Stack (most recent call first):
  cmake/scripts/common/Macros.cmake:333 (find_soname)
  CMakeLists.txt:180 (core_require_dyload_dep)


CMake Error at cmake/scripts/android/Macros.cmake:86 (string):
  string sub-command STRIP requires two arguments.
Call Stack (most recent call first):
  cmake/scripts/common/Macros.cmake:333 (find_soname)
  CMakeLists.txt:180 (core_require_dyload_dep)


CMake Error at cmake/scripts/android/Macros.cmake:93 (message):
  Could not find dynamically loadable library ASS
Call Stack (most recent call first):
  cmake/scripts/common/Macros.cmake:333 (find_soname)
  CMakeLists.txt:180 (core_require_dyload_dep)


-- Configuring incomplete, errors occurred!
See also "/Volumes/android-dev/kodi/kodi-android/build/CMakeFiles/CMakeOutput.log".
make: *** [all] Error 1

I'm beginning to this this is getting personal ..

Code:
Could not find dynamically loadable library ASS
find quote
Memphiz Offline
Kodi MVP
Posts: 16,097
Joined: Feb 2011
Reputation: 227
Location: germany
Post: #18
Man I fixed those Cmake errors already in my branch ... have you even looked at those commits?

https://github.com/Memphiz/xbmc/commits/osx_droid

You are wasting time by reinventing the wheel i already have done Wink

AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
find quote
Memphiz Offline
Kodi MVP
Posts: 16,097
Joined: Feb 2011
Reputation: 227
Location: germany
Post: #19
After changing or cherry-picking those cmake fixes you need to redo the bootstrap and configure commands in tools/depends and then the cmakebuildsys should run ...

AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
find quote
kraka40 Offline
Donor
Posts: 69
Joined: May 2014
Reputation: 3
Post: #20
Yep get it.. I haven't compared yet. Will do .. I was unable to get your branch compiled at all.. posts my config and version info .. could you share yours?


Sent from my iPhone (typie typie)
find quote
kraka40 Offline
Donor
Posts: 69
Joined: May 2014
Reputation: 3
Post: #21
(2017-04-28 07:46)Memphiz Wrote:  That --with-toolchain in your configure has to point to the toolchain ( /Volumes/android-dev/kodi/kodi-depends-osxdroid/arm-linux-androideabi-android-21 i think) start over from scratch again (git clean -xfd in kodi src dir will get the tree cleaned 100%)

ok will give this a shot, but thought the toolchain was supposed to point to the toolchain created directly from the ndk via make-standalone-toolchain.sh

my current target --with-toolchain=/Volumes/android-dev/android/android-21.12b was built from the 12b ndk

Code:
./make-standalone-toolchain.sh --system=darwin-x86_64 --ndk-dir=../../ --install-dir=/Volumes/android-dev/android/android-21.12b --platform=android-21 --toolchain=arm-linux-androideabi-4.9
find quote
kraka40 Offline
Donor
Posts: 69
Joined: May 2014
Reputation: 3
Post: #22
Makefile
8c8
< VERSION=0.19.8
---
> VERSION=0.18.2

gettext version 0.18.2 is not compiling for me correctly. Looks like gettext-runtime/gnulib-lib isn't bringing forward the langinfo.h

changing version and recompiling to see if this works.
find quote
kraka40 Offline
Donor
Posts: 69
Joined: May 2014
Reputation: 3
Post: #23
OK ... another update on this rambling post ..

1. I reset my build to the Krypton branch (not master) .. so now focused on 17.2
2. Compiling with ndk12b was successful with the one zlib Makefile change ( see https://github.com/xbmc/xbmc/pull/12032 )

@Memphiz .. I didn't need to implement your cmake changes with the Krypton build

Still no extensive testing of the actual apk file yet...
find quote
kraka40 Offline
Donor
Posts: 69
Joined: May 2014
Reputation: 3
Post: #24
kodiapp-armeabi-v7a-debug.apk: 1 file pushed. 1.4 MB/s (63242145 bytes in 42.437s)
pkg: /data/local/tmp/kodiapp-armeabi-v7a-debug.apk
Failure [INSTALL_FAILED_UPDATE_INCOMPATIBLE]


on a firetv ... more digging needed
find quote
chicovip123 Offline
Junior Member
Posts: 1
Joined: Apr 2017
Reputation: 0
Post: #25
very nice bro
find quote
kraka40 Offline
Donor
Posts: 69
Joined: May 2014
Reputation: 3
Post: #26
ok got the install to work .. had to remove the standard build. Now testing on firetv ... looks good so far.

two identical gen1 firetv boxes .. installed on one, not the other ...

identical install process, remove official package, adb install the debug build. for the main unit, no problem. For the other box,
Failure [INSTALL_FAILED_UPDATE_INCOMPATIBLE].

odd
(This post was last modified: 2017-04-30 22:38 by kraka40.)
find quote
kraka40 Offline
Donor
Posts: 69
Joined: May 2014
Reputation: 3
Post: #27
ok good news, got it installed .. only installed with one binary addon (pvr.mythtv). I'll recompile later with all to ensure they all work.

I had to manually uninstall the old package:org.xbmc.kodi from the other FTV box. For some reason it wasn't registering on an uninstall from the GUI.

I'll continue to test to confirm this works ( at least for me ) .. Hopefully this journey helps someone else. I'll summarize at some point.
find quote
kraka40 Offline
Donor
Posts: 69
Joined: May 2014
Reputation: 3
Post: #28
one change ..did go back and redo my patch for zlib ..
https://github.com/xbmc/xbmc/pull/12040

successfully passed testing
find quote
Memphiz Offline
Kodi MVP
Posts: 16,097
Joined: Feb 2011
Reputation: 227
Location: germany
Post: #29
We already provide CC dirctly - is there no way to continue that road (like i did in my branch?) - i have a bad feeling about that cross prefix - because we don't cross compile only (there is linux where we compile with native tools for example)

Sorry for being so strict - but that depends buildsystem is a bit tricky with all its platforms. And i still don't have a clue why my branch doesn't work for you when it works here with a vanilla mac os sierra installation ...

AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
(This post was last modified: 2017-05-02 08:04 by Memphiz.)
find quote
kraka40 Offline
Donor
Posts: 69
Joined: May 2014
Reputation: 3
Post: #30
(2017-05-02 08:02)Memphiz Wrote:  We already provide CC dirctly - is there no way to continue that road (like i did in my branch?) - i have a bad feeling about that cross prefix - because we don't cross compile only (there is linux where we compile with native tools for example)

Sorry for being so strict - but that depends buildsystem is a bit tricky with all its platforms. And i still don't have a clue why my branch doesn't work for you when it works here with a vanilla mac os sierra installation ...

I'll go back and redo your branch and see if I can figure it out. In reading through the configuration script, it doesn't look like zlib configuration is built to any strict standard. I agree CROSS_COMPILE does seem to be a bit of a hack, but works with the logic in the script at least as far as I can tell.

It did make it through jenkins Smile
find quote