Hifiberry Digi+ on Kodi 17.1
#1
Hi, everyone. My configuration was:
Raspberry Pi 3
Hifiberry DIGI+
Raspbian
Kodi 15.2

I have recently upgrade Kodi to version 17.1, but now it doesn't recognize the Hifiberry anymore. I can't enable passthrough audio.
Audio device options are:
PI: HDMI
PI: Analogue
PI: HDMI and Analogue
ALSA: Playback/recording through the PulseAduio sound server
ALSA: PulseAudio Sound Server

When Kodi 15.2 was installed the selected audio device was snd_rpi_hifiberry_digi S/PDIF.

Any ideas how to enable it in this new version of Kodi?

Thank you!
Reply
#2
Whats your kernel version?
Reply
#3
Configure pulseaudio externally or just remove it, things wil work like before.
Reply
#4
Make sure you have all Raspbian Jessie updates installed
Code:
sudo apt-get update
sudo apt-get dist-upgrade
sudo rpi-update
sudo reboot
(rpi-update is optional)

Passthrough on the Hifiberry Digi requires a proper Alsa configuration. The Alsa cards conf file was added some time ago in Raspbian. Without the updates you won't get passthrough in Kodi.

so long,

Hias
Reply
#5
(2017-04-24, 22:00)ileenback Wrote: Whats your kernel version?

Linux raspberrypi 4.4.50-v7+ #970 SMP Mon Feb 20 19:18:29 GMT 2017 armv7l GNU/Linux
Reply
#6
(2017-04-24, 22:01)rascas Wrote: Configure pulseaudio externally or just remove it, things wil work like before.

It worked.

Thank you!
Reply
#7
Hi, everyone. My configuration is:
Raspberry Pi 3
Hifiberry DIGI+
Openelec 8.0.3 which I just installed.

Openelec 8.0.3 has Kodi version 17.1 which doesn't recognize the Hifiberry Digi+ sound card
(aplay -l results in: aplay: device_list:270: no soundcards found...).

The only Kodi Audio device options are:
PI: HDMI
PI: Analogue
PI: HDMI and Analogue
PULSE: Default, Bluetooth Audio (PULSEAUDIO)

Could someone provide instructions concerning which programs to run or files to edit in order to remove pulseaudio?
Maybe this would solve the missing Hifiberry digi+ audio options problems.

Thank you!
Reply
#8
In general to use audio HATs you need to add a line to config.txt like:
Code:
dtoverlay=hifiberry-digi
Reply
#9
@popcornmix

Thank you for your answer,
but I already added that to /flash/config.txt (after remounting /flash as read/write :-)
Some suggested further adding dtoverlay=pi3-disable-bt and dtdebug=1 but that too does not help.

Further attempts which do not solve the problem were to add a file /storage/.config/modules-load.d/hifiberry.conf containing:
snd_soc_bcm2708_i2s
bcm2708_dmaengine
snd_soc_wm8804
snd_soc_hifiberry_digi
but this too did not help....

The one thing I have not yet managed to do is getting rid of pulseaudio in favour of ALSA...

Many Thanks!
Reply
#10
(2017-05-07, 16:05)EssefBeh Wrote: Openelec 8.0.3 has Kodi version 17.1 which doesn't recognize the Hifiberry Digi+ sound card
(aplay -l results in: aplay: device_list:270: no soundcards found...).
I haven't tested myself but from what I've read so far this issue seems to be specific to OpenELEC.

Could you test if this works with LibreELEC?
https://libreelec.tv/

so long,

Hias
Reply
#11
@Hias

Thank you for your answer.
I took me some time, but I have now installed LibreElec instead and (with "dtoverlay=hifiberry-digi" added to config.txt) the sound card appears, can be selected and works!

I was confused by OpenElec describing their version 8.0.3 as "stable" when in fact it appears to be the buggy "testing" version while LibreElec is "stable".
For a newcomer the relationship between LibreElec and OpenElec is somewhat unclear.
Reply
#12
I have exactly the same problem with the HifiBerry Digi with LibreElec: no sound coming from SP/DIF through ALSA

Some suggest to disable PulseAudio completely to get the digital out to work on the HifiBerry, but I cannot find the instructions on how to disable PulseAudio on LibreElec.
Can anyone help this pitiful noob?

Thanks
Peter


(2017-05-07, 16:05)EssefBeh Wrote: I haven't tested myself but from what I've read so far this issue seems to be specific to OpenELEC.

Could you test if this works with LibreELEC?
https://libreelec.tv/

so long,

Hias
Reply
#13
@SlimPvC

Did you carry out the suggestion in post #8 (i.e. adding the line dtoverlay=hifiberry-digi to the file config.txt)?
It is necessary.
The path to the file config.txt is /flash/config.txt and /flash is usually mounted as read-only, so you have to remount /flash as read/write to be able to edit /flash/config.txt


PS Something went wrong with your quote which combines my name with the text of HiassofT post at #10
Reply
#14
I should've mentioned that I added that line to config.txt. Instructions to do so were easy to find.
I can see the ALSA output in Kodi settings. and I can select them as output, but there's no sound from the optical or the coax output..
I only get sound through HDMI (which is standard RPi, not HifiBerry)



(2017-09-03, 14:13)EssefBeh Wrote: PS Something went wrong with your quote which combines my name with the text of HiassofT post at #10

Sorry for this mix-up
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Hifiberry Digi+ on Kodi 17.100
This forum uses Lukasz Tkacz MyBB addons.