•   
  • 1
  • 42
  • 43
  • 44
  • 45
  • 46(current)
Release -  YeeMee - (Control Yeelight Smart Bulb + Ambi from Kodi)
On the latest LibreElec an error, anything I'm doing wrong?

20:06:46.041 T:1598079904 WARNING: CPythonInvoker(23): Script invoked without an addon. Adding all addon modules installed to python path as fallback. This behaviour will be removed in future version.
20:06:46.848 T:1598079904   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.AttributeError'>
                                            Error Contents: 'module' object has no attribute 'system'
                                            Traceback (most recent call last):
                                              File "/storage/.kodi/addons/service.yeemee/discover.py", line 17, in <module>
                                                from standalone import RepeatedTimer, OverlayText
                                              File "/storage/.kodi/addons/service.yeemee/standalone.py", line 17, in <module>
                                                import requests
                                              File "/storage/.kodi/addons/script.module.requests/lib/requests/__init__.py", line 97, in <module>
                                                from . import utils
                                              File "/storage/.kodi/addons/script.module.requests/lib/requests/utils.py", line 42, in <module>
                                                if platform.system() == 'Windows':
                                            AttributeError: 'module' object has no attribute 'system'
                                            -->End of Python script error report<--
Reply
Can you post the whole log?
Kodi addons: Lanik repo
Reply
https://paste.ubuntu.com/p/VSgFxbrjWW/
Reply
Thanks, but I don't think that debugging was turned on - In Settings -> System -> Logging, toggle the Enable debug logging setting.
Kodi addons: Lanik repo
Reply
Just did a clean install to check if the problem persists, it didn't, so it's time for a new Kodi install for me, no biggy. Tnx for the support.
Reply
OK, cool Smile because the error was inside the dependency and I am not sure I can do anything about it Smile
Kodi addons: Lanik repo
Reply
v4.5
- Added support for White Bulb 2nd gen (ct_bulb)
- Language file format related changes
Kodi addons: Lanik repo
Reply
there is a bug with the bulbs V2 RGB not always starting.
most of the times i have to start the movie then stop the movie and then start the movie again in order for the bulbs to work.

feature question....
since i am using openhab and it accepts json requests to interact with different things in the house.... is it possible that we could have some json controllers so that they can use post parameters?
Reply
I do not know the ID of the new V2 color bulbs....
Kodi addons: Lanik repo
Reply
The bulbs also use JSON format for received commands, I am not sure I understand what exactly you want?
Kodi addons: Lanik repo
Reply
  •   
  • 1
  • 42
  • 43
  • 44
  • 45
  • 46(current)
 
Thread Rating:
  • 2 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
YeeMee - (Control Yeelight Smart Bulb + Ambi from Kodi)52