•   
  • 1
  • 6
  • 7
  • 8(current)
  • 9
  • 10
  • 16
  •   
Release Control Kodi with your Google Home
Hi,

I use VPN, how can I configure My IP etc. when I use VPN?
Reply
Hello RDoornek

That is more of a question for your VPN provider and their paid support. Kodi does not need a VPN to operate, so the use of one is seen as a 3rd party modification outside the scope of this forum. With this in mind, the developers here may be unable to assist you.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
anyone have any ideas? Thanks in advance
Reply
(2018-01-21, 08:00)sg1102 Wrote: Hi,
I need some help setting this up. I've been trying for a few days and I can't figure out what I'm doing wrong.

My setup:
1. Have glitch setup per instructions
2. Kodi is setup per instructions
3. Configured the router to forward the port
4. IFTTT is setup per instructions
Make a web request:
URL: https://leaf-xxxxx.glitch.me/playpause
METHOD: post
CONTENT TYPE: Application/json
BODY: {“token”:”token”}

Both the internal and external IP test work and Kodi pauses both times.

BUT, everytime I tell Google home to pause Kodi, I get the following error in IFTTT:
UNABLE TO MAKE A WEB REQUEST. YOUR SERVER RETURNED A 400

Any help would be great coz now I have a headache trying to get this to work and it's frustrating.
Anyone have any ideas? Thanks in advance
Reply
(2018-01-22, 15:49)sg1102 Wrote:
(2018-01-21, 08:00)sg1102 Wrote: Hi,
I need some help setting this up. I've been trying for a few days and I can't figure out what I'm doing wrong.

My setup:
1. Have glitch setup per instructions
2. Kodi is setup per instructions
3. Configured the router to forward the port
4. IFTTT is setup per instructions
Make a web request:
URL: https://leaf-xxxxx.glitch.me/playpause
METHOD: post
CONTENT TYPE: Application/json
BODY: {“token”:”token”}

Both the internal and external IP test work and Kodi pauses both times.

BUT, everytime I tell Google home to pause Kodi, I get the following error in IFTTT:
UNABLE TO MAKE A WEB REQUEST. YOUR SERVER RETURNED A 400

Any help would be great coz now I have a headache trying to get this to work and it's frustrating.
Anyone have any ideas? Thanks in advance 
I was able to figure out and fix the issue.
Reply
Hey guys, 

I am pretty new to this and I´m not quite able to set it up. 

I followed the instructions and if I say: "Ok google, play movie xyz" then google responses with " Ok, playing xyz" but nothing happens. I´ve tried it with the action "navigate to home" : 

YOUR_NODE_SERVER/navhome 

same story, it accepts the action, respond, but nothing happens. 

Any idea why ? The only point I can imagine is the portforwarding thing. This is what I did:

Service Name: HTTP(TCP:80)
External Start Port: 80
External End Port: 80
Internal Start Port: 80
Internal End Port: 80
Internal IP address: 192.168.0.13

Have I forwarded it ? 

Thanks guys
Reply
No one an idea ?
Reply
Hi folks. I'm having trouble getting Kodi to play a playlist.  It's a music playlist. I'm using this the phrase Kodi playlist $ and the URL is YOUR_NODE_SERVER/playercontrol?q={{TextField}}

Would this work better with the PlayMedia function than PlayerControl?
Reply
Thanks so much. I got this working in one devise. I have node server on synology nas. I configured send kodi box and followed the instructions- created two IFTT appliets

My Config file
 =9.0ptexports.kodiConfig = [
  {
      id
: 'kodi', // Give your main instance here any name you want
      // YOUR_KODI_PROTOCOL (http or https)
      kodiProtocol: 'http',
     
// YOUR_KODI_IP_ADDRESS
      kodiIp: '192.168.0.170',
     
// YOUR_KODI_PORT
      kodiPort: '8080',
     
// YOUR_KODI_USER_NAME
      kodiUser: 'xxx',
     
// YOUR_KODI_PASSWORD
      kodiPassword: 'yyy'
  },
     
// You can use this to specify additonal kodi installation, that you'd like to control.
      // For example alternate kodi destination 1:
  {
      id
: 'PLEX',
     
// YOUR_2ND_KODI_PROTOCOL (http or https)
      kodiProtocol: 'http',
     
// YOUR_2ND_KODI_IP_ADDRESS
      kodiIp: '192.168.0.171',
     
// YOUR_2ND_KODI_PORT
      kodiPort: '8080',
     
// YOUR_2ND_KODI_USER_NAME
      kodiUser: 'xxx',
     
// YOUR_2ND_KODI_PASSWORD
      kodiPassword: 'yyy'
  }
 
];
=11.0pt =11.0pt =11.0ptexports.globalConfig = {=11.0pt    // YOUR_CONNECTION_PASSWORD=11.0pt    authToken: 'mykey',=11.0pt    // YOUR_LOCAL_LISTENING_PORT=11.0pt    listenerPort: '8099',=11.0pt    // YOUR_YOUTUBE_API_KEY=11.0pt    youtubeKey: 'AnnIzaSyB_sE5gtNo_B2S1xR3UL8G9KnXUKXxGc6k'
I use the following in webhooks=12.0pt{"token":"mykey", "kodiid":"kodi"}=12.0pt{"token":"mykey, "kodiid":"PLEX"}
Please note I use same username and password in both kodi boxes "kodi" and "PLEX" and same token key in applets for "kodi" and "PLEX"

In IFTT applet in the IF side: what do you want to say has
kodi play movie $ in applet for kodi box "kodi" 
and
PLEX play movie $ in the applet done for kodi box "PLEX"

When I give command
Hey Gogle kodi play movie australia it work in "kodi" box
however when I say Hey Google PLEX play movie australia I get "unable to make web request. Your server returned a 500". This is is what is in IFTT log shows as error for not running the Plex applet

I am also confused as to the instructions you noted in your document to handle mutiple boxes
"Having one node server targeting both kodi instances. (Recommended when hosting yourself)
  1. The utilization of the kodi-hosts.config.js allows you to name your instances and target them individually.
    i.e. the phrase 
    Code:
    [b]living room kodi play[/b]...
     could target 
    Code:
    http://192.168.100.1:8080/playpause

    and the phrase 
    Code:
    [b]bedroom [size=large]kodi[/size] play[/b]...
     could target 
    Code:
    http://192.168.100.2:8080/playpause
    )."
becuase your id: living room" not "living room kodi" etc

and for local node js method you state 
"xample scan library If you normally would use a sentence like: 
Code:
"Hey Google, kodi scan library" --> Will start a full library scan
. For running this command on your second kodi instance, you could copy the applet, and change it to: 
Code:
"[font=Comic Sans MS,cursive][b]Hey Google, kodi scan library in the bedroom[/b][/font]"
.".

Are the above correct? It is confusing. could you please clarify how the voice command should be give to play a movie on my box named "kodi" and "PLEX". I belive that the name here is the name set in kodi application setting as the name for the kodi 

Thanks in advance
Reply
reposting due to it is picking up some formating characters

Thanks so much. I got this working in one devise. I have node server on synology nas. I configured send kodi box and followed the instructions- created two IFTT appliets

My Config file
exports.kodiConfig = [
  {
      id: 'kodi', // Give your main instance here any name you want
      // YOUR_KODI_PROTOCOL (http or https)
      kodiProtocol: 'http',
      // YOUR_KODI_IP_ADDRESS
      kodiIp: '192.168.0.170',
      // YOUR_KODI_PORT
      kodiPort: '8080',
      // YOUR_KODI_USER_NAME
      kodiUser: 'xxx',
      // YOUR_KODI_PASSWORD
      kodiPassword: 'yyy'
  },
      // You can use this to specify additonal kodi installation, that you'd like to control.
      // For example alternate kodi destination 1:
  {
      id: 'PLEX',
      // YOUR_2ND_KODI_PROTOCOL (http or https)
      kodiProtocol: 'http',
      // YOUR_2ND_KODI_IP_ADDRESS
      kodiIp: '192.168.0.171',
      // YOUR_2ND_KODI_PORT
      kodiPort: '8080',
      // YOUR_2ND_KODI_USER_NAME
      kodiUser: 'xxx',
      // YOUR_2ND_KODI_PASSWORD
      kodiPassword: 'yyy'
  }
 ];
  
exports.globalConfig = {
    // YOUR_CONNECTION_PASSWORD
    authToken: 'mykey',
    // YOUR_LOCAL_LISTENING_PORT
    listenerPort: '8099',
    // YOUR_YOUTUBE_API_KEY
    youtubeKey: 'AnnIzaSyB_sE5gtNo_B2S1xR3UL8G9KnXUKXxGc6k'

I use the following in webhooks
{"token":"mykey", "kodiid":"kodi"}
{"token":"mykey, "kodiid":"PLEX"}

Please note I use same username and password in both kodi boxes "kodi" and "PLEX" and same token key in applets for "kodi" and "PLEX"

In IFTT applet in the IF side: what do you want to say has
kodi play movie $ in applet for kodi box "kodi" 
and
PLEX play movie $ in the applet done for kodi box "PLEX"

When I give command
Hey Gogle kodi play movie australia it work in "kodi" box
however when I say Hey Google PLEX play movie australia I get "unable to make web request. Your server returned a 500". This is is what is in IFTT log shows as error for not running the Plex applet

I am also confused as to the instructions you noted in your document to handle mutiple boxes
"Having one node server targeting both kodi instances. (Recommended when hosting yourself)
1.    The utilization of the kodi-hosts.config.js allows you to name your instances and target them individually.
i.e. the phrase living room kodi play... could target http://192.168.100.1:8080/playpause
and the phrase bedroom kodi play... could target http://192.168.100.2:8080/playpause)."
becuase your id: living room" not "living room kodi" etc

and for local node js method you state 
"xample scan library If you normally would use a sentence like: "Hey Google, kodi scan library" --> Will start a full library scan. For running this command on your second kodi instance, you could copy the applet, and change it to: "Hey Google, kodi scan library in the bedroom".".

Are the above correct? It is confusing. could you please clarify how the voice command should be give to play a movie on my box named "kodi" and "PLEX". I belive that the name here is the name set in kodi application setting as the name for the kodi 

Thanks in advance
Reply
I did further testing on configuring two kodi boxes. As I cannot figure out why I am getting Unable to make web request. Your server returned a 500 everytime following the intructions.

Sp did the following
I changed my working  id: 'kodi', to id: "xmbc" in the kodi-hosts.config.js  and also changed the IFTT applet 
"Kodi plat movie $"----> "XMBC play movie $"
{"token":"mytoken for xmbc", "kodiid":"kodi"}-->{"token":"mytoken for xmbc", "kodiid":"xmbc"}

still I am getting Your server returned a 500. This means the application does not run other than for where id in config file is "kodi"

I believe there are changes to be done to config.js script to accomodate two kodi boxes.

Can someone please confirm
Reply
I have good news and I am thrilled after many days of struggling
The scripts as per the original instructions work for mutiple boxes. However becuase I made changed to config file several times etc and was eiditing existing IFTT applets created before it gave 500 and web request time out error in IFTT. The commands to issue are "OK google, kodi play movie x-men", "OK google, kodibedroom play movie australia" where kodi and kodibedroom are the id in kodi-host.config.js and "kodiid" in the IFTT. you could keep same username/passwords in all kodi boxes and same port and same "token". Not sure if you need to change kodi box name in kodi installation to reflect rge id in kodi-host.config.js but I do not think it is required though I did it

what need to be done or make sure is
a) each time you change the kodi-hosts.config.js you need to stop the server.js session, run "npm install" for config changes to make effect (if not done it would lead to authentication errors and not executing)
b) also create new applet in IFTT -sometimes editing existing applet and saving does not work (it result in timeout and applet failing)

I also had a issue and uninstalling node js application and installing it again, copying a fresh copy of googlehomekodi code and change the config and do npm install and then node ....../server.js did work

so i can confirma that no more changes are required to other files. Only change required is kodi-host.config.js and then in create new applets with the following format {"token":"mytoken", "kodiid":"kodi"}

I am commiting here in case someone try to add second box later will find it not working. The original instuctions does not talk about having to run npm insall with config file change 

please note that I am running local node server- method: =11ptB.2 Set up local webserver
Reply
I am running Kodi 17.6 on a HTPC and have been able to get the voice controls to work using the glitch option. However, it seems unbearably slow and makes the voice control less desirable compared to going for the remote. Is there a way to speed up the response between Kodi and Google Home? TIA for any assistance!
Reply
Hi, Does anyone know if this still works? I have followed the steps but cannot seem to connect to Kodi?
Reply
Yes. It does.
Reply
  •   
  • 1
  • 6
  • 7
  • 8(current)
  • 9
  • 10
  • 16
  •   



Logout Mark Read Team Forum Stats Members Help
Control Kodi with your Google Home4
This forum uses Lukasz Tkacz MyBB addons.