Thread Rating:
  • 0 Vote(s) - 0 Average
Kodi 18 - Picture Addons do not Work
#1
Has something significantly changed in the way web pictures are begin displayed using picture addons?

Locally stored pictures are displayed normally. However, for pictures derived from Addons, only thumbs and backdrops are created and displayed but the actual picture is not shown.

From the log it looks like Kodi is trying to display the chosen picture through the VideoPlayer.

Debug Log
Reply
#2
Can no one shed a light on this?
Reply
#3
i tried 500x and it worked fine for me for all images i tested. but i'm on latest master and linux so quite a bit of things are different.
Reply
#4
(2017-05-18, 12:39)ironic_monkey Wrote: i tried 500x and it worked fine for me for all images i tested. but i'm on latest master and linux so quite a bit of things are different.

Indeed they are. Must be the interaction with the underlying os then....

Installed latest master with the default settings on Windows 10 x64. Nothing shown. (but it also did not on Android)

Again videoplayer tries to render a picture:
Code:
439 T:4916  NOTICE: VideoPlayer: Opening: https://drscdn.500px.org/photo/212471369/m%3D900_k%3D1_a%3D1/2648819a466b486a4fc715057838ab6d
18:01:52.439 T:4916 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
18:01:52.456 T:4916   DEBUG: CCurlFile::GetMimeType - https://drscdn.500px.org/photo/212471369/m%3D900_k%3D1_a%3D1/2648819a466b486a4fc715057838ab6d -> image/jpeg
18:01:52.456 T:4916   ERROR: DXVA::CProcessorHD::IsFormatSupported: Unsupported format 104 for 1.
18:01:52.456 T:4916   ERROR: DXVA::CProcessorHD::IsFormatSupported: Unsupported format 105 for 1.
18:01:52.456 T:724   DEBUG: Thread VideoPlayer start, auto delete: false
18:01:52.456 T:724  NOTICE: Creating InputStream
18:01:52.457 T:724   DEBUG: CurlFile::Open(0B98EE50) https://drscdn.500px.org/photo/212471369/m%3D900_k%3D1_a%3D1/2648819a466b486a4fc715057838ab6d
18:01:52.468 T:724   DEBUG: CFileCache::Open - opening <photo/212471369/m%3D900_k%3D1_a%3D1/2648819a466b486a4fc715057838ab6d> using cache
18:01:52.469 T:724   DEBUG: CurlFile::Open(09209F60) https://drscdn.500px.org/photo/212471369/m%3D900_k%3D1_a%3D1/2648819a466b486a4fc715057838ab6d
18:01:52.526 T:724  NOTICE: Creating Demuxer
18:01:52.526 T:720   DEBUG: Thread FileCache start, auto delete: false
18:01:52.553 T:720    INFO: CFileCache::Process - Source read didn't return any data! Hit eof(?)
18:01:52.560 T:724   DEBUG: CDVDDemuxFFmpeg::Open - probing detected format [jpeg_pipe]
18:01:52.560 T:724   DEBUG: CDVDDemuxFFmpeg::Open - avformat_find_stream_info starting
18:01:52.562 T:724   DEBUG: CDVDDemuxFFmpeg::Open - av_find_stream_info finished
18:01:52.562 T:724    INFO: ffmpeg[2D4]: Input #0, jpeg_pipe, https://drscdn.500px.org/photo/212471369/m%3D900_k%3D1_a%3D1/2648819a466b486a4fc715057838ab6':
18:01:52.562 T:724    INFO: ffmpeg[2D4]:   Duration: N/A, bitrate: N/A
18:01:52.562 T:724    INFO: ffmpeg[2D4]:     Stream #0:0: Video: mjpeg, yuvj420p(pc, bt470bg/unknown/unknown), 600x900 [SAR 1:1 DAR 2:3], 25 tbr, 25 tbn, 25 tbc

Debug log for the devs: Log
Reply
#5
grgl. sorry!

i have an unusual git configuration for my kodi where master is not upstream master. confused myself. this is indeed broken, i'll track and fix.
Reply
#6
regression identified, https://github.com/xbmc/xbmc/pull/11998 do not have time to fix it right now as it's a bit involved it seems.
Reply
#7
Thanks, will be waiting for a fix...
Reply
#8
fixed in master / by https://github.com/xbmc/xbmc/pull/12137
Reply
#9
Yep, it's working. Thanks to all involved
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Picture Addons do not Work00